summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-26 20:50:43 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-26 20:50:43 +0100
commit479d7f175a213fd6c9d1f9f76972061e14180ee6 (patch)
treeb1f53cefeb6777e1b7d0d8b2e4ccf736972a7044 /meta
parent2498dd2f7dcb41154281dcedbca2b81d71bab331 (diff)
downloadopenembedded-core-479d7f175a213fd6c9d1f9f76972061e14180ee6.tar.gz
openembedded-core-479d7f175a213fd6c9d1f9f76972061e14180ee6.tar.bz2
openembedded-core-479d7f175a213fd6c9d1f9f76972061e14180ee6.tar.xz
openembedded-core-479d7f175a213fd6c9d1f9f76972061e14180ee6.zip
opkg-utils: Further missing files tweaks
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch29
-rw-r--r--meta/packages/opkg-utils/opkg-utils_svn.bb2
2 files changed, 21 insertions, 10 deletions
diff --git a/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
index 3eb2c9349..bafc2f6a1 100644
--- a/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
+++ b/meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
@@ -1,14 +1,7 @@
-If we're building an image and some package rebuilds while this is happening
-some package can be removed/added to the ipk deploy directory. The image will
-not depend on this package so we can safely ignore these cases rather than
-error out.
-
-RP - 26/8/09
-
Index: opkg-utils/opkg-make-index
===================================================================
--- opkg-utils.orig/opkg-make-index 2009-08-26 17:21:26.000000000 +0100
-+++ opkg-utils/opkg-make-index 2009-08-26 17:24:05.000000000 +0100
++++ opkg-utils/opkg-make-index 2009-08-26 20:49:52.000000000 +0100
@@ -96,6 +96,7 @@
files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
files.sort()
@@ -22,8 +15,26 @@ Index: opkg-utils/opkg-make-index
if opt_s:
print filename
+ except OSError:
-+ sys.stderr.write("Package %s disappeared on us!\n" % (filename,))
++ sys.stderr.write("Package %s disappeared on us!\n" % (filename))
+ continue
pkgsStampsFile = open(stamplist_filename, "w")
for f in pkgsStamps.keys():
+@@ -148,6 +152,7 @@
+ names = packages.packages.keys()
+ names.sort()
+ for name in names:
++ try:
+ pkg = packages.packages[name]
+ if locales_dir and pkg.depends:
+ depends = string.split(pkg.depends, ',')
+@@ -165,6 +170,9 @@
+ if (verbose):
+ sys.stderr.write("Writing info for package %s\n" % (pkg.package,))
+ print pkg
++ except OSError:
++ sys.stderr.write("Package %s disappeared on us!\n" % (name))
++ continue
+ if packages_filename:
+ sys.stdout.close()
+ sys.stdout = old_stdout
diff --git a/meta/packages/opkg-utils/opkg-utils_svn.bb b/meta/packages/opkg-utils/opkg-utils_svn.bb
index 53b208db1..a14150571 100644
--- a/meta/packages/opkg-utils/opkg-utils_svn.bb
+++ b/meta/packages/opkg-utils/opkg-utils_svn.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
LICENSE = "GPL"
RDEPENDS = "python"
RDEPENDS_virtclass-native = ""
-PR = "r4"
+PR = "r5"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
file://index-ignore-filenotfound.patch;patch=1"