summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-09-07 09:59:57 +0000
committerRichard Purdie <richard@openedhand.com>2008-09-07 09:59:57 +0000
commit4be407b4d92411c2963f31120d9b96a0231faf59 (patch)
treecbcf9561abdb9bd2fe455bd92a09683e5a84d1bb /meta
parent4a2e4c725da102fa17d6165943bebec79aea2ce9 (diff)
downloadopenembedded-core-4be407b4d92411c2963f31120d9b96a0231faf59.tar.gz
openembedded-core-4be407b4d92411c2963f31120d9b96a0231faf59.tar.bz2
openembedded-core-4be407b4d92411c2963f31120d9b96a0231faf59.tar.xz
openembedded-core-4be407b4d92411c2963f31120d9b96a0231faf59.zip
rpm: Handle PYTHONVER differently in EXTRA_OECONF to stop gettext/uclibc failures during parsing
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5152 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/rpm/rpm_4.4.2.3.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/meta/packages/rpm/rpm_4.4.2.3.bb b/meta/packages/rpm/rpm_4.4.2.3.bb
index 6718042f8..ef6087893 100644
--- a/meta/packages/rpm/rpm_4.4.2.3.bb
+++ b/meta/packages/rpm/rpm_4.4.2.3.bb
@@ -2,13 +2,15 @@ DESCRIPTION = "The RPM Package Manager."
HOMEPAGE = "http://rpm.org/"
LICENSE = "LGPL GPL"
DEPENDS = "zlib beecrypt file popt python"
-PR = "r7"
+PR = "r9"
SRC_URI = "http://www.rpm.org/releases/rpm-4.4.x/rpm-4.4.2.3.tar.gz \
file://external-tools.patch;patch=1 \
file://cross_libpaths.patch;patch=1 \
file://weakdeps.patch;patch=1;pnum=0 \
- file://tagsbackport.patch;patch=1;pnum=0"
+ file://tagsbackport.patch;patch=1;pnum=0 \
+ file://missingok.patch;patch=1;pnum=0 \
+ file://extcond.patch;patch=1;pnum=0"
inherit autotools gettext
@@ -16,9 +18,9 @@ S = "${WORKDIR}/rpm-${PV}"
acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
-EXTRA_OECONF = "--with-python=${PYTHONVER} \
- --with-python-incdir=${STAGING_INCDIR}/python${PYTHONVER} \
- --with-python-libdir=${STAGING_LIBDIR}/python${PYTHONVER} \
+EXTRA_OECONF = "--with-python=$PYTHONVER \
+ --with-python-incdir=${STAGING_INCDIR}/python$PYTHONVER \
+ --with-python-libdir=${STAGING_LIBDIR}/python$PYTHONVER \
--without-apidocs \
--without-selinux \
--without-lua \
@@ -97,4 +99,6 @@ def rpm_python_version(d):
if os.path.exists( "%s/python2.3" % staging_incdir ): return "2.3"
raise "No Python in STAGING_INCDIR. Forgot to build python/python-native?"
-PYTHONVER = "${@rpm_python_version(d)}"
+# Use a shell variable here since otherwise gettext trys to expand this at
+# parse time when it manipulates EXTRA_OECONF which fails
+export PYTHONVER = "${@rpm_python_version(d)}"