summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-01-10 11:22:45 +0000
committerRoss Burton <ross@openedhand.com>2008-01-10 11:22:45 +0000
commit6486e5ef30517ab8e664b270626a73198c67d049 (patch)
tree0e209291e7260becdd99e484c955618d3da1f92a /meta
parent07668faff4e407c23f9e5a2f4389e6b0dd9068b4 (diff)
downloadopenembedded-core-6486e5ef30517ab8e664b270626a73198c67d049.tar.gz
openembedded-core-6486e5ef30517ab8e664b270626a73198c67d049.tar.bz2
openembedded-core-6486e5ef30517ab8e664b270626a73198c67d049.tar.xz
openembedded-core-6486e5ef30517ab8e664b270626a73198c67d049.zip
libvorbis: use autotools_stage_all (fixing .la installation)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3449 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libvorbis/libvorbis_1.0.1.bb17
1 files changed, 4 insertions, 13 deletions
diff --git a/meta/packages/libvorbis/libvorbis_1.0.1.bb b/meta/packages/libvorbis/libvorbis_1.0.1.bb
index 8a2d17a0a..70f279403 100644
--- a/meta/packages/libvorbis/libvorbis_1.0.1.bb
+++ b/meta/packages/libvorbis/libvorbis_1.0.1.bb
@@ -4,12 +4,12 @@ DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
that is free of intellectual property restrictions. libvorbis \
is the main vorbis codec library."
LICENSE = "BSD"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.vorbis.com/files/${PV}/unix/libvorbis-${PV}.tar.gz \
-file://m4.patch;patch=1"
+ file://m4.patch;patch=1"
-inherit autotools pkgconfig
+inherit autotools pkgconfig
# vorbisfile.c reveals a problem in the gcc register spilling for the
# thumb instruction set...
@@ -19,14 +19,5 @@ EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
--with-ogg-includes=${STAGING_INCDIR}"
do_stage () {
- oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
- oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
- oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/vorbis
- install -m 0644 include/vorbis/vorbisenc.h \
- include/vorbis/vorbisfile.h \
- include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
+ autotools_stage_all
}