summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-25 21:08:16 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-25 21:08:16 +0000
commit85efc571d5da08e4af3e84eb63b6854148e7f105 (patch)
treecdbee8a81799093baf377e61f4c1d9617df0a56d /meta
parent15af82a09f33360ba365c0da9ead24d15959f985 (diff)
downloadopenembedded-core-85efc571d5da08e4af3e84eb63b6854148e7f105.tar.gz
openembedded-core-85efc571d5da08e4af3e84eb63b6854148e7f105.tar.bz2
openembedded-core-85efc571d5da08e4af3e84eb63b6854148e7f105.tar.xz
openembedded-core-85efc571d5da08e4af3e84eb63b6854148e7f105.zip
Move libtiff to meta from meta-extras
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5102 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libtiff/files/libtool2.patch19
-rw-r--r--meta/packages/libtiff/tiff_3.8.2.bb25
2 files changed, 44 insertions, 0 deletions
diff --git a/meta/packages/libtiff/files/libtool2.patch b/meta/packages/libtiff/files/libtool2.patch
new file mode 100644
index 000000000..8285be51d
--- /dev/null
+++ b/meta/packages/libtiff/files/libtool2.patch
@@ -0,0 +1,19 @@
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- tiff-3.8.2.orig/configure.ac
++++ tiff-3.8.2/configure.ac
+@@ -25,11 +25,11 @@ dnl OF THIS SOFTWARE.
+ dnl Process this file with autoconf to produce a configure script.
+
+ AC_PREREQ(2.59)
+ AC_INIT([LibTIFF Software], 3.8.2, [tiff@lists.maptools.org], tiff)
+ AC_CONFIG_AUX_DIR(config)
+-AC_CONFIG_MACRO_DIR(m4)
++dnl AC_CONFIG_MACRO_DIR(m4)
+ AC_LANG(C)
+
+ dnl Compute the canonical target-system type variable
+ AC_CANONICAL_TARGET
+
diff --git a/meta/packages/libtiff/tiff_3.8.2.bb b/meta/packages/libtiff/tiff_3.8.2.bb
new file mode 100644
index 000000000..e9a88ae58
--- /dev/null
+++ b/meta/packages/libtiff/tiff_3.8.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This software provides support for the Tag Image File Format (TIFF)"
+LICENSE = ""
+HOMEPAGE = "http://www.remotesensing.org/libtiff/"
+DEPENDS = "zlib jpeg lzo"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
+ file://libtool2.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C libtiff -a -so libtiff ${STAGING_LIBDIR}
+ oe_libinstall -C libtiff -a -so libtiffxx ${STAGING_LIBDIR}
+
+}
+
+PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiff-utils tiff-utils-dbg"
+FILES_tiffxx = "${libdir}/libtiffxx.so.*"
+FILES_tiffxx-dev = "${libdir}/libtiffxx.so ${libdir}/libtiffxx.*a"
+FILES_tiffxx-dbg += "${libdir}/.debug/libtiffxx.so*"
+FILES_tiff-utils = "${bindir}/*"
+FILES_tiff-utils-dbg += "${bindir}/.debug/"