summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-04 15:52:03 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-13 12:15:23 +0000
commit91a071b469e5e2bfad1eee6e5e648b4c7ae101f6 (patch)
tree7ee42f301590d5462397758ca86cb1346b9e34df /meta
parentbb4dfbf39bb18294f21d31d92663b0c6d9db1c0a (diff)
downloadopenembedded-core-91a071b469e5e2bfad1eee6e5e648b4c7ae101f6.tar.gz
openembedded-core-91a071b469e5e2bfad1eee6e5e648b4c7ae101f6.tar.bz2
openembedded-core-91a071b469e5e2bfad1eee6e5e648b4c7ae101f6.tar.xz
openembedded-core-91a071b469e5e2bfad1eee6e5e648b4c7ae101f6.zip
unzip: Convert to use BBCLASSEXTEND
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/unzip/unzip-native_552.bb8
-rw-r--r--meta/packages/unzip/unzip_552.bb4
2 files changed, 3 insertions, 9 deletions
diff --git a/meta/packages/unzip/unzip-native_552.bb b/meta/packages/unzip/unzip-native_552.bb
deleted file mode 100644
index 1d4b18cf4..000000000
--- a/meta/packages/unzip/unzip-native_552.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-SECTION = "console/utils"
-inherit native
-require unzip_${PV}.bb
-
-do_stage() {
- install -d ${STAGING_BINDIR}
- install unzip ${STAGING_BINDIR}
-}
diff --git a/meta/packages/unzip/unzip_552.bb b/meta/packages/unzip/unzip_552.bb
index 2f06e1b1c..84e4fd4a7 100644
--- a/meta/packages/unzip/unzip_552.bb
+++ b/meta/packages/unzip/unzip_552.bb
@@ -7,6 +7,7 @@ SRC_URI = "http://ftp.info-zip.org/pub/infozip/src/unzip${PV}.tar.gz"
S = "${WORKDIR}/unzip-5.52"
export LD = "${CC}"
+LD_virtclass-native = "${CC}"
do_compile() {
oe_runmake -f unix/Makefile generic
@@ -18,4 +19,5 @@ do_install() {
mv ${D}${prefix}/man/* ${D}${mandir}
}
-
+BBCLASSEXTEND = "native"
+NATIVE_INSTALL_WORKS = "1"