summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-04-25 13:43:34 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-04-25 13:43:34 +0000
commit9d0afeb9bde588bd4246466ad86f48111a40eb8f (patch)
tree47b1aecbb646eee659990ef6d236e1613402fb89 /meta
parent2445bb8a765ecdcc2386a60c9c8e876cff727ad2 (diff)
downloadopenembedded-core-9d0afeb9bde588bd4246466ad86f48111a40eb8f.tar.gz
openembedded-core-9d0afeb9bde588bd4246466ad86f48111a40eb8f.tar.bz2
openembedded-core-9d0afeb9bde588bd4246466ad86f48111a40eb8f.tar.xz
openembedded-core-9d0afeb9bde588bd4246466ad86f48111a40eb8f.zip
linux-nokia770: added gcc4.patch needed for gcc 4.1.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1559 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/linux/linux-nokia770-2.6.16-osso26/gcc4.patch34
-rw-r--r--meta/packages/linux/linux-nokia770_2.6.16-osso26.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/packages/linux/linux-nokia770-2.6.16-osso26/gcc4.patch b/meta/packages/linux/linux-nokia770-2.6.16-osso26/gcc4.patch
new file mode 100644
index 000000000..340d1d6db
--- /dev/null
+++ b/meta/packages/linux/linux-nokia770-2.6.16-osso26/gcc4.patch
@@ -0,0 +1,34 @@
+Index: kernel-source-2.6.16-2.6.16.rel/drivers/i2c/chips/tlv320aic23.c
+===================================================================
+--- kernel-source-2.6.16-2.6.16.rel.orig/drivers/i2c/chips/tlv320aic23.c 2007-04-14 15:15:39.000000000 +0200
++++ kernel-source-2.6.16-2.6.16.rel/drivers/i2c/chips/tlv320aic23.c 2007-04-14 15:16:33.000000000 +0200
+@@ -185,7 +185,7 @@
+ }
+
+ static struct i2c_driver aic23_driver = {
+- .driver {
++ .driver = {
+ .name = "OMAP+TLV320AIC23 codec",
+ },
+ .id = I2C_DRIVERID_MISC,
+Index: kernel-source-2.6.16-2.6.16.rel/drivers/usb/core/hub.c
+===================================================================
+--- kernel-source-2.6.16-2.6.16.rel.orig/drivers/usb/core/hub.c 2007-04-14 15:18:05.000000000 +0200
++++ kernel-source-2.6.16-2.6.16.rel/drivers/usb/core/hub.c 2007-04-14 15:22:38.000000000 +0200
+@@ -50,6 +50,7 @@
+ module_param (blinkenlights, bool, S_IRUGO);
+ MODULE_PARM_DESC (blinkenlights, "true to cycle leds on hubs");
+
++static int __usb_suspend_device (struct usb_device *udev, int port1);
+ /*
+ * As of 2.6.10 we introduce a new USB device initialization scheme which
+ * closely resembles the way Windows works. Hopefully it will be compatible
+@@ -1371,8 +1372,6 @@
+ * (Includes HNP test device.)
+ */
+ if (udev->bus->b_hnp_enable || udev->bus->is_b_host) {
+- static int __usb_suspend_device(struct usb_device *,
+- int port1);
+ err = __usb_suspend_device(udev, udev->bus->otg_port);
+ if (err < 0)
+ dev_dbg(&udev->dev, "HNP fail, %d\n", err);
diff --git a/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb b/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb
index fa7dc45ee..fb672b121 100644
--- a/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb
+++ b/meta/packages/linux/linux-nokia770_2.6.16-osso26.bb
@@ -1,9 +1,10 @@
SECTION = "kernel"
DESCRIPTION = "Linux kernel for Nokia 770"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://repository.maemo.org/pool/maemo2.1/free/source/k/kernel-source-2.6.16/kernel-source-2.6.16_2.6.16.rel-osso26.tar.gz \
+ file://gcc4.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/kernel-source-2.6.16-2.6.16.rel"