summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-02-02 16:21:56 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-02 16:21:56 +0000
commit9d225568d39da0fcff4410e354e7d08594c01ebd (patch)
tree6f9e37f7192926808e9d3a6fc17489a465f5bf92 /meta
parent18ba0bc495a737f765e4a6da70479ef4ec392d74 (diff)
downloadopenembedded-core-9d225568d39da0fcff4410e354e7d08594c01ebd.tar.gz
openembedded-core-9d225568d39da0fcff4410e354e7d08594c01ebd.tar.bz2
openembedded-core-9d225568d39da0fcff4410e354e7d08594c01ebd.tar.xz
openembedded-core-9d225568d39da0fcff4410e354e7d08594c01ebd.zip
kexec-tools: Fix synatx error with recent autoconf+automake
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/kexec/kexec-tools-1.101/configurefix.patch45
-rw-r--r--meta/packages/kexec/kexec-tools.inc3
-rw-r--r--meta/packages/kexec/kexec-tools_1.101.bb2
3 files changed, 48 insertions, 2 deletions
diff --git a/meta/packages/kexec/kexec-tools-1.101/configurefix.patch b/meta/packages/kexec/kexec-tools-1.101/configurefix.patch
new file mode 100644
index 000000000..60c55f08e
--- /dev/null
+++ b/meta/packages/kexec/kexec-tools-1.101/configurefix.patch
@@ -0,0 +1,45 @@
+Index: kexec-tools-1.101/configure.ac
+===================================================================
+--- kexec-tools-1.101.orig/configure.ac 2010-02-02 15:14:43.173906722 +0000
++++ kexec-tools-1.101/configure.ac 2010-02-02 15:15:07.623910565 +0000
+@@ -100,23 +100,23 @@
+ BUILD_CFLAGS='-O2 -Wall $(CPPFLAGS)'
+
+ dnl ---Sanity checks
+-if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]) fi
+-if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]) fi
+-if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]) fi
+-if test "$AS" = "no"; then AC_MSG_ERROR([as not found]) fi
+-if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]) fi
+-if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]) fi
+-
+-if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]) fi
+-if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]) fi
+-if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]) fi
+-if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]) fi
+-if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]) fi
+-if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]) fi
+-if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]) fi
+-if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]) fi
+-if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]) fi
+-if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]) fi
++if test "$CC" = "no"; then AC_MSG_ERROR([cc not found]); fi
++if test "$CPP" = "no"; then AC_MSG_ERROR([cpp not found]); fi
++if test "$LD" = "no"; then AC_MSG_ERROR([ld not found]); fi
++if test "$AS" = "no"; then AC_MSG_ERROR([as not found]); fi
++if test "$OBJCOPY" = "no"; then AC_MSG_ERROR([objcopy not found]); fi
++if test "$AR" = "no"; then AC_MSG_ERROR([ar not found]); fi
++
++if test "$MKDIR" = "no"; then AC_MSG_ERROR([ mkdir not found]); fi
++if test "$RM" = "no"; then AC_MSG_ERROR([ rm not found]); fi
++if test "$CP" = "no"; then AC_MSG_ERROR([ cp not found]); fi
++if test "$LN" = "no"; then AC_MSG_ERROR([ ln not found]); fi
++if test "$TAR" = "no"; then AC_MSG_ERROR([ tar not found]); fi
++if test "$RPM" = "no"; then AC_MSG_ERROR([ rpm not found]); fi
++if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]); fi
++if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]); fi
++if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]); fi
++if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]); fi
+
+ dnl ---Output variables...
+
diff --git a/meta/packages/kexec/kexec-tools.inc b/meta/packages/kexec/kexec-tools.inc
index 38919b3ff..8b8c70af6 100644
--- a/meta/packages/kexec/kexec-tools.inc
+++ b/meta/packages/kexec/kexec-tools.inc
@@ -12,4 +12,5 @@ COMPATIBLE_HOST = '(x86_64|i.86.*|arm.*)-(linux|freebsd.*)'
SRC_URI = "http://www.xmission.com/~ebiederm/files/kexec/kexec-tools-${PV}.tar.gz \
file://kexec-tools-arm.patch;patch=1 \
file://kexec-arm-atags.patch;patch=1 \
- file://recentheader.patch;patch=1"
+ file://recentheader.patch;patch=1 \
+ file://configurefix.patch;patch=1"
diff --git a/meta/packages/kexec/kexec-tools_1.101.bb b/meta/packages/kexec/kexec-tools_1.101.bb
index 17e8a41dc..949f22cf1 100644
--- a/meta/packages/kexec/kexec-tools_1.101.bb
+++ b/meta/packages/kexec/kexec-tools_1.101.bb
@@ -2,4 +2,4 @@ require kexec-tools.inc
export LDFLAGS = "-L${STAGING_LIBDIR}"
EXTRA_OECONF = " --with-zlib=yes"
-PR = "r7"
+PR = "r8"