summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@openedhand.com>2008-10-08 08:19:28 +0000
committerSamuel Ortiz <sameo@openedhand.com>2008-10-08 08:19:28 +0000
commitade5e7371c4f96f2f58940ff5950935b60443d61 (patch)
tree5dd3d342273b63edd5749423e9a7eeb14f41e2aa /meta
parentbfeacba18bad42aebaa6efbbf174be73a0b8ed72 (diff)
downloadopenembedded-core-ade5e7371c4f96f2f58940ff5950935b60443d61.tar.gz
openembedded-core-ade5e7371c4f96f2f58940ff5950935b60443d61.tar.bz2
openembedded-core-ade5e7371c4f96f2f58940ff5950935b60443d61.tar.xz
openembedded-core-ade5e7371c4f96f2f58940ff5950935b60443d61.zip
parted: Initial commit
This is needed for netbook install images. git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5443 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/parted/parted-1.8.8/syscalls.patch53
-rw-r--r--meta/packages/parted/parted_1.8.8.bb17
2 files changed, 70 insertions, 0 deletions
diff --git a/meta/packages/parted/parted-1.8.8/syscalls.patch b/meta/packages/parted/parted-1.8.8/syscalls.patch
new file mode 100644
index 000000000..042fc9769
--- /dev/null
+++ b/meta/packages/parted/parted-1.8.8/syscalls.patch
@@ -0,0 +1,53 @@
+---
+ libparted/arch/linux.c | 13 +++++++++++++
+ 1 file changed, 13 insertions(+)
+
+Index: parted-1.8.8/libparted/arch/linux.c
+===================================================================
+--- parted-1.8.8.orig/libparted/arch/linux.c 2007-08-09 20:47:57.000000000 +0200
++++ parted-1.8.8/libparted/arch/linux.c 2008-10-06 13:49:17.000000000 +0200
+@@ -18,6 +18,8 @@
+
+ #define PROC_DEVICES_BUFSIZ 16384
+
++#include <linux/version.h>
++
+ #include <config.h>
+
+ #include <parted/parted.h>
+@@ -1361,12 +1363,14 @@ linux_refresh_close (PedDevice* dev)
+
+ #if SIZEOF_OFF_T < 8
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,20)
+ static _syscall5(int,_llseek,
+ unsigned int, fd,
+ unsigned long, offset_high,
+ unsigned long, offset_low,
+ loff_t*, result,
+ unsigned int, origin)
++#endif
+
+ loff_t
+ llseek (unsigned int fd, loff_t offset, unsigned int whence)
+@@ -1374,11 +1378,20 @@ llseek (unsigned int fd, loff_t offset,
+ loff_t result;
+ int retval;
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,20)
+ retval = _llseek(fd,
+ ((unsigned long long)offset) >> 32,
+ ((unsigned long long)offset) & 0xffffffff,
+ &result,
+ whence);
++#else
++ retval = syscall(__NR__llseek, fd,
++ ((unsigned long long)offset) >> 32,
++ ((unsigned long long)offset) & 0xffffffff,
++ &result,
++ whence);
++#endif
++
+ return (retval==-1 ? (loff_t) retval : result);
+ }
+
diff --git a/meta/packages/parted/parted_1.8.8.bb b/meta/packages/parted/parted_1.8.8.bb
new file mode 100644
index 000000000..633a1006a
--- /dev/null
+++ b/meta/packages/parted/parted_1.8.8.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "parted, the GNU partition resizing program"
+HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
+LICENSE = "GPLv2"
+SECTION = "console/tools"
+DEPENDS = "readline e2fsprogs-libs"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
+ file://syscalls.patch;patch=1 "
+
+EXTRA_OECONF = "--disable-Werror gl_cv_ignore_unused_libraries=none"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}