summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-01-15 14:53:08 +0000
committerJoshua Lock <josh@linux.intel.com>2010-01-15 15:11:56 +0000
commitb0bda60d77f066fefb57a7b084a6a0d3eee2a6ee (patch)
treed6de741ab1e6cba3c06ed73fb780912473b773f6 /meta
parentdfe72318ede6097ca80e5de06908d10f3c5bb60f (diff)
downloadopenembedded-core-b0bda60d77f066fefb57a7b084a6a0d3eee2a6ee.tar.gz
openembedded-core-b0bda60d77f066fefb57a7b084a6a0d3eee2a6ee.tar.bz2
openembedded-core-b0bda60d77f066fefb57a7b084a6a0d3eee2a6ee.tar.xz
openembedded-core-b0bda60d77f066fefb57a7b084a6a0d3eee2a6ee.zip
qemu: build mips system support in qemu
Add mips to the target-list configuration option and add a dummygl for mips. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/qemu/qemu-git/fix-nogl.patch27
-rw-r--r--meta/packages/qemu/qemu_git.bb6
2 files changed, 30 insertions, 3 deletions
diff --git a/meta/packages/qemu/qemu-git/fix-nogl.patch b/meta/packages/qemu/qemu-git/fix-nogl.patch
index f1f9bcf00..6cb812f00 100644
--- a/meta/packages/qemu/qemu-git/fix-nogl.patch
+++ b/meta/packages/qemu/qemu-git/fix-nogl.patch
@@ -38,3 +38,30 @@ Index: git/target-arm/dummygl.c
+{
+
+}
+Index: git/target-mips/dummygl.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ git/target-mips/dummygl.c 2009-06-09 22:15:55.000000000 +0100
+@@ -0,0 +1,22 @@
++#include <string.h>
++#include <stdlib.h>
++#include <assert.h>
++#include <stdint.h>
++#include <X11/Xlib.h>
++#include <X11/Xutil.h>
++
++void opengl_exec_set_parent_window(Display* _dpy, Window _parent_window)
++{
++
++}
++
++void opengl_process_enable(void)
++{
++
++}
++
++
++void mem_opengl(uint64_t ptr)
++{
++
++}
diff --git a/meta/packages/qemu/qemu_git.bb b/meta/packages/qemu/qemu_git.bb
index c8383f4af..98fdc7c7d 100644
--- a/meta/packages/qemu/qemu_git.bb
+++ b/meta/packages/qemu/qemu_git.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
PV = "0.10.6+git${SRCREV}"
-PR = "r1"
+PR = "r2"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
@@ -18,7 +18,7 @@ SRC_URI = "\
S = "${WORKDIR}/git"
-EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu --disable-gfx-check"
+EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-gfx-check"
#EXTRA_OECONF += "--disable-sdl"
inherit autotools
@@ -31,6 +31,6 @@ do_configure() {
SRC_URI_append_virtclass-nativesdk = " file://glflags.patch;patch=1"
DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk qemugl-nativesdk"
RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
-EXTRA_OECONF_virtclass-nativesdk = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu --disable-vnc-tls --cc=${HOST_PREFIX}gcc"
+EXTRA_OECONF_virtclass-nativesdk = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-vnc-tls --cc=${HOST_PREFIX}gcc"
BBCLASSEXTEND = "native nativesdk"