summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-16 15:41:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-16 15:41:54 +0000
commitbb73b0edc546102a922c4b33e0eb0efd26265f9c (patch)
tree6084740f6d53be71b46aa3fa09c9d7e3986597db /meta
parent4f10a48b66b825737cbae2c3d35b63b39288bc13 (diff)
downloadopenembedded-core-bb73b0edc546102a922c4b33e0eb0efd26265f9c.tar.gz
openembedded-core-bb73b0edc546102a922c4b33e0eb0efd26265f9c.tar.bz2
openembedded-core-bb73b0edc546102a922c4b33e0eb0efd26265f9c.tar.xz
openembedded-core-bb73b0edc546102a922c4b33e0eb0efd26265f9c.zip
busybox: update 1.7.2 to 1.8.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3186 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/busybox/busybox-1.7.2/run_parts.c174
-rwxr-xr-xmeta/packages/busybox/busybox-1.8.1/busybox-mdev.sh (renamed from meta/packages/busybox/busybox-1.7.2/busybox-mdev.sh)0
-rw-r--r--meta/packages/busybox/busybox-1.8.1/defconfig (renamed from meta/packages/busybox/busybox-1.7.2/defconfig)0
-rw-r--r--meta/packages/busybox/busybox-1.8.1/udhcpscript.patch (renamed from meta/packages/busybox/busybox-1.7.2/udhcpscript.patch)0
-rw-r--r--meta/packages/busybox/busybox_1.8.1.bb (renamed from meta/packages/busybox/busybox_1.7.2.bb)12
5 files changed, 1 insertions, 185 deletions
diff --git a/meta/packages/busybox/busybox-1.7.2/run_parts.c b/meta/packages/busybox/busybox-1.7.2/run_parts.c
deleted file mode 100644
index 56f70c6ee..000000000
--- a/meta/packages/busybox/busybox-1.7.2/run_parts.c
+++ /dev/null
@@ -1,174 +0,0 @@
-/* vi: set sw=4 ts=4: */
-/*
- * Mini run-parts implementation for busybox
- *
- * Copyright (C) 2007 Bernhard Fischer
- *
- * Based on a older version that was in busybox which was 1k big..
- * Copyright (C) 2001 by Emanuele Aina <emanuele.aina@tiscali.it>
- *
- * Based on the Debian run-parts program, version 1.15
- * Copyright (C) 1996 Jeff Noxon <jeff@router.patch.net>,
- * Copyright (C) 1996-1999 Guy Maor <maor@debian.org>
- *
- *
- * Licensed under GPL v2 or later, see file LICENSE in this tarball for details.
- */
-
-/* This is my first attempt to write a program in C (well, this is my first
- * attempt to write a program! :-) . */
-
-/* This piece of code is heavily based on the original version of run-parts,
- * taken from debian-utils. I've only removed the long options and a the
- * report mode. As the original run-parts support only long options, I've
- * broken compatibility because the BusyBox policy doesn't allow them.
- * The supported options are:
- * -t test. Print the name of the files to be executed, without
- * execute them.
- * -a ARG argument. Pass ARG as an argument the program executed. It can
- * be repeated to pass multiple arguments.
- * -u MASK umask. Set the umask of the program executed to MASK.
- */
-
-#include <getopt.h>
-
-#include "libbb.h"
-
-struct globals {
- char **names;
- int cur;
- char *cmd[1];
-};
-#define G (*(struct globals*)&bb_common_bufsiz1)
-#define names (G.names)
-#define cur (G.cur )
-#define cmd (G.cmd )
-
-enum { NUM_CMD = (COMMON_BUFSIZE - sizeof(struct globals)) / sizeof(cmd[0]) };
-
-enum {
- RUN_PARTS_OPT_a = (1 << 0),
- RUN_PARTS_OPT_u = (1 << 1),
- RUN_PARTS_OPT_t = (1 << 2),
- RUN_PARTS_OPT_l = (1 << 3) * ENABLE_FEATURE_RUN_PARTS_FANCY,
-};
-
-#if ENABLE_FEATURE_RUN_PARTS_FANCY
-#define list_mode (option_mask32 & RUN_PARTS_OPT_l)
-#else
-#define list_mode 0
-#endif
-
-/* Is this a valid filename (upper/lower alpha, digits,
- * underscores, and hyphens only?)
- */
-static bool invalid_name(const char *c)
-{
- c = bb_basename(c);
-
- while (*c && (isalnum(*c) || *c == '_' || *c == '-'))
- c++;
-
- return *c; /* TRUE (!0) if terminating NUL is not reached */
-}
-
-static int bb_alphasort(const void *p1, const void *p2)
-{
- return strcmp(*(char **) p1, *(char **) p2);
-}
-
-static int act(const char *file, struct stat *statbuf, void *args, int depth)
-{
- if (depth == 1)
- return TRUE;
-
- if (depth == 2
- && ( !(statbuf->st_mode & (S_IFREG | S_IFLNK))
- || invalid_name(file)
- || (!list_mode && access(file, X_OK) != 0))
- ) {
- return SKIP;
- }
-
- names = xrealloc(names, (cur + 2) * sizeof(names[0]));
- names[cur++] = xstrdup(file);
- names[cur] = NULL;
-
- return TRUE;
-}
-
-#if ENABLE_FEATURE_RUN_PARTS_LONG_OPTIONS
-static const char runparts_longopts[] ALIGN1 =
- "arg\0" Required_argument "a"
- "umask\0" Required_argument "u"
- "test\0" No_argument "t"
-#if ENABLE_FEATURE_RUN_PARTS_FANCY
- "list\0" No_argument "l"
-//TODO: "reverse\0" No_argument "r"
-//TODO: "verbose\0" No_argument "v"
-#endif
- ;
-#endif
-
-int run_parts_main(int argc, char **argv);
-int run_parts_main(int argc, char **argv)
-{
- const char *umask_p = "22";
- llist_t *arg_list = NULL;
- unsigned n;
- int ret;
-
-#if ENABLE_FEATURE_RUN_PARTS_LONG_OPTIONS
- applet_long_options = runparts_longopts;
-#endif
- /* We require exactly one argument: the directory name */
- opt_complementary = "=1:a::";
- getopt32(argv, "a:u:t"USE_FEATURE_RUN_PARTS_FANCY("l"), &arg_list, &umask_p);
-
- umask(xstrtou_range(umask_p, 8, 0, 07777));
-
- n = 1;
- while (arg_list && n < NUM_CMD) {
- cmd[n] = arg_list->data;
- arg_list = arg_list->link;
- n++;
- }
- /* cmd[n] = NULL; - is already zeroed out */
-
- /* run-parts has to sort executables by name before running them */
-
- recursive_action(argv[optind],
- ACTION_RECURSE|ACTION_FOLLOWLINKS,
- act, /* file action */
- act, /* dir action */
- NULL, /* user data */
- 1 /* depth */
- );
-
- if (!names)
- return 0;
-
- qsort(names, cur, sizeof(char *), bb_alphasort);
-
- n = 0;
- while (1) {
- char *name = *names++;
- if (!name)
- break;
- if (option_mask32 & (RUN_PARTS_OPT_t | RUN_PARTS_OPT_l)) {
- puts(name);
- continue;
- }
- cmd[0] = name;
- ret = wait4pid(spawn(cmd));
- if (ret == 0)
- continue;
- n = 1;
- if (ret < 0)
- bb_perror_msg("failed to exec %s", name);
- else /* ret > 0 */
- bb_error_msg("%s exited with return code %d", name, ret);
- }
-
- return n;
-}
diff --git a/meta/packages/busybox/busybox-1.7.2/busybox-mdev.sh b/meta/packages/busybox/busybox-1.8.1/busybox-mdev.sh
index 9744322fa..9744322fa 100755
--- a/meta/packages/busybox/busybox-1.7.2/busybox-mdev.sh
+++ b/meta/packages/busybox/busybox-1.8.1/busybox-mdev.sh
diff --git a/meta/packages/busybox/busybox-1.7.2/defconfig b/meta/packages/busybox/busybox-1.8.1/defconfig
index 19cfafab2..19cfafab2 100644
--- a/meta/packages/busybox/busybox-1.7.2/defconfig
+++ b/meta/packages/busybox/busybox-1.8.1/defconfig
diff --git a/meta/packages/busybox/busybox-1.7.2/udhcpscript.patch b/meta/packages/busybox/busybox-1.8.1/udhcpscript.patch
index fc21d440c..fc21d440c 100644
--- a/meta/packages/busybox/busybox-1.7.2/udhcpscript.patch
+++ b/meta/packages/busybox/busybox-1.8.1/udhcpscript.patch
diff --git a/meta/packages/busybox/busybox_1.7.2.bb b/meta/packages/busybox/busybox_1.8.1.bb
index e446a19d9..0cd757cc9 100644
--- a/meta/packages/busybox/busybox_1.7.2.bb
+++ b/meta/packages/busybox/busybox_1.8.1.bb
@@ -15,21 +15,11 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
file://syslog.conf \
file://udhcpscript.patch;patch=1 \
file://umount.busybox \
- file://run_parts.c"
-
-
-SRC_URI += "http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-ash.patch;patch=1 \
- http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-iptun.patch;patch=1 \
- http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-logger.patch;patch=1 \
- http://busybox.net/downloads/fixes-1.7.2/busybox-1.7.2-tail.patch;patch=1 \
- file://defconfig"
+ file://defconfig"
EXTRA_OEMAKE_append = " V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
do_configure () {
- # default run-parts does not sort entries == X11 session broken
- install -m 0644 ${WORKDIR}/run_parts.c ${S}/debianutils/
-
install -m 0644 ${WORKDIR}/defconfig ${S}/.config
cml1_do_configure
}