summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-19 17:00:44 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-19 17:00:44 +0000
commitc3a4acb22d264e778014660f4944b544ab20de84 (patch)
treeb512c9a2f84ed830216f2c5f6fb9c70f89f20e9f /meta
parentab5c2b9ebbfb8acb9a459cfc0e9af2fc01e3e768 (diff)
downloadopenembedded-core-c3a4acb22d264e778014660f4944b544ab20de84.tar.gz
openembedded-core-c3a4acb22d264e778014660f4944b544ab20de84.tar.bz2
openembedded-core-c3a4acb22d264e778014660f4944b544ab20de84.tar.xz
openembedded-core-c3a4acb22d264e778014660f4944b544ab20de84.zip
libxslt: Upgrade to 1.1.22 with pkgconfig fixes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4073 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libxslt/files/destdir.patch10
-rw-r--r--meta/packages/libxslt/libxslt_1.1.20.bb44
-rw-r--r--meta/packages/libxslt/libxslt_1.1.22.bb23
3 files changed, 23 insertions, 54 deletions
diff --git a/meta/packages/libxslt/files/destdir.patch b/meta/packages/libxslt/files/destdir.patch
deleted file mode 100644
index 8df1b206b..000000000
--- a/meta/packages/libxslt/files/destdir.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: libxslt-1.1.17/libxslt/Makefile.am
-===================================================================
---- libxslt-1.1.17.orig/libxslt/Makefile.am 2005-10-02 11:25:21.000000000 +0200
-+++ libxslt-1.1.17/libxslt/Makefile.am 2006-09-29 23:13:35.000000000 +0200
-@@ -61,4 +61,4 @@
- @(cd ../xsltproc ; $(MAKE))
-
- install-exec-hook:
-- $(mkinstalldirs) "$(libdir)/libxslt-plugins"
-+ $(mkinstalldirs) "$(DESTDIR)$(libdir)/libxslt-plugins"
diff --git a/meta/packages/libxslt/libxslt_1.1.20.bb b/meta/packages/libxslt/libxslt_1.1.20.bb
deleted file mode 100644
index 6ec59f14b..000000000
--- a/meta/packages/libxslt/libxslt_1.1.20.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-DESCRIPTION = "GNOME XSLT library"
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "libxml2"
-LICENSE = "MIT"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/${PN}-${PV}.tar.gz"
-S = "${WORKDIR}/${PN}-${PV}"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
-
-xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
- keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
- templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
- xsltexports.h xsltutils.h"
-exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
-
-do_stage () {
- oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
- oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
-
- mkdir -p ${STAGING_INCDIR}/libxslt
- for i in ${xsltheaders}; do
- install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
- done
- mkdir -p ${STAGING_INCDIR}/libexslt
- for i in ${exsltheaders}; do
- install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
- done
-
- cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_DIR_HOST}${layout_prefix}," \
- -e "s,^exec_prefix=.*,exec_prefix=${STAGING_DIR_HOST}${layout_exec_prefix}," \
- -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
- -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xslt-config
- chmod a+rx ${STAGING_BINDIR_CROSS}/xslt-config
- install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
-}
-
-PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
-
-FILES_${PN}-dev += "${bindir}/xslt-config"
-FILES_${PN}-utils += "${bindir}"
diff --git a/meta/packages/libxslt/libxslt_1.1.22.bb b/meta/packages/libxslt/libxslt_1.1.22.bb
new file mode 100644
index 000000000..86fe70dff
--- /dev/null
+++ b/meta/packages/libxslt/libxslt_1.1.22.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz \
+ file://pkgconfig_fix.patch;patch=1"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"