summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-04-14 09:52:55 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-04-14 09:52:55 +0000
commitd12aa66245d694ff26676294fd19b5d69cb10f50 (patch)
treecd156fb775994f5ebf57dd6c35aaa19a9d880b2a /meta
parent0e55205d349e7b4b87df3a9c31dbc00caa9d235f (diff)
downloadopenembedded-core-d12aa66245d694ff26676294fd19b5d69cb10f50.tar.gz
openembedded-core-d12aa66245d694ff26676294fd19b5d69cb10f50.tar.bz2
openembedded-core-d12aa66245d694ff26676294fd19b5d69cb10f50.tar.xz
openembedded-core-d12aa66245d694ff26676294fd19b5d69cb10f50.zip
webkit: updated to r31859 and disabled SVG fonts
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4246 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/distro/poky.conf2
-rw-r--r--meta/packages/webkit/files/GNUmakefile.am4
-rwxr-xr-x[-rw-r--r--]meta/packages/webkit/files/autogen.sh0
-rw-r--r--meta/packages/webkit/files/configure.ac56
-rw-r--r--meta/packages/webkit/webkit-gtk_svn.bb3
5 files changed, 37 insertions, 28 deletions
diff --git a/meta/conf/distro/poky.conf b/meta/conf/distro/poky.conf
index 0dc851bfe..a88407f56 100644
--- a/meta/conf/distro/poky.conf
+++ b/meta/conf/distro/poky.conf
@@ -142,7 +142,7 @@ SRCREV_pn-gaku ?= "365"
SRCREV_pn-gypsy ?= "39"
SRCDATE_yaffs2-utils = "20071107"
SRCDATE_yaffs2-utils-native = "20071107"
-SRCREV_pn-webkit-gtk ?= "31467"
+SRCREV_pn-webkit-gtk ?= "31859"
SRCREV_pn-clipboard-manager ?= "14994"
SRCREV_pn-opkg ?= "4209"
SRCREV_pn-opkg-native ?= "4209"
diff --git a/meta/packages/webkit/files/GNUmakefile.am b/meta/packages/webkit/files/GNUmakefile.am
index 4cdd3dbfe..a0aefbf50 100644
--- a/meta/packages/webkit/files/GNUmakefile.am
+++ b/meta/packages/webkit/files/GNUmakefile.am
@@ -116,13 +116,13 @@ libJavaScriptCore_la_CXXFLAGS = \
$(global_cflags) \
$(GLOBALDEPS_CFLAGS) \
$(UNICODE_CFLAGS) \
- -fstrict-aliasing
+ -fno-strict-aliasing
libJavaScriptCore_la_CFLAGS = \
$(global_cflags) \
$(GLOBALDEPS_CFLAGS) \
$(UNICODE_CFLAGS) \
- -fstrict-aliasing
+ -fno-strict-aliasing
libJavaScriptCore_la_CPPFLAGS = \
$(global_cppflags) \
diff --git a/meta/packages/webkit/files/autogen.sh b/meta/packages/webkit/files/autogen.sh
index a929538d2..a929538d2 100644..100755
--- a/meta/packages/webkit/files/autogen.sh
+++ b/meta/packages/webkit/files/autogen.sh
diff --git a/meta/packages/webkit/files/configure.ac b/meta/packages/webkit/files/configure.ac
index 64f32dc68..3ab2baffb 100644
--- a/meta/packages/webkit/files/configure.ac
+++ b/meta/packages/webkit/files/configure.ac
@@ -263,11 +263,19 @@ AC_ARG_ENABLE(cross_document_messaging,
[],[enable_cross_document_messaging="yes"])
AC_MSG_RESULT([$enable_cross_document_messaging])
+# check whether to enable HTML5 client-side session and persitent storage support
+AC_MSG_CHECKING([whether to enable HTML5 client-side session and persistent storage support])
+AC_ARG_ENABLE(dom_storage,
+ AC_HELP_STRING([--enable-dom-storage],
+ [enable HTML5 client-side session and persistent storage support [default=no]]),
+ [],[enable_dom_storage="no"])
+AC_MSG_RESULT([$enable_dom_storage])
+
# check whether to build with database support
-AC_MSG_CHECKING([whether to enable HTML5 client-side storage support])
+AC_MSG_CHECKING([whether to enable HTML5 client-side database storage support])
AC_ARG_ENABLE(database,
AC_HELP_STRING([--enable-database],
- [enable HTML5 client-side storage support [default=yes]]),
+ [enable HTML5 client-side database storage support [default=yes]]),
[],[enable_database="yes"])
AC_MSG_RESULT([$enable_database])
@@ -498,6 +506,7 @@ AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
# WebKit feature conditionals
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"])
+AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
AM_CONDITIONAL([ENABLE_XPATH],[test "$enable_xpath" = "yes"])
@@ -526,27 +535,28 @@ echo "
WebKit was configured with the following options:
Build configuration:
- Enable debugging (slow) : $enable_debug
- Code coverage support : $enable_coverage
- Unicode backend : $unicode_backend
- HTTP backend : $with_http_backend
- Font backend : $with_font_backend
- Optimized memory allocator : $enable_fast_malloc
+ Enable debugging (slow) : $enable_debug
+ Code coverage support : $enable_coverage
+ Unicode backend : $unicode_backend
+ HTTP backend : $with_http_backend
+ Font backend : $with_font_backend
+ Optimized memory allocator : $enable_fast_malloc
Features:
- HTML5 cross-document messaging : $enable_cross_document_messaging
- HTML5 client-side storage support : $enable_database
- HTML5 video element support : $enable_video
- Icon database support : $enable_icon_database
- SVG support : $enable_svg
- SVG animation support : $enable_svg_animation
- SVG filters support : $enable_svg_filters
- SVG fonts support : $enable_svg_fonts
- SVG foreign object support : $enable_svg_foreign_object
- SVG as image support : $enable_svg_as_image
- SVG use element support : $enable_svg_use_element
- XPATH support : $enable_xpath
- XSLT support : $enable_xslt
+ HTML5 cross-document messaging : $enable_cross_document_messaging
+ HTML5 client-side session and persistent storage support : $enable_dom_storage
+ HTML5 client-side database storage support : $enable_database
+ HTML5 video element support : $enable_video
+ Icon database support : $enable_icon_database
+ SVG support : $enable_svg
+ SVG animation support : $enable_svg_animation
+ SVG filters support : $enable_svg_filters
+ SVG fonts support : $enable_svg_fonts
+ SVG foreign object support : $enable_svg_foreign_object
+ SVG as image support : $enable_svg_as_image
+ SVG use element support : $enable_svg_use_element
+ XPATH support : $enable_xpath
+ XSLT support : $enable_xslt
GTK+ configuration:
- GDK target : $with_target
- Hildon UI extensions : $with_hildon
+ GDK target : $with_target
+ Hildon UI extensions : $with_hildon
"
diff --git a/meta/packages/webkit/webkit-gtk_svn.bb b/meta/packages/webkit/webkit-gtk_svn.bb
index c7a49fdd2..2e7a0885c 100644
--- a/meta/packages/webkit/webkit-gtk_svn.bb
+++ b/meta/packages/webkit/webkit-gtk_svn.bb
@@ -4,7 +4,7 @@ SRCREV_FORMAT = "webcore-rwebkit"
# Yes, this is wrong...
PV = "0.1+svnr${SRCREV}"
-PR = "r4"
+PR = "r5"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -27,7 +27,6 @@ inherit autotools pkgconfig
EXTRA_OECONF = "\
--enable-debug=no \
--enable-svg \
- --enable-svg-fonts \
--enable-icon-database=yes \
"