summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-05-29 13:25:58 +0000
committerRoss Burton <ross@openedhand.com>2007-05-29 13:25:58 +0000
commitd2f5510b56e7f94be951a0f46e81b372e3214ed7 (patch)
tree3908cba2a557b5c1a8ecaeecd62f8c60043111b2 /meta
parent4df31383fccb716d14c94054502d72ba121e9738 (diff)
downloadopenembedded-core-d2f5510b56e7f94be951a0f46e81b372e3214ed7.tar.gz
openembedded-core-d2f5510b56e7f94be951a0f46e81b372e3214ed7.tar.bz2
openembedded-core-d2f5510b56e7f94be951a0f46e81b372e3214ed7.tar.xz
openembedded-core-d2f5510b56e7f94be951a0f46e81b372e3214ed7.zip
Upgrade Empathy, with hot no-libgnomeui patch
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1805 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/telepathy/empathy-0.1/no-gnome.diff39
-rw-r--r--meta/packages/telepathy/empathy-0.5/no-gnome.diff133
-rw-r--r--meta/packages/telepathy/empathy_0.1.bb17
-rw-r--r--meta/packages/telepathy/empathy_0.5.bb18
4 files changed, 151 insertions, 56 deletions
diff --git a/meta/packages/telepathy/empathy-0.1/no-gnome.diff b/meta/packages/telepathy/empathy-0.1/no-gnome.diff
deleted file mode 100644
index 4dd4a9635..000000000
--- a/meta/packages/telepathy/empathy-0.1/no-gnome.diff
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -ur empathy-0.1.orig/configure.ac empathy-0.1/configure.ac
---- empathy-0.1.orig/configure.ac 2007-04-25 23:05:40.000000000 +0100
-+++ empathy-0.1/configure.ac 2007-04-27 17:10:29.000000000 +0100
-@@ -39,12 +39,12 @@
-
- PKG_CHECK_MODULES(EMPATHY,
- [
-+ libxml-2.0
- glib-2.0 >= $GLIB_REQUIRED
- gobject-2.0
- gtk+-2.0 >= $GTK_REQUIRED
- gconf-2.0 >= $GCONF_REQUIRED
- libglade-2.0 >= $LIBGLADE_REQUIRED
-- libgnomeui-2.0
- libtelepathy >= $TELEPATHY_REQUIRED
- libmissioncontrol >= $MISSION_CONTROL_REQUIRED
- ])
-Only in empathy-0.1: configure.ac~
-diff -ur empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c empathy-0.1/libempathy-gtk/gossip-ui-utils.c
---- empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c 2007-04-25 23:05:40.000000000 +0100
-+++ empathy-0.1/libempathy-gtk/gossip-ui-utils.c 2007-04-27 17:06:48.000000000 +0100
-@@ -31,7 +31,6 @@
- #include <glib/gi18n.h>
- #include <gtk/gtk.h>
- #include <glade/glade.h>
--#include <libgnome/libgnome.h>
-
- #include <libmissioncontrol/mc-profile.h>
-
-@@ -1307,7 +1306,7 @@
- GError *error = NULL;
-
- real_url = fixup_url (url);
-- gnome_url_show (real_url, &error);
-+ g_warning ("TODO: gnome_url_show (real_url, &error);");
- if (error) {
- g_warning ("Couldn't show URL:'%s'", real_url);
- g_error_free (error);
-Only in empathy-0.1/libempathy-gtk: gossip-ui-utils.c~
diff --git a/meta/packages/telepathy/empathy-0.5/no-gnome.diff b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
new file mode 100644
index 000000000..3246c8789
--- /dev/null
+++ b/meta/packages/telepathy/empathy-0.5/no-gnome.diff
@@ -0,0 +1,133 @@
+Index: libempathy-gtk/gossip-ui-utils.c
+===================================================================
+--- libempathy-gtk/gossip-ui-utils.c (revision 99)
++++ libempathy-gtk/gossip-ui-utils.c (working copy)
+@@ -33,7 +33,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <libgnome/libgnome.h>
+
+ #include <libmissioncontrol/mc-profile.h>
+
+@@ -1283,7 +1282,7 @@
+ GError *error = NULL;
+
+ real_url = fixup_url (url);
+- gnome_url_show (real_url, &error);
++ g_warning ("TODO: gnome_url_show (real_url, &error);");
+ if (error) {
+ g_warning ("Couldn't show URL:'%s'", real_url);
+ g_error_free (error);
+Index: src/empathy-chat-main.c
+===================================================================
+--- src/empathy-chat-main.c (revision 99)
++++ src/empathy-chat-main.c (working copy)
+@@ -28,9 +28,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+
+-#include <libgnome/gnome-program.h>
+-#include <libgnomeui/gnome-ui-init.h>
+-
+ #include <libtelepathy/tp-conn.h>
+ #include <libtelepathy/tp-chan.h>
+ #include <libmissioncontrol/mc-account.h>
+@@ -162,7 +159,6 @@
+ main (int argc, char *argv[])
+ {
+ EmpathyChandler *chandler;
+- GnomeProgram *program;
+ gchar *localedir;
+
+ localedir = gossip_paths_get_locale_path ();
+@@ -171,14 +167,8 @@
+ textdomain (GETTEXT_PACKAGE);
+ g_free (localedir);
+
+- program = gnome_program_init ("empathy-chat",
+- PACKAGE_VERSION,
+- LIBGNOMEUI_MODULE,
+- argc, argv,
+- GNOME_PROGRAM_STANDARD_PROPERTIES,
+- GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
+- NULL);
+-
++ gtk_init (&argc, &argv);
++
+ gtk_window_set_default_icon_name ("empathy");
+
+ if (g_getenv ("EMPATHY_DEBUG")) {
+@@ -194,7 +184,6 @@
+
+ gtk_main ();
+
+- g_object_unref (program);
+ g_object_unref (chandler);
+
+ return EXIT_SUCCESS;
+Index: src/empathy-main.c
+===================================================================
+--- src/empathy-main.c (revision 99)
++++ src/empathy-main.c (working copy)
+@@ -28,9 +28,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+
+-#include <libgnome/gnome-program.h>
+-#include <libgnomeui/gnome-ui-init.h>
+-
+ #include <libmissioncontrol/mc-account.h>
+ #include <libmissioncontrol/mc-account-monitor.h>
+ #include <libmissioncontrol/mission-control.h>
+@@ -136,7 +133,6 @@
+ McAccountMonitor *monitor;
+ EmpathyFilter *filter;
+ gchar *localedir;
+- GnomeProgram *program;
+ gboolean no_connect = FALSE;
+ GOptionContext *context;
+ GOptionEntry options[] = {
+@@ -157,14 +153,8 @@
+
+ g_set_application_name (PACKAGE_NAME);
+
+- program = gnome_program_init ("empathy",
+- PACKAGE_VERSION,
+- LIBGNOMEUI_MODULE,
+- argc, argv,
+- GNOME_PROGRAM_STANDARD_PROPERTIES,
+- "goption-context", context,
+- GNOME_PARAM_HUMAN_READABLE_NAME, PACKAGE_NAME,
+- NULL);
++ gtk_init (&argc, &argv);
++ /* TODO: option parsing */
+
+ gtk_window_set_default_icon_name ("empathy");
+
+@@ -204,7 +194,6 @@
+ g_object_unref (monitor);
+ g_object_unref (mc);
+ g_object_unref (icon);
+- g_object_unref (program);
+
+ return EXIT_SUCCESS;
+ }
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 99)
++++ configure.ac (working copy)
+@@ -62,12 +62,12 @@
+
+ PKG_CHECK_MODULES(EMPATHY,
+ [
++ libxml-2.0
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+- libgnomeui-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ])
diff --git a/meta/packages/telepathy/empathy_0.1.bb b/meta/packages/telepathy/empathy_0.1.bb
deleted file mode 100644
index 410acd01e..000000000
--- a/meta/packages/telepathy/empathy_0.1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "Empathy: a Telepathy based IM client"
-HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
-LICENSE = "GPL"
-DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
-RDEPENDS = "telepathy-mission-control"
-RRECOMMENDS = "telepathy-gabble"
-
-PR="r1"
-
-SRC_URI = "http://projects.collabora.co.uk/~xclaesse/empathy-0.1.tar.gz \
- file://no-gnome.diff;patch=1"
-
-inherit autotools pkgconfig
-
-FILES_${PN} += "/usr/share/mission-control/profiles/*.profile \
- /usr/share/dbus-1/services/*.service \
- /usr/share/telepathy/managers/*.chandler"
diff --git a/meta/packages/telepathy/empathy_0.5.bb b/meta/packages/telepathy/empathy_0.5.bb
new file mode 100644
index 000000000..99a787318
--- /dev/null
+++ b/meta/packages/telepathy/empathy_0.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR="r0"
+
+inherit gnome
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/empathy/0.5/empathy-${PV}.tar.bz2 \
+ file://no-gnome.diff;patch=1;pnum=0"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons"