summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-20 13:10:14 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 21:44:37 +0100
commitd86e127ea046f5a150a5022c457c7a8dbf0a22f0 (patch)
tree6c54aa41e5da0728dccc57e651744796e7d60c5b /meta
parent856769b0016c480627c9302b8dc8d2f479058120 (diff)
downloadopenembedded-core-d86e127ea046f5a150a5022c457c7a8dbf0a22f0.tar.gz
openembedded-core-d86e127ea046f5a150a5022c457c7a8dbf0a22f0.tar.bz2
openembedded-core-d86e127ea046f5a150a5022c457c7a8dbf0a22f0.tar.xz
openembedded-core-d86e127ea046f5a150a5022c457c7a8dbf0a22f0.zip
libidn: upgrade to 0.6.14(GPLv2), and 1.19 (GPLv3)
libidn changed to GPLv3 since 2007 (its 1.0 release), so this upgrade includes two: 0.6.14 (GPLv2): - change SRC_URI as original doesn't work - remove original do_configure_prepend, which doesn't make any sense when inheriting autotools - this version includes a local copy of AC_USE_SYSTEM_EXTENSIONS which conflicts with latest autoconf. Actually it's not necessary and remove all references to local version 1.19 (GPLv3): - split a new package 'idn' for command line tools, which are licensed under GPLv3. keep other bits in libidn licensed under LGPLv2.1 Signed-off-by: Kevin Tian <kevin.tian@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libidn/libidn_0.5.19.bb16
-rw-r--r--meta/packages/libidn/libidn_0.6.14.bb26
-rw-r--r--meta/packages/libidn/libidn_1.19.bb20
3 files changed, 46 insertions, 16 deletions
diff --git a/meta/packages/libidn/libidn_0.5.19.bb b/meta/packages/libidn/libidn_0.5.19.bb
deleted file mode 100644
index 07cdb9647..000000000
--- a/meta/packages/libidn/libidn_0.5.19.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
-HOMEPAGE = "http://www.gnu.org/software/libidn/"
-SECTION = "libs"
-# change to GPLv3 for >1.0 version
-LICENSE = "LGPLv2.1+ & GPLv2+"
-PR = "r1"
-
-inherit pkgconfig autotools gettext
-
-SRC_URI = "http://josefsson.org/libidn/releases/${P}.tar.gz"
-
-EXTRA_OECONF = " --disable-tld"
-
-do_configure_prepend () {
- autoreconf -f -i -s
-}
diff --git a/meta/packages/libidn/libidn_0.6.14.bb b/meta/packages/libidn/libidn_0.6.14.bb
new file mode 100644
index 000000000..17bb103d9
--- /dev/null
+++ b/meta/packages/libidn/libidn_0.6.14.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
+HOMEPAGE = "http://www.gnu.org/software/libidn/"
+SECTION = "libs"
+LICENSE = "LGPLv2.1+ & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+ file://lib/idna.h;firstline=6;endline=18;md5=6d9d5532eb28b99e860262281c540d02 \
+ file://src/idn.c;firstline=6;endline=18;md5=41b6aec531cc6a9d54a6c4deee251bf5"
+PR = "r0"
+
+inherit pkgconfig autotools gettext
+
+SRC_URI = "http://alpha.gnu.org/gnu/libidn/${P}.tar.gz"
+
+EXTRA_OECONF = " --disable-tld"
+
+do_configure_prepend() {
+ # this version of libidn copies AC_USE_SYSTEM_EXTENSIONS from
+ # autoconf CVS because atm the autoconf it uses is a bit old
+ # now with cross autotool, that macro is already there and this
+ # local definition causes circular dependency. Actually AC_GNU_SOURCE
+ # is identical to AC_USE_SYSTEM_EXTENSIONS. So remove all local
+ # references to the latter here.
+ sed -i -e "/AC_REQUIRE(\[gl_USE_SYSTEM_EXTENSIONS/d" ${S}/lib/gl/m4/gnulib-comp.m4
+ rm -f ${S}/lib/gl/m4/extensions.m4
+}
diff --git a/meta/packages/libidn/libidn_1.19.bb b/meta/packages/libidn/libidn_1.19.bb
new file mode 100644
index 000000000..2e29ade14
--- /dev/null
+++ b/meta/packages/libidn/libidn_1.19.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
+HOMEPAGE = "http://www.gnu.org/software/libidn/"
+SECTION = "libs"
+LICENSE = "LGPLv2.1+ & GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+ file://lib/idna.h;firstline=6;endline=18;md5=643beb30bf98d8c4aed59a51b86fe9ea \
+ file://src/idn.c;firstline=6;endline=18;md5=07a57d46977b38a2557aac446dda35dd"
+PR = "r0"
+
+inherit pkgconfig autotools gettext
+
+SRC_URI = "http://ftp.gnu.org/gnu/libidn/${P}.tar.gz"
+
+# command tool is under GPLv3+, while libidn itself is under LGPLv2.1+
+# so package command into a separate package
+PACKAGES =+ "idn"
+FILES_idn = "${bindir}/*"
+
+EXTRA_OECONF = " --disable-tld"