summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-14 13:09:18 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-16 16:25:17 +0100
commitdd05d05044017fb46b70f46503c76212aa606a9e (patch)
tree99520f0e19e1d9580a91c6d3e4b6462866fb4810 /meta
parente17f8f7e409f22767e620681e023a2c28039357d (diff)
downloadopenembedded-core-dd05d05044017fb46b70f46503c76212aa606a9e.tar.gz
openembedded-core-dd05d05044017fb46b70f46503c76212aa606a9e.tar.bz2
openembedded-core-dd05d05044017fb46b70f46503c76212aa606a9e.tar.xz
openembedded-core-dd05d05044017fb46b70f46503c76212aa606a9e.zip
pcmciautils: upgrade to version 017
from 014 changes: - put LEX=flex into EXTRA_OEMAKE, from openembedded project - add RDEPENDS only to ${PN}, from openembedded project - remove modalias_update patch, it's in upstream - rebase the other two patches - starting from 017 (or maybe 016), two helper binaries are put into /usr/lib/udev instead of /sbin, adapt this change by adding the new path into package Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch (renamed from meta/packages/pcmciautils/pcmciautils-014/makefile_fix.patch)67
-rw-r--r--meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch (renamed from meta/packages/pcmciautils/pcmciautils-014/version_workaround.patch)2
-rw-r--r--meta/packages/pcmciautils/pcmciautils.inc9
-rw-r--r--meta/packages/pcmciautils/pcmciautils/modalias_update.patch56
-rw-r--r--meta/packages/pcmciautils/pcmciautils_014.bb9
-rw-r--r--meta/packages/pcmciautils/pcmciautils_017.bb9
6 files changed, 55 insertions, 97 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils-014/makefile_fix.patch b/meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch
index f5bb64b9b..82dbfa869 100644
--- a/meta/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
+++ b/meta/packages/pcmciautils/pcmciautils-017/makefile_fix.patch
@@ -1,21 +1,34 @@
+rebase the patch to 017, removing hardcoded path for true
+as well. Removing of -D in install invocation is a little
+questionable, is it some GNU extention?
+
+07/14/2010 - qhe, original patch note follows
+
Hardcoded paths are bad...
-Index: pcmciautils-014/Makefile
-===================================================================
---- pcmciautils-014.orig/Makefile 2006-06-01 11:07:52.000000000 +0200
-+++ pcmciautils-014/Makefile 2006-10-29 13:50:25.000000000 +0100
-@@ -69,7 +69,7 @@
+diff --git a/Makefile b/Makefile
+index 26f3e4b..31f0cdf 100644
+--- a/Makefile
++++ b/Makefile
+@@ -69,7 +69,7 @@ sbindir = ${exec_prefix}/sbin
mandir = ${prefix}/usr/share/man
- srcdir = .
+ udevdir = ${prefix}/lib/udev
-INSTALL = /usr/bin/install -c
+INSTALL = install -c
INSTALL_PROGRAM = ${INSTALL}
INSTALL_DATA = ${INSTALL} -m 644
INSTALL_SCRIPT = ${INSTALL_PROGRAM}
---- pcmciautils-014/Makefile~ 2007-05-25 19:40:39.000000000 +0200
-+++ pcmciautils-014/Makefile 2007-05-25 19:40:39.000000000 +0200
-@@ -258,28 +258,29 @@
+@@ -171,7 +171,7 @@ endif
+ # if DEBUG is enabled, then we do not strip or optimize
+ ifeq ($(strip $(DEBUG)),true)
+ CFLAGS += -O1 -g -DDEBUG -D_GNU_SOURCE
+- STRIPCMD = /bin/true -Since_we_are_debugging
++ STRIPCMD = true -Since_we_are_debugging
+ else
+ CFLAGS += $(OPTIMIZATION) -fomit-frame-pointer -D_GNU_SOURCE
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+@@ -264,30 +264,32 @@ clean:
install-hotplug:
$(INSTALL) -d $(DESTDIR)$(hotplugdir)
@@ -31,57 +44,55 @@ Index: pcmciautils-014/Makefile
- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
-+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
++ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
uninstall-socket-hotplug:
- rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+
install-socket-tools:
-- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-+ $(INSTALL) -d $(DESTDIR)$(sbindir)
-+ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_SOCKET_STARTUP)
++ $(INSTALL) -d $(DESTDIR)$(udevhelperdir)
++ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_SOCKET_STARTUP)
uninstall-socket-tools:
- - rm -f $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+ - rm -f $(DESTDIR)$(udevhelperdir)/$(PCMCIA_SOCKET_STARTUP)
install-tools:
$(INSTALL) -d $(DESTDIR)$(sbindir)
- $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
-- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
++ $(INSTALL) -d $(DESTDIR)$(udevhelperdir)
+ $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
-+ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
$(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
+- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_CHECK_BROKEN_CIS)
++ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(udevhelperdir)/$(PCMCIA_CHECK_BROKEN_CIS)
uninstall-tools:
-@@ -289,18 +290,20 @@
+ - rm -f $(DESTDIR)$(sbindir)/$(PCCARDCTL)
+@@ -296,22 +298,24 @@ uninstall-tools:
install-config:
$(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
- $(INSTALL_DATA) -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
+ $(INSTALL_DATA) config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
+ if [ -f config/config.opts.$(ARCH) ]; then \
+- $(INSTALL_DATA) -D config/config.opts.$(ARCH) $(DESTDIR)$(pcmciaconfdir)/config.opts; \
++ $(INSTALL_DATA) config/config.opts.$(ARCH) $(DESTDIR)$(pcmciaconfdir)/config.opts; \
+ fi
uninstall-config:
# - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
install-udev:
- $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-+ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
++ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
+ $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
uninstall-udev:
- rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
install-man:
-+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
- $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
-
---- pcmciautils-014/Makefile~ 2007-05-25 19:43:01.000000000 +0200
-+++ pcmciautils-014/Makefile 2007-05-25 19:43:01.000000000 +0200
-@@ -304,7 +304,7 @@
-
- install-man:
- $(INSTALL) -d $(DESTDIR)$(mandir)/man8
- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+ $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
$(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
diff --git a/meta/packages/pcmciautils/pcmciautils-014/version_workaround.patch b/meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch
index 962aa4e24..57efa68d3 100644
--- a/meta/packages/pcmciautils/pcmciautils-014/version_workaround.patch
+++ b/meta/packages/pcmciautils/pcmciautils-017/version_workaround.patch
@@ -10,7 +10,7 @@ Index: pcmciautils-013/src/pccardctl.c
static void print_header(void) {
- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
-+ printf("pcmciautils 014\n");
++ printf("pcmciautils 017\n");
printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
}
diff --git a/meta/packages/pcmciautils/pcmciautils.inc b/meta/packages/pcmciautils/pcmciautils.inc
index 7adef38e0..750a2cf60 100644
--- a/meta/packages/pcmciautils/pcmciautils.inc
+++ b/meta/packages/pcmciautils/pcmciautils.inc
@@ -2,9 +2,13 @@ DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
SECTION = "kernel/userland"
PRIORITY = "optional"
+
LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
DEPENDS = "sysfsutils flex-native"
-RDEPENDS = "udev module-init-tools"
+RDEPENDS_${PN} = "udev module-init-tools"
+RCONFLICTS_${PN} += "pcmcia-cs"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2"
@@ -20,11 +24,10 @@ LD = "${CC}"
CFLAGS =+ "-I${S}/src"
PARALLEL_MAKE = ""
-EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
+EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs' 'LEX=flex'"
do_install () {
oe_runmake 'DESTDIR=${D}' install
}
CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
-RCONFLICTS_${PN} += "pcmcia-cs"
diff --git a/meta/packages/pcmciautils/pcmciautils/modalias_update.patch b/meta/packages/pcmciautils/pcmciautils/modalias_update.patch
deleted file mode 100644
index 5727442b5..000000000
--- a/meta/packages/pcmciautils/pcmciautils/modalias_update.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From: Miklos Vajna <vmiklos@frugalware.org>
-Date: Fri, 3 Nov 2006 16:33:38 +0000 (-0500)
-Subject: [PATCH] fix for udev-094
-X-Git-Url: http://git.kernel.org/?p=linux%2Fpcmcia%2Fpcmciautils.git;a=commitdiff_plain;h=3a5217492c1f95711b30f4e27c51563dff6ceb3e
-
-[PATCH] fix for udev-094
-
-from udev's release notes:
-
-"udev 094
-========
-The built-in MODALIAS key and substitution is removed.
-(...)
-udev 080
-========
-(...)
-MODALIAS and $modalias is not needed and will be removed from one of
-the next udev versions, replace it in all rules with ENV{MODALIAS} or
-the sysfs "modalias" value."
-
-here is a patch to fix this issue
-
-Signed-off-by: Miklos Vajna <vmiklos@frugalware.org>
-Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
----
-
-diff --git a/udev/rules-base b/udev/rules-base
-index c6d14de..6ed3a27 100644
---- a/udev/rules-base
-+++ b/udev/rules-base
-@@ -3,12 +3,12 @@
- # are so broken that we need to read out random bytes of it
- # instead of the manufactor, card or product ID. Then the
- # matching is done in userspace.
--ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
-+ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
- RUN+="/sbin/pcmcia-check-broken-cis"
-
- # However, the "weak" matching by func_id is only allowed _after_ modprobe
- # returns, so that "strong" matches have a higher priority.
--ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
-+ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
- RUN+="/bin/sh -c 'echo 1 > /sys/$devpath/allow_func_id_match'"
-
- # PCMCIA sockets:
-diff --git a/udev/rules-modprobe b/udev/rules-modprobe
-index ea1f44a..a13b2ad 100644
---- a/udev/rules-modprobe
-+++ b/udev/rules-modprobe
-@@ -1,3 +1,3 @@
--# modprobe $modalias loads all possibly appropriate modules
--ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
-- RUN+="/sbin/modprobe $modalias"
-+# modprobe $env{MODALIAS} loads all possibly appropriate modules
-+ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
-+ RUN+="/sbin/modprobe $env{MODALIAS}"
diff --git a/meta/packages/pcmciautils/pcmciautils_014.bb b/meta/packages/pcmciautils/pcmciautils_014.bb
deleted file mode 100644
index 139dc54c0..000000000
--- a/meta/packages/pcmciautils/pcmciautils_014.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require pcmciautils.inc
-
-PR = "r2"
-
-export LEX = "flex"
-
-SRC_URI += "file://makefile_fix.patch;patch=1 \
- file://version_workaround.patch;patch=1 \
- file://modalias_update.patch;patch=1"
diff --git a/meta/packages/pcmciautils/pcmciautils_017.bb b/meta/packages/pcmciautils/pcmciautils_017.bb
new file mode 100644
index 000000000..109b17d76
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils_017.bb
@@ -0,0 +1,9 @@
+require pcmciautils.inc
+
+PR = "r0"
+
+SRC_URI += "file://makefile_fix.patch \
+ file://version_workaround.patch"
+
+FILES_${PN}-dbg += "${libdir}/udev/.debug"
+FILES_${PN} += "${libdir}/udev"