summaryrefslogtreecommitdiff
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-21 11:28:02 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-21 11:28:02 +0000
commite423fc9d57748b50d673c044aeefd956c04affbe (patch)
tree5cd63982d212900d0d8c91110e71fae8eb8daa98 /meta
parenteef43c9f5571ab000c4fd1d8ca88a3dbdd47f2e2 (diff)
downloadopenembedded-core-e423fc9d57748b50d673c044aeefd956c04affbe.tar.gz
openembedded-core-e423fc9d57748b50d673c044aeefd956c04affbe.tar.bz2
openembedded-core-e423fc9d57748b50d673c044aeefd956c04affbe.tar.xz
openembedded-core-e423fc9d57748b50d673c044aeefd956c04affbe.zip
libidl: Improve staging from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@914 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libidl/libidl_0.8.3.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/packages/libidl/libidl_0.8.3.bb b/meta/packages/libidl/libidl_0.8.3.bb
index 5a6f5800d..e74324739 100644
--- a/meta/packages/libidl/libidl_0.8.3.bb
+++ b/meta/packages/libidl/libidl_0.8.3.bb
@@ -2,13 +2,16 @@ LICENSE = "LGPL"
DESCRIPTION = "Library for parsing CORBA IDL files"
SECTION = "gnome/libs"
DEPENDS = "glib-2.0"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-${PV}.tar.bz2"
S = "${WORKDIR}/libIDL-${PV}"
inherit autotools pkgconfig
+# Firefox uses the libIDL-config-2 script instead of pkgconfig (for some
+# strange reason - so we do some sed fu to fix the path there
+
do_stage() {
oe_runmake install \
prefix=${STAGING_DIR} \
@@ -17,6 +20,9 @@ do_stage() {
libdir=${STAGING_LIBDIR} \
datadir=${STAGING_DATADIR} \
infodir=${STAGING_INFODIR}
+
+ cp ${STAGING_BINDIR}/libIDL-config-2 ${STAGING_BINDIR}/libIDL-config-2.orig
+ cat ${STAGING_BINDIR}/libIDL-config-2.orig | sed -e 's:${includedir}:${STAGING_INCDIR}:' > ${STAGING_BINDIR}/libIDL-config-2
}
FILES_${PN} = "${libdir}/*.so.*"