summaryrefslogtreecommitdiff
path: root/openembedded-extras/packages/libmad
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-04 20:20:45 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-04 20:20:45 +0000
commit5426fb4ebd087ab75490a27bd9ac6074ff1881c0 (patch)
treec80e2bf07f0db59ec054a61351de60619bad040d /openembedded-extras/packages/libmad
parent81b93eb2ed7eb493d3da664bf7b4d6b3178fe535 (diff)
downloadopenembedded-core-5426fb4ebd087ab75490a27bd9ac6074ff1881c0.tar.gz
openembedded-core-5426fb4ebd087ab75490a27bd9ac6074ff1881c0.tar.bz2
openembedded-core-5426fb4ebd087ab75490a27bd9ac6074ff1881c0.tar.xz
openembedded-core-5426fb4ebd087ab75490a27bd9ac6074ff1881c0.zip
Add madplay to -extras and create an extras image to include apps in extras
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@502 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded-extras/packages/libmad')
-rw-r--r--openembedded-extras/packages/libmad/libmad_0.15.0b.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/openembedded-extras/packages/libmad/libmad_0.15.0b.bb b/openembedded-extras/packages/libmad/libmad_0.15.0b.bb
new file mode 100644
index 000000000..b3614db05
--- /dev/null
+++ b/openembedded-extras/packages/libmad/libmad_0.15.0b.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "MPEG Audio Decoder Library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+DEPENDS = "libid3tag"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "ftp://ftp.mars.org/pub/mpeg/libmad-${PV}.tar.gz"
+S = "${WORKDIR}/libmad-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "-enable-speed --enable-shared"
+# The ASO's don't take any account of thumb...
+EXTRA_OECONF_append_thumb = " --disable-aso --enable-fpm=default"
+
+do_configure_prepend () {
+# damn picky automake...
+ touch NEWS AUTHORS ChangeLog
+}
+
+do_stage() {
+ oe_libinstall -so libmad ${STAGING_LIBDIR}
+ install -m 0644 mad.h ${STAGING_INCDIR}
+}