summaryrefslogtreecommitdiff
path: root/openembedded-extras/packages/python/python-native-2.4.0
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-26 13:28:14 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-26 13:28:14 +0000
commit1cd244533c2436e27a974d7c6a15262be7a49f50 (patch)
treec86f52fe49cfb4421a581f9cd7b9f65dfaea9a2e /openembedded-extras/packages/python/python-native-2.4.0
parent39811ea4ae7f49ce27b6206727ffd929aed986dd (diff)
downloadopenembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.tar.gz
openembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.tar.bz2
openembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.tar.xz
openembedded-core-1cd244533c2436e27a974d7c6a15262be7a49f50.zip
Create openembedded-extras collection. Disabled by default - see local.conf.sample about how to enable
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@429 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded-extras/packages/python/python-native-2.4.0')
-rw-r--r--openembedded-extras/packages/python/python-native-2.4.0/bindir-libdir.patch18
-rw-r--r--openembedded-extras/packages/python/python-native-2.4.0/cross-distutils.patch38
2 files changed, 56 insertions, 0 deletions
diff --git a/openembedded-extras/packages/python/python-native-2.4.0/bindir-libdir.patch b/openembedded-extras/packages/python/python-native-2.4.0/bindir-libdir.patch
new file mode 100644
index 000000000..999bddc44
--- /dev/null
+++ b/openembedded-extras/packages/python/python-native-2.4.0/bindir-libdir.patch
@@ -0,0 +1,18 @@
+
+#
+# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200
++++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100
+@@ -78,8 +78,8 @@
+ exec_prefix= @exec_prefix@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/openembedded-extras/packages/python/python-native-2.4.0/cross-distutils.patch b/openembedded-extras/packages/python/python-native-2.4.0/cross-distutils.patch
new file mode 100644
index 000000000..76ae883c1
--- /dev/null
+++ b/openembedded-extras/packages/python/python-native-2.4.0/cross-distutils.patch
@@ -0,0 +1,38 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100
++++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100
+@@ -19,8 +19,8 @@
+ from errors import DistutilsPlatformError
+
+ # These are needed in a couple of spots, so just compute them once.
+-PREFIX = os.path.normpath(sys.prefix)
+-EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
++PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
++EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+ # python_build: (Boolean) if true, we're either building Python or
+ # building an extension with an un-installed Python, so we use
+@@ -192,7 +192,8 @@
+ else:
+ # The name of the config.h file changed in 2.2
+ config_h = 'pyconfig.h'
+- return os.path.join(inc_dir, config_h)
++ print "NOTE: sysconfig.get_config_h_filename() altered for OpenEmbedded"
++ return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+
+ def get_makefile_filename():
+@@ -200,7 +201,8 @@
+ if python_build:
+ return os.path.join(os.path.dirname(sys.executable), "Makefile")
+ lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
+- return os.path.join(lib_dir, "config", "Makefile")
++ print "NOTE: sysconfig.get_config_h_filename() altered for OpenEmbedded"
++ return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
+
+
+ def parse_config_h(fp, g=None):