summaryrefslogtreecommitdiff
path: root/openembedded/packages/alsa/alsa-lib_1.0.10.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-12-15 17:50:54 +0000
committerRichard Purdie <richard@openedhand.com>2005-12-15 17:50:54 +0000
commit47eec0a88c2478c3da1c9607d549a5a95424fe1d (patch)
tree658cc436fc808a712c86c0b0508881512b2d463c /openembedded/packages/alsa/alsa-lib_1.0.10.bb
parentb38f2a5935beaa588b90eec63fa5ab56d084f822 (diff)
downloadopenembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.tar.gz
openembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.tar.bz2
openembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.tar.xz
openembedded-core-47eec0a88c2478c3da1c9607d549a5a95424fe1d.zip
Add Alsa support to poky
git-svn-id: https://svn.o-hand.com/repos/poky@198 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/alsa/alsa-lib_1.0.10.bb')
-rw-r--r--openembedded/packages/alsa/alsa-lib_1.0.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/openembedded/packages/alsa/alsa-lib_1.0.10.bb b/openembedded/packages/alsa/alsa-lib_1.0.10.bb
new file mode 100644
index 000000000..a5d542631
--- /dev/null
+++ b/openembedded/packages/alsa/alsa-lib_1.0.10.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Alsa sound library"
+MAINTAINER = "Lorn Potter <lpotter@trolltech.com>"
+SECTION = "libs/multimedia"
+LICENSE = "GPL"
+
+# configure.in sets -D__arm__ on the command line for any arm system
+# (not just those with the ARM instruction set), this should be removed,
+# (or replaced by a permitted #define).
+#FIXME: remove the following
+ARM_INSTRUCTION_SET = "arm"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes"
+
+do_stage () {
+ oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/alsa/sound
+ install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
+ install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "libasound alsa-server alsa-conf alsa-doc alsa-dev"
+FILES_libasound = "${libdir}/libasound.so*"
+FILES_alsa-server = "${bindir}"
+FILES_alsa-conf = "${datadir}"
+FILES_alsa-dev = "${libdir}/pkgconfig/ /usr/include/"