summaryrefslogtreecommitdiff
path: root/openembedded/packages/apmd/apmd_3.2.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
commit4b46c1f6e891b1ddd5968536440b888661fade3e (patch)
treee0ba2c1f56f61b868bf746da5c4feabb25b800b2 /openembedded/packages/apmd/apmd_3.2.2.bb
downloadopenembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.gz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.bz2
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.xz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.zip
Initial population
git-svn-id: https://svn.o-hand.com/repos/poky@1 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/apmd/apmd_3.2.2.bb')
-rw-r--r--openembedded/packages/apmd/apmd_3.2.2.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/openembedded/packages/apmd/apmd_3.2.2.bb b/openembedded/packages/apmd/apmd_3.2.2.bb
new file mode 100644
index 000000000..0e8b36445
--- /dev/null
+++ b/openembedded/packages/apmd/apmd_3.2.2.bb
@@ -0,0 +1,83 @@
+DESCRIPTION = "Set of tools for managing notebook power consumption."
+SECTION = "base"
+PRIORITY = "required"
+DEPENDS = "libtool-cross"
+LICENSE = "GPL"
+PR = "r5"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz; \
+ file://debian.patch;patch=1 \
+ file://workaround.patch;patch=1 \
+ file://apmwrapper \
+ file://init \
+ file://default \
+ file://apmd_proxy \
+ file://apmd_proxy.conf"
+
+S = "${WORKDIR}/apmd-${PV}.orig"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "apmd"
+INITSCRIPT_PARAMS = "defaults"
+
+do_compile() {
+ oe_runmake "LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool" apm apmd
+}
+
+do_stage() {
+ install -m 0644 apm.h ${STAGING_INCDIR}
+ oe_libinstall -so libapm ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/apm
+ install -d ${D}${sysconfdir}/apm/event.d
+ install -d ${D}${sysconfdir}/apm/other.d
+ install -d ${D}${sysconfdir}/apm/suspend.d
+ install -d ${D}${sysconfdir}/apm/resume.d
+ install -d ${D}${sysconfdir}/apm/scripts.d
+ install -d ${D}${sysconfdir}/default
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir}
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${datadir}/apmd
+#
+# only Zaurus 2.4-embedix kernels need a breadead apm hack
+#
+#
+ case ${MACHINE} in
+ collie | poodle | tosa | c7x0 | akita | spitz | borzoi)
+ if [ "${KERNEL_VERSION}" == "2.6" ]
+ then
+ install -m 4577 ${S}/.libs/apm ${D}${bindir}/apm
+ else
+ install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm.orig
+ install -m 0755 ${WORKDIR}/apmwrapper ${D}${bindir}/apm
+ fi
+ ;;
+ *)
+ install -m 4577 ${S}/.libs/apm ${D}${bindir}/apm
+ ;;
+ esac
+
+ install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd
+ install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/
+ install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/
+ install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/apmd
+ oe_libinstall -so libapm ${D}${libdir}
+ install -m 0644 apm.h ${D}${includedir}
+
+ cat ${WORKDIR}/init | sed -e 's,/usr/sbin,${sbindir},g; s,/etc,${sysconfdir},g;' > ${D}${sysconfdir}/init.d/apmd
+ chmod 755 ${D}${sysconfdir}/init.d/apmd
+}
+
+PACKAGES =+ "libapm libapm-dev apm"
+
+FILES_libapm = "${libdir}/libapm.so.*"
+FILES_libapm-dev = "${libdir}/libapm.* ${includedir}"
+FILES_apm = "${bindir}/apm*"
+
+