summaryrefslogtreecommitdiff
path: root/openembedded/packages/avahi/avahi_0.6.10.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-22 22:15:25 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-22 22:15:25 +0000
commita1c255607188f539ed4bb5e3d98ba965c819201c (patch)
tree30b60601c1ae9234f9ff09182e88c57d6685f8bb /openembedded/packages/avahi/avahi_0.6.10.bb
parentad4b746c07563a50fd35f6f68ebb82acdc0f194c (diff)
downloadopenembedded-core-a1c255607188f539ed4bb5e3d98ba965c819201c.tar.gz
openembedded-core-a1c255607188f539ed4bb5e3d98ba965c819201c.tar.bz2
openembedded-core-a1c255607188f539ed4bb5e3d98ba965c819201c.tar.xz
openembedded-core-a1c255607188f539ed4bb5e3d98ba965c819201c.zip
avahi: upgrade 0.6.3 -> 0.6.10 (and fix the postinst to run on device)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@406 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/avahi/avahi_0.6.10.bb')
-rw-r--r--openembedded/packages/avahi/avahi_0.6.10.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/openembedded/packages/avahi/avahi_0.6.10.bb b/openembedded/packages/avahi/avahi_0.6.10.bb
new file mode 100644
index 000000000..2b12d91c8
--- /dev/null
+++ b/openembedded/packages/avahi/avahi_0.6.10.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
+SECTION = "network"
+PRIORITY = "optional"
+AUTHOR = "Lennart Poettering <lennart@poettering.net>"
+HOMEPAGE = "http://avahi.org"
+MAINTAINER = "Philipp Zabel <philipp.zabel@gmail.com>"
+LICENSE= "GPL"
+
+DEPENDS = "expat libdaemon dbus"
+RRECOMMENDS = "libnss-mdns"
+
+SRC_URI = "http://avahi.org/download/avahi-${PV}.tar.gz"
+
+PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc avahi-utils"
+
+FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
+FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
+FILES_avahi-daemon = "${sbindir}/avahi-daemon \
+ ${sysconfdir}/avahi/avahi-daemon.conf \
+ ${sysconfdir}/avahi/hosts \
+ ${sysconfdir}/avahi/services \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/init.d/avahi-daemon \
+ ${datadir}/avahi/introspection/*.introspect \
+ ${datadir}/avahi/avahi-service.dtd \
+ ${datadir}/avahi/service-types"
+FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
+FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
+ ${sysconfdir}/avahi/avahi-dnsconfd.action \
+ ${sysconfdir}/init.d/avahi-dnsconfd"
+FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_avahi-utils = "${bindir}/avahi-*"
+
+CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
+
+EXTRA_OECONF = "--with-distro=debian --disable-gdbm --disable-gtk --disable-mono --disable-monodoc --disable-qt3 --disable-qt4 --disable-python"
+inherit autotools pkgconfig update-rc.d
+
+INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
+INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
+INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19"
+INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
+INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19"
+
+pkg_postinst_avahi-daemon () {
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ grep avahi /etc/group || addgroup avahi
+ grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon --no-create-home avahi --ingroup avahi -g Avahi
+ /etc/init.d/dbus-1 force-reload
+}
+
+pkg_postrm_avahi-daemon () {
+ deluser avahi || true
+ delgroup avahi || true
+}