summaryrefslogtreecommitdiff
path: root/openembedded/packages/console-tools
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-09 18:38:19 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-09 18:38:19 +0000
commitb4cb437c6595ff8ac13506e502fe04b1a60c4e04 (patch)
treef529de217094f1a49049f90c49d779a49e19cd7c /openembedded/packages/console-tools
parent3baacb49c13a48798d45e30a0a0076ca0b8c9e6a (diff)
downloadopenembedded-core-b4cb437c6595ff8ac13506e502fe04b1a60c4e04.tar.gz
openembedded-core-b4cb437c6595ff8ac13506e502fe04b1a60c4e04.tar.bz2
openembedded-core-b4cb437c6595ff8ac13506e502fe04b1a60c4e04.tar.xz
openembedded-core-b4cb437c6595ff8ac13506e502fe04b1a60c4e04.zip
Merge packages changes from OE into poky.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@386 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/console-tools')
-rw-r--r--openembedded/packages/console-tools/console-tools-0.3.2/uclibc-fileno.patch47
-rw-r--r--openembedded/packages/console-tools/console-tools_0.3.2.bb1
2 files changed, 48 insertions, 0 deletions
diff --git a/openembedded/packages/console-tools/console-tools-0.3.2/uclibc-fileno.patch b/openembedded/packages/console-tools/console-tools-0.3.2/uclibc-fileno.patch
new file mode 100644
index 000000000..c73d8a3d9
--- /dev/null
+++ b/openembedded/packages/console-tools/console-tools-0.3.2/uclibc-fileno.patch
@@ -0,0 +1,47 @@
+Fixing the locale issues isn't enough, console-tools also does a couple of
+other pretty stupid things (like FILE *f; f->_fileno instead of fileno(f)),
+
+--- console-tools-0.3.2/lib/cfont/fontstruct.c.ark 2005-05-22 19:12:38.000000000 +0000
++++ console-tools-0.3.2/lib/cfont/fontstruct.c 2005-05-22 19:13:23.000000000 +0000
+@@ -50,8 +50,7 @@
+ * get filesize
+ */
+
+- /* FIXME: should not use _fileno ! */
+- if (fstat(fontfile->_fileno, &stbuf) == -1)
++ if (fstat(fileno(fontfile), &stbuf) == -1)
+ goto rsf_return_error;
+
+ if (S_ISREG(stbuf.st_mode))
+@@ -211,8 +210,7 @@
+ * get filesize
+ */
+
+- /* FIXME: should not use _fileno ! */
+- if (fstat(fontfile->_fileno, &stbuf) == -1)
++ if (fstat(fileno(fontfile), &stbuf) == -1)
+ goto rfg_return_error;
+
+ if (S_ISREG(stbuf.st_mode))
+--- console-tools-0.3.2/lib/console/acm.c.ark 2005-05-22 19:17:15.000000000 +0000
++++ console-tools-0.3.2/lib/console/acm.c 2005-05-22 19:17:23.000000000 +0000
+@@ -30,7 +30,7 @@
+ lct_boolean parse_failed = False;
+ lct_boolean is_unicode;
+
+- if (fstat(fp->_fileno, &stbuf))
++ if (fstat(fileno(fp), &stbuf))
+ perror(_("Cannot stat ACM file")), exit(1);
+
+ /* first try a wg15-charmap (glibc) file format */
+--- console-tools-0.3.2/include/lct/local.h.ark 2005-05-22 19:08:54.000000000 +0000
++++ console-tools-0.3.2/include/lct/local.h 2005-05-22 19:09:12.000000000 +0000
+@@ -8,7 +8,7 @@
+ #include <locale.h>
+
+
+-#ifdef HAVE_LOCALE_H
++#if defined(HAVE_LOCALE_H) && defined(HAVE_LIBINTL_H)
+ # include <libintl.h>
+ # define _(String) gettext (String)
+ # ifdef gettext_noop
diff --git a/openembedded/packages/console-tools/console-tools_0.3.2.bb b/openembedded/packages/console-tools/console-tools_0.3.2.bb
index f7455825e..01c2e42a3 100644
--- a/openembedded/packages/console-tools/console-tools_0.3.2.bb
+++ b/openembedded/packages/console-tools/console-tools_0.3.2.bb
@@ -8,6 +8,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://configure.patch;patch=1 \
file://compile.patch;patch=1 \
file://kbdrate.patch;patch=1 \
+ file://uclibc-fileno.patch;patch=1 \
file://config/*.m4"
export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \