summaryrefslogtreecommitdiff
path: root/openembedded/packages/contacts
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-12-22 16:50:56 +0000
committerChris Lord <chris@openedhand.com>2005-12-22 16:50:56 +0000
commit597f73ebe7890f67ad02f8ac54acc3280330b097 (patch)
tree7e66c196d740cc7f82f0e56b7d0bb8628bd46620 /openembedded/packages/contacts
parente7cf0cc43167bf9bdc87e6168e64db38d6468427 (diff)
downloadopenembedded-core-597f73ebe7890f67ad02f8ac54acc3280330b097.tar.gz
openembedded-core-597f73ebe7890f67ad02f8ac54acc3280330b097.tar.bz2
openembedded-core-597f73ebe7890f67ad02f8ac54acc3280330b097.tar.xz
openembedded-core-597f73ebe7890f67ad02f8ac54acc3280330b097.zip
Add packages for Contacts 0.1 and svn
git-svn-id: https://svn.o-hand.com/repos/poky@203 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/contacts')
-rwxr-xr-xopenembedded/packages/contacts/contacts_0.1.bb (renamed from openembedded/packages/contacts/contacts_0.0.bb)5
-rwxr-xr-xopenembedded/packages/contacts/contacts_svn.bb36
2 files changed, 39 insertions, 2 deletions
diff --git a/openembedded/packages/contacts/contacts_0.0.bb b/openembedded/packages/contacts/contacts_0.1.bb
index ef2d1b1b9..aff86a1c6 100755
--- a/openembedded/packages/contacts/contacts_0.0.bb
+++ b/openembedded/packages/contacts/contacts_0.1.bb
@@ -3,15 +3,16 @@ SECTION = "x11"
DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
MAINTAINER = "Chris Lord <chris@openedhand.com>"
DESCRIPTION = "Contacts is an address-book application."
-PR = "r5"
-SRC_URI = "file:///tmp/${PN}-${PV}.tar.gz \
+SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
file://stock_contact.png \
file://stock_person.png \
file://index.theme"
inherit autotools pkgconfig
+S = "${WORKDIR}/release-0.1"
+
do_install_append () {
install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
diff --git a/openembedded/packages/contacts/contacts_svn.bb b/openembedded/packages/contacts/contacts_svn.bb
new file mode 100755
index 000000000..121f256a4
--- /dev/null
+++ b/openembedded/packages/contacts/contacts_svn.bb
@@ -0,0 +1,36 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus gnome-vfs"
+RDEPENDS = "gnome-vfs-plugin-file"
+RRECOMMENDS = "gnome-vfs-plugin-http"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DESCRIPTION = "Contacts is an address-book application."
+
+SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
+ file://stock_contact.png \
+ file://stock_person.png \
+ file://index.theme"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--enable-gnome-vfs"
+
+do_install_append () {
+ install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net
+ install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+
+ install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
+ install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
+ install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png \
+ ${datadir}/icons/hicolor/48x48/stock/*/*.png \
+ ${datadir}/icons/hicolor/index.theme"
+
+pkg_postinst_${PN} () {
+ gtk-update-icon-cache /usr/share/icons/hicolor
+}
+