summaryrefslogtreecommitdiff
path: root/openembedded/packages/curl/curl_7.14.0.bb
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2006-02-07 04:22:50 +0000
committerChris Lord <chris@openedhand.com>2006-02-07 04:22:50 +0000
commit4fbba6350edd17d9272a668b5ba564f558974a94 (patch)
treedafc821fd7b7d4ec5e08966b6ac479f50f94e5df /openembedded/packages/curl/curl_7.14.0.bb
parentef60244cc4a28777efdaed9260e8c7ae4872e2b1 (diff)
downloadopenembedded-core-4fbba6350edd17d9272a668b5ba564f558974a94.tar.gz
openembedded-core-4fbba6350edd17d9272a668b5ba564f558974a94.tar.bz2
openembedded-core-4fbba6350edd17d9272a668b5ba564f558974a94.tar.xz
openembedded-core-4fbba6350edd17d9272a668b5ba564f558974a94.zip
Add curl (new dependency of Web), fix a fontconfig-native build issue,
update gtkhtml2 patches and update to a newer more functional Web snapshot git-svn-id: https://svn.o-hand.com/repos/poky@251 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/curl/curl_7.14.0.bb')
-rw-r--r--openembedded/packages/curl/curl_7.14.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/openembedded/packages/curl/curl_7.14.0.bb b/openembedded/packages/curl/curl_7.14.0.bb
new file mode 100644
index 000000000..a0ad4d14d
--- /dev/null
+++ b/openembedded/packages/curl/curl_7.14.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Command line tool and library for client-side URL transfers."
+LICENSE = "MIT"
+DEPENDS = "zlib"
+SECTION = "console/network"
+
+SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2"
+S = "${WORKDIR}/curl-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
+ --without-ssl \
+ --with-random=/dev/urandom \
+ --without-idn \
+ --enable-http \
+ --enable-file"
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/curl
+ install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
+ oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
+}
+
+PACKAGES = "curl curl-doc libcurl libcurl-dev libcurl-doc"
+FILES_${PN} = "${bindir}/curl"
+FILES_${PN}-doc = "${mandir}/man1/curl.1"
+FILES_lib${PN} = "${libdir}/lib*.so.*"
+FILES_lib${PN}-dev = "${includedir} \
+ ${libdir}/lib*.so \
+ ${libdir}/lib*.a \
+ ${libdir}/lib*.la \
+ ${libdir}/pkgconfig \
+ ${datadir}/aclocal \
+ ${bindir}/*-config"
+FILES_lib${PN}-doc = "${mandir}/man3 \
+ ${mandir}/man1/curl-config.1"
+