summaryrefslogtreecommitdiff
path: root/openembedded/packages/eds/eds-dbus_svn.bb
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-09-29 18:30:53 +0000
committerChris Lord <chris@openedhand.com>2005-09-29 18:30:53 +0000
commit9243bc3d2f2e202ab0ded5fb1007291f181e9222 (patch)
tree5dded9146efbf9b6241dd80e0d43b3f53fd6307b /openembedded/packages/eds/eds-dbus_svn.bb
parent812ddef9f59e142706786d8fd3635c9493a68be2 (diff)
downloadopenembedded-core-9243bc3d2f2e202ab0ded5fb1007291f181e9222.tar.gz
openembedded-core-9243bc3d2f2e202ab0ded5fb1007291f181e9222.tar.bz2
openembedded-core-9243bc3d2f2e202ab0ded5fb1007291f181e9222.tar.xz
openembedded-core-9243bc3d2f2e202ab0ded5fb1007291f181e9222.zip
- Fix gconf staging to install into the right directory
- Complete eds-dbus staging git-svn-id: https://svn.o-hand.com/repos/poky@76 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/eds/eds-dbus_svn.bb')
-rwxr-xr-xopenembedded/packages/eds/eds-dbus_svn.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/openembedded/packages/eds/eds-dbus_svn.bb b/openembedded/packages/eds/eds-dbus_svn.bb
index be803a765..2ffa363fe 100755
--- a/openembedded/packages/eds/eds-dbus_svn.bb
+++ b/openembedded/packages/eds/eds-dbus_svn.bb
@@ -4,11 +4,12 @@ RDEPENDS = "gtk+ gconf db libiconv"
MAINTAINER = "Chris Lord <chris@openedhand.com>"
DESCRIPTION = "Evolution database backend server"
PV = "1.4.0cvs${CVSDATE}"
-PR = "r3"
+PR = "r4"
SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
file://external_libdb.patch;patch=1 \
file://no_gnomevfs.patch;patch=1 \
+ file://no_gnomevfs2.patch;patch=1 \
file://no_iconv_test.patch;patch=1 \
file://iconv-detect.h"
@@ -27,8 +28,26 @@ FILES_${PN} += "${libdir}/evolution-data-server-1.2/extensions/*.so \
${datadir}/evolution-data-server-1.4/zoneinfo/*/*.ics \
${datadir}/evolution-data-server-1.4/zoneinfo/*/*/*.ics \
${datadir}/dbus-1/services/*.service"
-
FILES_${PN}-dev += "${libdir}/evolution-data-server-1.2/extensions/*.la \
${libdir}/evolution-data-server-1.2/camel-providers/*.la"
+
do_configure_append = " cp ${WORKDIR}/iconv-detect.h ${S} "
+
+do_stage () {
+ oe_libinstall -so -C addressbook/libebook-dbus libebook-1.2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C addressbook/libedata-book-dbus libedata-book-1.2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C calendar/libecal-dbus libecal-1.2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C calendar/libedata-cal-dbus libedata-cal-1.2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C libedataserver libedataserver-1.2 ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/camel ${STAGING_INCDIR}/libebook \
+ ${STAGING_INCDIR}/libecal ${STAGING_INCDIR}/libedataserver \
+ ${STAGING_INCDIR}/libical
+ install -m 0644 ${S}/camel/*.h ${STAGING_INCDIR}/camel
+ install -m 0644 ${S}/addressbook/libebook-dbus/*.h ${STAGING_INCDIR}/libebook
+ install -m 0644 ${S}/calendar/libecal-dbus/*.h ${STAGING_INCDIR}/libecal
+ install -m 0644 ${S}/libedataserver/*.h ${STAGING_INCDIR}/libedataserver
+ install -m 0644 ${S}/calendar/libical/src/libical/*.h ${STAGING_INCDIR}/libical
+}
+