summaryrefslogtreecommitdiff
path: root/openembedded/packages/freetype
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
commit4b46c1f6e891b1ddd5968536440b888661fade3e (patch)
treee0ba2c1f56f61b868bf746da5c4feabb25b800b2 /openembedded/packages/freetype
downloadopenembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.gz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.bz2
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.xz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.zip
Initial population
git-svn-id: https://svn.o-hand.com/repos/poky@1 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/freetype')
-rw-r--r--openembedded/packages/freetype/files/configure.patch47
-rw-r--r--openembedded/packages/freetype/freetype-native_2.1.10.bb21
-rw-r--r--openembedded/packages/freetype/freetype_2.1.10.bb31
3 files changed, 99 insertions, 0 deletions
diff --git a/openembedded/packages/freetype/files/configure.patch b/openembedded/packages/freetype/files/configure.patch
new file mode 100644
index 000000000..f11cf96be
--- /dev/null
+++ b/openembedded/packages/freetype/files/configure.patch
@@ -0,0 +1,47 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: freetype-2.1.8/builds/unix/configure.ac
+===================================================================
+--- freetype-2.1.8.orig/builds/unix/configure.ac 2004-04-14 04:49:11.000000000 -0400
++++ freetype-2.1.8/builds/unix/configure.ac 2005-03-12 03:14:23.000000000 -0500
+@@ -111,8 +111,8 @@
+ # Check for system zlib
+
+ AC_ARG_WITH([zlib],
+- dnl don't quote AS_HELP_STRING!
+- AS_HELP_STRING([--without-zlib],
++ dnl don't quote AC_HELP_STRING!
++ AC_HELP_STRING([--without-zlib],
+ [use internal zlib instead of system-wide]))
+ if test x$with_zlib != xno && test -z "$LIBZ"; then
+ AC_CHECK_LIB([z], [gzsetparams], [AC_CHECK_HEADER([zlib.h], [LIBZ='-lz'])])
+@@ -127,7 +127,7 @@
+ # Whether to use Mac OS resource-based fonts or not
+
+ AC_ARG_WITH([old-mac-fonts],
+- dnl don't quote AS_HELP_STRING!
+- AS_HELP_STRING([--with-old-mac-fonts],
++ dnl don't quote AC_HELP_STRING!
++ AC_HELP_STRING([--with-old-mac-fonts],
+ [allow Mac resource-based fonts to be used]))
+ if test x$with_old_mac_fonts = xyes; then
+Index: freetype-2.1.8/builds/unix/unix-cc.in
+===================================================================
+--- freetype-2.1.8.orig/builds/unix/unix-cc.in 2003-11-09 03:37:13.000000000 -0500
++++ freetype-2.1.8/builds/unix/unix-cc.in 2005-03-12 18:37:24.613693760 -0500
+@@ -14,9 +14,11 @@
+
+ CC := @CC@
+ COMPILER_SEP := $(SEP)
++SHELL := @SHELL@
++top_builddir := $(BUILD_DIR)
+
+ ifndef LIBTOOL
+- LIBTOOL := $(BUILD_DIR)/libtool
++ LIBTOOL := @LIBTOOL@
+ endif
+
+
diff --git a/openembedded/packages/freetype/freetype-native_2.1.10.bb b/openembedded/packages/freetype/freetype-native_2.1.10.bb
new file mode 100644
index 000000000..64fac71cb
--- /dev/null
+++ b/openembedded/packages/freetype/freetype-native_2.1.10.bb
@@ -0,0 +1,21 @@
+include freetype_${PV}.bb
+inherit native
+DEPENDS = ""
+FILESPATH = "${FILE_DIRNAME}/freetype-${PV}:${FILE_DIRNAME}/freetype:${FILE_DIRNAME}/files"
+
+EXTRA_OEMAKE=
+
+do_configure() {
+ (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_includes
+ oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+do_install() {
+ :
+}
+
diff --git a/openembedded/packages/freetype/freetype_2.1.10.bb b/openembedded/packages/freetype/freetype_2.1.10.bb
new file mode 100644
index 000000000..772b316cc
--- /dev/null
+++ b/openembedded/packages/freetype/freetype_2.1.10.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Freetype font rendering library"
+HOMEPAGE = "http://www.freetype.org"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+
+do_configure() {
+ cd builds/unix
+ gnu-configize
+ aclocal -I .
+ autoconf
+ cd ${S}
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_includes
+ oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"