summaryrefslogtreecommitdiff
path: root/openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-16 16:20:35 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-16 16:20:35 +0000
commit1a5f0fedce5084690bb478a302d7dd326198afee (patch)
tree4ee4c487b833e01dd4b82eaf4d6ee13578bfd78b /openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb
parentf0d9a3840ce349e606f5a6bfcf552c1adcaf2a46 (diff)
downloadopenembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.tar.gz
openembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.tar.bz2
openembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.tar.xz
openembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.zip
Add gcc versions 4.0.2, 3.3.4 and 3.4.4
git-svn-id: https://svn.o-hand.com/repos/poky@182 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb')
-rw-r--r--openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb b/openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb
new file mode 100644
index 000000000..e3b365da1
--- /dev/null
+++ b/openembedded/packages/gcc/gcc-cross-initial_3.3.4.bb
@@ -0,0 +1,28 @@
+SECTION = "devel"
+include gcc-cross_${PV}.bb
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils"
+DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel']]}"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-multilib \
+ --disable-__cxa_atexit \
+ --enable-languages=c \
+ --enable-target-optspace \
+ --program-prefix=${TARGET_PREFIX} \
+ ${@get_gcc_fpu_setting(bb, d)}"
+
+do_stage_prepend () {
+ mkdir -p ${CROSS_DIR}/lib/gcc-lib/${TARGET_SYS}/${PV}
+ ln -sf libgcc.a ${CROSS_DIR}/lib/gcc-lib/${TARGET_SYS}/${PV}/libgcc_eh.a
+}
+
+# Override the method from gcc-cross so we don't try to install libgcc
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}