summaryrefslogtreecommitdiff
path: root/openembedded/packages/gcc/gcc_3.4.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-16 16:20:35 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-16 16:20:35 +0000
commit1a5f0fedce5084690bb478a302d7dd326198afee (patch)
tree4ee4c487b833e01dd4b82eaf4d6ee13578bfd78b /openembedded/packages/gcc/gcc_3.4.4.bb
parentf0d9a3840ce349e606f5a6bfcf552c1adcaf2a46 (diff)
downloadopenembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.tar.gz
openembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.tar.bz2
openembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.tar.xz
openembedded-core-1a5f0fedce5084690bb478a302d7dd326198afee.zip
Add gcc versions 4.0.2, 3.3.4 and 3.4.4
git-svn-id: https://svn.o-hand.com/repos/poky@182 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/gcc/gcc_3.4.4.bb')
-rw-r--r--openembedded/packages/gcc/gcc_3.4.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/openembedded/packages/gcc/gcc_3.4.4.bb b/openembedded/packages/gcc/gcc_3.4.4.bb
new file mode 100644
index 000000000..5be603f2c
--- /dev/null
+++ b/openembedded/packages/gcc/gcc_3.4.4.bb
@@ -0,0 +1,30 @@
+PR = "r5"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
+
+inherit autotools gettext
+
+include gcc-package.inc
+
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://gcc34-reverse-compare.patch;patch=1 \
+ file://gcc34-arm-ldm.patch;patch=1 \
+ file://gcc34-arm-ldm-peephole.patch;patch=1 \
+ file://gcc34-arm-tune.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \
+ file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \
+ file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1 \
+ file://GCC3.4.0VisibilityPatch.diff;patch=1 \
+ file://15342.patch;patch=1 \
+ file://always-fixincperm.patch;patch=1"
+
+SRC_URI += "file://gcc34-configure.in.patch;patch=1"
+SRC_URI += "file://gcc34-thumb-support.patch;patch=1"
+
+include gcc3-build.inc