summaryrefslogtreecommitdiff
path: root/openembedded/packages/gtkhtml2
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-10-06 11:42:44 +0000
committerChris Lord <chris@openedhand.com>2005-10-06 11:42:44 +0000
commit7469e31faccee9fe1021507281edd7da8d5221ec (patch)
tree81b3b8693ea748661b7b170c90646dcdaa446ef5 /openembedded/packages/gtkhtml2
parentbab73940ce94653d4ef855a5f7979cb0030f689c (diff)
downloadopenembedded-core-7469e31faccee9fe1021507281edd7da8d5221ec.tar.gz
openembedded-core-7469e31faccee9fe1021507281edd7da8d5221ec.tar.bz2
openembedded-core-7469e31faccee9fe1021507281edd7da8d5221ec.tar.xz
openembedded-core-7469e31faccee9fe1021507281edd7da8d5221ec.zip
Add libgtkhtml-2.0
git-svn-id: https://svn.o-hand.com/repos/poky@124 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/gtkhtml2')
-rwxr-xr-xopenembedded/packages/gtkhtml2/gtkhtml2_cvs.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/openembedded/packages/gtkhtml2/gtkhtml2_cvs.bb b/openembedded/packages/gtkhtml2/gtkhtml2_cvs.bb
new file mode 100755
index 000000000..7755cffa2
--- /dev/null
+++ b/openembedded/packages/gtkhtml2/gtkhtml2_cvs.bb
@@ -0,0 +1,22 @@
+SECTION = "libs"
+DEPENDS = "gtk+ glib-2.0 libxml2"
+DESCRIPTION = "A GTK+ HTML rendering library."
+LICENSE = "GPL"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+PV = "0.0cvs${CVSDATE}"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gtkhtml2"
+
+S = "${WORKDIR}/${PN}"
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --disable-accessibility"
+
+do_stage() {
+ oe_libinstall -so -C libgtkhtml libgtkhtml-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
+ ( for i in css document dom dom/core dom/events dom/html dom/traversal dom/views graphics layout layout/html util view; do install -d ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; install -m 0644 ${S}/libgtkhtml/$i/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml/$i; done )
+ install -m 0644 ${S}/libgtkhtml/*.h ${STAGING_INCDIR}/gtkhtml-2.0/libgtkhtml
+}
+