summaryrefslogtreecommitdiff
path: root/openembedded/packages/hal/hal_0.5.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-03 13:07:08 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-03 13:07:08 +0000
commit923c1b061e0197c654a09e33b8443e26c6c1d735 (patch)
treeaacfed081a120f2dcad6d1711518adbd281a743f /openembedded/packages/hal/hal_0.5.4.bb
parent9a725b75ff28d0729af42a355ea89f9edf2c88f6 (diff)
downloadopenembedded-core-923c1b061e0197c654a09e33b8443e26c6c1d735.tar.gz
openembedded-core-923c1b061e0197c654a09e33b8443e26c6c1d735.tar.bz2
openembedded-core-923c1b061e0197c654a09e33b8443e26c6c1d735.tar.xz
openembedded-core-923c1b061e0197c654a09e33b8443e26c6c1d735.zip
Remove linux-openzaurus-2.6.14-rc4 and add hal
git-svn-id: https://svn.o-hand.com/repos/poky@158 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/hal/hal_0.5.4.bb')
-rw-r--r--openembedded/packages/hal/hal_0.5.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/openembedded/packages/hal/hal_0.5.4.bb b/openembedded/packages/hal/hal_0.5.4.bb
new file mode 100644
index 000000000..3db575399
--- /dev/null
+++ b/openembedded/packages/hal/hal_0.5.4.bb
@@ -0,0 +1,31 @@
+SECTION = "unknown"
+DESCRIPTION = "Hardware Abstraction Layer"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "dbus expat libusb"
+RDEPENDS += "hotplug"
+RDEPENDS_hal-device-manager = "python hal python-pygnome"
+RRECOMMENDS = "udev-utils"
+HOMEPAGE = "http://freedesktop.org/Software/hal"
+LICENSE = "GPL LGPL AFL"
+
+SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
+S = "${WORKDIR}/hal-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
+ --with-expat=${STAGING_LIBDIR}/.. \
+ --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
+ --with-hotplug=${sysconfdir}/hotplug.d"
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
+ install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
+}
+
+PACKAGES += "hal-device-manager"
+FILES_${PN} = "${sysconfdir} ${bindir}/lshal ${bindir}/hal-get-property ${bindir}/hal-set-property ${sbindir} ${libdir}/libhal.so* ${libdir}/libhal-storage.so* ${libexecdir} ${datadir}/hal/fdi"
+FILES_hal-device-manager = "${datadir}/hal/device-manager/ ${bindir}/hal-device-manager"
+