summaryrefslogtreecommitdiff
path: root/openembedded/packages/hostap
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-20 07:04:35 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-20 07:04:35 +0000
commitb4a7122cacef647dbec3db5c9ebe1e504a7670df (patch)
tree006885a1f4e8032062632ee1a091e72c32dd2810 /openembedded/packages/hostap
parentf9e1d16bfa73a2df5254c63ae1abb6a4bbe0a062 (diff)
downloadopenembedded-core-b4a7122cacef647dbec3db5c9ebe1e504a7670df.tar.gz
openembedded-core-b4a7122cacef647dbec3db5c9ebe1e504a7670df.tar.bz2
openembedded-core-b4a7122cacef647dbec3db5c9ebe1e504a7670df.tar.xz
openembedded-core-b4a7122cacef647dbec3db5c9ebe1e504a7670df.zip
Updates against mainline OE
git-svn-id: https://svn.o-hand.com/repos/poky@26 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/hostap')
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch11
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch28
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch77
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch70
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch (renamed from openembedded/packages/hostap/hostap-modules-0.4.4/ipaq_compat.patch)0
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff (renamed from openembedded/packages/hostap/hostap-modules-0.4.4/mtx_compat.diff)0
-rw-r--r--openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff (renamed from openembedded/packages/hostap/hostap-modules-0.4.4/mtx_hostap_deferred_irq.diff)0
-rw-r--r--openembedded/packages/hostap/hostap-modules_0.3.9.bb (renamed from openembedded/packages/hostap/hostap-modules_0.4.4.bb)8
8 files changed, 192 insertions, 2 deletions
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch
new file mode 100644
index 000000000..2fc5e9ed4
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/Makefile.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
++++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ VERFILE := $(KERNEL_PATH)/include/linux/version.h
+ KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
+- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
++ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
+ else uname -r; fi)
+ KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
+ sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch
new file mode 100644
index 000000000..d5f2a10e8
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/add_event.patch
@@ -0,0 +1,28 @@
+Index: hostap-driver-0.3.7/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-08-03 17:05:53.000000000 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-08-03 17:07:59.000000000 +0100
+@@ -526,11 +526,13 @@
+ dev_list = link;
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask = CS_EVENT_CARD_INSERTION |
+ CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &prism2_event;
++#endif
+ client_reg.Version = 0x0210;
+ client_reg.event_callback_args.client_data = link;
+ ret = pcmcia_register_client(&link->handle, &client_reg);
+@@ -913,6 +915,9 @@
+ .name = "hostap_cs",
+ },
+ .attach = prism2_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = prism2_event,
++#endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,
+ };
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch
new file mode 100644
index 000000000..c29cc8d2c
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap-utsname.patch
@@ -0,0 +1,77 @@
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
+@@ -25,6 +25,7 @@
+ #include <linux/if_arp.h>
+ #include <linux/delay.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
+@@ -15,6 +15,7 @@
+ #include <linux/init.h>
+ #include <linux/slab.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
+@@ -12,6 +12,7 @@
+ #include <linux/timer.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
+@@ -11,6 +11,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
+@@ -14,6 +14,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
diff --git a/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch
new file mode 100644
index 000000000..05f716e22
--- /dev/null
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/hostap_cardid.patch
@@ -0,0 +1,70 @@
+Index: hostap-driver-0.3.9/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.9.orig/driver/modules/hostap_cs.c 2005-08-24 10:11:47.000000000 +0100
++++ hostap-driver-0.3.9/driver/modules/hostap_cs.c 2005-08-24 10:39:10.000000000 +0100
+@@ -908,6 +908,57 @@
+ return 0;
+ }
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id hostap_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7100),
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x0101, 0x0777),
++ PCMCIA_DEVICE_MANF_CARD(0x0126, 0x8000),
++ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0250, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1612),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02d2, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0xc00f, 0x0000),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0010),
++ PCMCIA_MFC_DEVICE_PROD_ID12(0, "SanDisk", "ConnectPlus",
++ 0x7a954bd9, 0x74be00c6),
++ PCMCIA_DEVICE_PROD_ID1234(
++ "Intersil", "PRISM 2_5 PCMCIA ADAPTER", "ISL37300P",
++ "Eval-RevA",
++ 0x4b801a17, 0x6345a0bf, 0xc9049a39, 0xc23adc0e),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Addtron", "AWP-100 Wireless PCMCIA", "Version 01.02",
++ 0xe6ec52ce, 0x08649af2, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "D", "Link DWL-650 11Mbps WLAN Card", "Version 01.02",
++ 0x71b18589, 0xb6f1b0ab, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Instant Wireless ", " Network PC CARD", "Version 01.02",
++ 0x11d901af, 0x6e9bd926, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "SMC", "SMC2632W", "Version 01.02",
++ 0xc4f8b18b, 0x474a1f2a, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID12("Compaq", "WL200_11Mbps_Wireless_PCI_Card",
++ 0x54f7c49c, 0x15a75e5b),
++ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE",
++ 0x74c5e40d, 0xdb472a18),
++ PCMCIA_DEVICE_PROD_ID12("Linksys", "Wireless CompactFlash Card",
++ 0x0733cc81, 0x0c52f395),
++ PCMCIA_DEVICE_PROD_ID12(
++ "ZoomAir 11Mbps High", "Rate wireless Networking",
++ 0x273fe3db, 0x32a1eaee),
++ PCMCIA_DEVICE_NULL
++};
++MODULE_DEVICE_TABLE(pcmcia, hostap_cs_ids);
++#endif
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
+ static struct pcmcia_driver hostap_driver = {
+@@ -917,6 +968,7 @@
+ .attach = prism2_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = prism2_event,
++ .id_table = hostap_cs_ids,
+ #endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,
diff --git a/openembedded/packages/hostap/hostap-modules-0.4.4/ipaq_compat.patch b/openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch
index b139ef38f..b139ef38f 100644
--- a/openembedded/packages/hostap/hostap-modules-0.4.4/ipaq_compat.patch
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/ipaq_compat.patch
diff --git a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_compat.diff b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff
index c2d6662d6..c2d6662d6 100644
--- a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_compat.diff
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_compat.diff
diff --git a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_hostap_deferred_irq.diff b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff
index e979b72d9..e979b72d9 100644
--- a/openembedded/packages/hostap/hostap-modules-0.4.4/mtx_hostap_deferred_irq.diff
+++ b/openembedded/packages/hostap/hostap-modules-0.3.9/mtx_hostap_deferred_irq.diff
diff --git a/openembedded/packages/hostap/hostap-modules_0.4.4.bb b/openembedded/packages/hostap/hostap-modules_0.3.9.bb
index fd7a3eaff..1be1e6a77 100644
--- a/openembedded/packages/hostap/hostap-modules_0.4.4.bb
+++ b/openembedded/packages/hostap/hostap-modules_0.3.9.bb
@@ -3,10 +3,14 @@ SECTION = "kernel/modules"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
+PR = "r4"
SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
- file://hostap_cs.conf "
-
+ file://hostap_cs.conf \
+ file://Makefile.patch;patch=1 \
+ file://add_event.patch;patch=1 \
+ file://hostap-utsname.patch;patch=1 \
+ file://hostap_cardid.patch;patch=1"
SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "