summaryrefslogtreecommitdiff
path: root/openembedded/packages/jpeg/jpeg_6b.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
commit4b46c1f6e891b1ddd5968536440b888661fade3e (patch)
treee0ba2c1f56f61b868bf746da5c4feabb25b800b2 /openembedded/packages/jpeg/jpeg_6b.bb
downloadopenembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.gz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.bz2
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.xz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.zip
Initial population
git-svn-id: https://svn.o-hand.com/repos/poky@1 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/jpeg/jpeg_6b.bb')
-rw-r--r--openembedded/packages/jpeg/jpeg_6b.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/openembedded/packages/jpeg/jpeg_6b.bb b/openembedded/packages/jpeg/jpeg_6b.bb
new file mode 100644
index 000000000..49e0382b6
--- /dev/null
+++ b/openembedded/packages/jpeg/jpeg_6b.bb
@@ -0,0 +1,35 @@
+SECTION = "libs"
+PRIORITY = "required"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "libtool-cross"
+DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
+PACKAGES =+ "jpeg-tools "
+FILES_jpeg-tools = "${bindir}"
+LICENSE ="jpeg"
+SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
+ file://debian.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://paths.patch;patch=1"
+S = "${WORKDIR}/jpeg-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-static --enable-shared"
+EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR}/${HOST_SYS}-libtool"'
+
+CFLAGS_append = " -D_REENTRANT"
+
+do_stage() {
+ install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
+ install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
+ install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
+ install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
+ install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
+ oe_libinstall -so libjpeg ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir} ${D}${includedir} \
+ ${D}${mandir}/man1 ${D}${libdir}
+ oe_runmake 'DESTDIR=${D}' install
+}