summaryrefslogtreecommitdiff
path: root/openembedded/packages/libdaemon
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
commit95efeafc86f47592b37c44f2f7314324cc04250d (patch)
treee60fe38e88d8e6cf42cf1311c5ada752b79a59c7 /openembedded/packages/libdaemon
parent7755d9d194b42ea859096f805f2e22ae5b6e6281 (diff)
downloadopenembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.gz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.bz2
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.xz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.zip
Add gtk+, avahi, dbus-0.34 (.36 coming soon) and dependencies. Fix x11-common breakage.
git-svn-id: https://svn.o-hand.com/repos/poky@13 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/libdaemon')
-rw-r--r--openembedded/packages/libdaemon/libdaemon_0.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/openembedded/packages/libdaemon/libdaemon_0.6.bb b/openembedded/packages/libdaemon/libdaemon_0.6.bb
new file mode 100644
index 000000000..578c9b767
--- /dev/null
+++ b/openembedded/packages/libdaemon/libdaemon_0.6.bb
@@ -0,0 +1,18 @@
+SECTION = "libs"
+DESCRIPTION = "libdaemon is a lightweight C library which eases the writing of UNIX daemons."
+HOMEPAGE = "http://0pointer.de/lennart/projects/libdaemon/"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://0pointer.de/lennart/projects/libdaemon/libdaemon-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-lynx --disable-doxygen"
+
+do_stage () {
+ oe_libinstall -a -so -C src libdaemon ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libdaemon
+ for i in dlog.h dexec.h dfork.h dsignal.h dnonblock.h dpid.h; do
+ install -m 0644 ${S}/src/$i ${STAGING_INCDIR}/libdaemon/
+ done
+}