summaryrefslogtreecommitdiff
path: root/openembedded/packages/libgpg-error/libgpg-error_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
commit95efeafc86f47592b37c44f2f7314324cc04250d (patch)
treee60fe38e88d8e6cf42cf1311c5ada752b79a59c7 /openembedded/packages/libgpg-error/libgpg-error_1.0.bb
parent7755d9d194b42ea859096f805f2e22ae5b6e6281 (diff)
downloadopenembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.gz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.bz2
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.xz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.zip
Add gtk+, avahi, dbus-0.34 (.36 coming soon) and dependencies. Fix x11-common breakage.
git-svn-id: https://svn.o-hand.com/repos/poky@13 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/libgpg-error/libgpg-error_1.0.bb')
-rw-r--r--openembedded/packages/libgpg-error/libgpg-error_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/openembedded/packages/libgpg-error/libgpg-error_1.0.bb b/openembedded/packages/libgpg-error/libgpg-error_1.0.bb
new file mode 100644
index 000000000..c29053832
--- /dev/null
+++ b/openembedded/packages/libgpg-error/libgpg-error_1.0.bb
@@ -0,0 +1,28 @@
+PR = "r0"
+DESCRIPTION = "GPG-Error library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
+ file://pkgconfig.patch;patch=1"
+
+# move libgpg-error-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"
+
+inherit autotools binconfig pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
+ install -m 0755 src/gpg-error-config ${STAGING_BINDIR}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gpg-error.h
+ do
+ install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
+}