summaryrefslogtreecommitdiff
path: root/openembedded/packages/libxcursor/libxcursor_1.1.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
commit95efeafc86f47592b37c44f2f7314324cc04250d (patch)
treee60fe38e88d8e6cf42cf1311c5ada752b79a59c7 /openembedded/packages/libxcursor/libxcursor_1.1.2.bb
parent7755d9d194b42ea859096f805f2e22ae5b6e6281 (diff)
downloadopenembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.gz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.bz2
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.tar.xz
openembedded-core-95efeafc86f47592b37c44f2f7314324cc04250d.zip
Add gtk+, avahi, dbus-0.34 (.36 coming soon) and dependencies. Fix x11-common breakage.
git-svn-id: https://svn.o-hand.com/repos/poky@13 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/libxcursor/libxcursor_1.1.2.bb')
-rw-r--r--openembedded/packages/libxcursor/libxcursor_1.1.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/openembedded/packages/libxcursor/libxcursor_1.1.2.bb b/openembedded/packages/libxcursor/libxcursor_1.1.2.bb
new file mode 100644
index 000000000..d948ff50d
--- /dev/null
+++ b/openembedded/packages/libxcursor/libxcursor_1.1.2.bb
@@ -0,0 +1,23 @@
+SECTION = "x11/libs"
+LICENSE= "BSD-X"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DESCRIPTION = "X Cursor library"
+DEPENDS = "libxfixes"
+PR = "r2"
+
+SRC_URI = "${XLIBS_MIRROR}/libXcursor-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/libXcursor-${PV}"
+FILES_${PN} += "${libdir}/libXcursor.so"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR}/man
+}