summaryrefslogtreecommitdiff
path: root/openembedded/packages/libxi
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-30 14:28:18 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-30 14:28:18 +0000
commitb86b4ae5db5c0fbfecb85584f486a17ec0b46437 (patch)
tree51f20ee7f13090389d69cb60110ab403f27b0d8f /openembedded/packages/libxi
parent06b04dcace4eb99f565b8959d5b7ba1a4ae7f00a (diff)
downloadopenembedded-core-b86b4ae5db5c0fbfecb85584f486a17ec0b46437.tar.gz
openembedded-core-b86b4ae5db5c0fbfecb85584f486a17ec0b46437.tar.bz2
openembedded-core-b86b4ae5db5c0fbfecb85584f486a17ec0b46437.tar.xz
openembedded-core-b86b4ae5db5c0fbfecb85584f486a17ec0b46437.zip
Add minimo (+ deps: zip, libxi). Update puzzzles to include icon. Update meta packages with new programs.
git-svn-id: https://svn.o-hand.com/repos/poky@86 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/libxi')
-rw-r--r--openembedded/packages/libxi/files/autofoo.patch12
-rw-r--r--openembedded/packages/libxi/libxi_6.0.1.bb20
2 files changed, 32 insertions, 0 deletions
diff --git a/openembedded/packages/libxi/files/autofoo.patch b/openembedded/packages/libxi/files/autofoo.patch
new file mode 100644
index 000000000..f1bce9ed7
--- /dev/null
+++ b/openembedded/packages/libxi/files/autofoo.patch
@@ -0,0 +1,12 @@
+Index: libXi-6.0.1/configure.ac
+===================================================================
+--- libXi-6.0.1.orig/configure.ac 2003-11-01 04:11:49.000000000 -0500
++++ libXi-6.0.1/configure.ac 2005-01-20 11:34:06.878357352 -0500
+@@ -8,7 +8,6 @@
+ AM_MAINTAINER_MODE
+
+ AM_CONFIG_HEADER([config.h])
+-AC_CONFIG_AUX_DIR(.)
+
+ # Checks for programs.
+ AC_PROG_LIBTOOL
diff --git a/openembedded/packages/libxi/libxi_6.0.1.bb b/openembedded/packages/libxi/libxi_6.0.1.bb
new file mode 100644
index 000000000..b84aef819
--- /dev/null
+++ b/openembedded/packages/libxi/libxi_6.0.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "X Input Extension library"
+LICENSE = "MIT-X"
+SECTION = "x11/libs"
+DEPENDS = "xproto x11 xextensions"
+PR = "r1"
+
+SRC_URI = "${XLIBS_MIRROR}/libXi-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/libXi-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}
+