summaryrefslogtreecommitdiff
path: root/openembedded/packages/linux-libc-headers
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
committerRichard Purdie <richard@openedhand.com>2005-08-31 10:45:47 +0000
commit4b46c1f6e891b1ddd5968536440b888661fade3e (patch)
treee0ba2c1f56f61b868bf746da5c4feabb25b800b2 /openembedded/packages/linux-libc-headers
downloadopenembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.gz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.bz2
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.xz
openembedded-core-4b46c1f6e891b1ddd5968536440b888661fade3e.zip
Initial population
git-svn-id: https://svn.o-hand.com/repos/poky@1 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/linux-libc-headers')
-rw-r--r--openembedded/packages/linux-libc-headers/files/keyboard.patch78
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch72
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff11
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb64
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb56
-rw-r--r--openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb61
6 files changed, 342 insertions, 0 deletions
diff --git a/openembedded/packages/linux-libc-headers/files/keyboard.patch b/openembedded/packages/linux-libc-headers/files/keyboard.patch
new file mode 100644
index 000000000..7df00418b
--- /dev/null
+++ b/openembedded/packages/linux-libc-headers/files/keyboard.patch
@@ -0,0 +1,78 @@
+--- kernel/include/linux/keyboard.h 2004-01-17 23:04:30.000000000 +0000
++++ kernel/include/linux/keyboard.h 2004-08-30 12:49:41.000000000 +0100
+@@ -37,6 +44,8 @@
+ #define KT_ASCII 9
+ #define KT_LOCK 10
+ #define KT_SLOCK 12
++#define KT_X 13 /* A few useful symbols from the base X Keysym set, that go with... */
++#define KT_XF 14 /* The XFree86 Internet multimedia and PDA keyboard symbols */
+
+ #define K(t,v) (((t)<<8)|(v))
+ #define KTYP(x) ((x) >> 8)
+@@ -421,4 +430,66 @@
+ #define NR_LOCK 8
+
+ #define MAX_DIACR 256
++
++/*
++ * modifications to this section of this list should be coordinated with
++ * the X Window System keysym list; life is much easier that way
++ *
++ */
++
++/* These don't correspond identically. */
++#define K_XMENU K(KT_X, 0x1)
++#define K_XTELEPHONE K(KT_X, 0x2)
++
++/*
++ * XFree86 vendor specific keysyms.
++ *
++ * These map to XFree86 X keysym range is 0x1008FF01 - 0x1008FFFF;
++ * for simplicity's sake, we'll define a simple identity mapping for these.
++ *
++ * Please coordinate changes here with XFree86.org, so this simple
++ * identity mapping can be maintained (and old code "just works").
++ *
++ * Keys found on some "Internet" keyboards.
++ */
++#define K_XFSTANDBY K(KT_XF,0x10)
++#define K_XFAUDIOLOWERVOLUME K(KT_XF,0x11)
++#define K_XFAUDIOMUTE K(KT_XF,0x12)
++#define K_XFAUDIORAISEVOLUME K(KT_XF,0x13)
++#define K_XFAUDIOPLAY K(KT_XF,0x14)
++#define K_XFAUDIOSTOP K(KT_XF,0x15)
++#define K_XFAUDIOPREV K(KT_XF,0x16)
++#define K_XFAUDIONEXT K(KT_XF,0x17)
++#define K_XFHOMEPAGE K(KT_XF,0x18)
++#define K_XFMAIL K(KT_XF,0x19)
++#define K_XFSTART K(KT_XF,0x1A)
++#define K_XFSEARCH K(KT_XF,0x1B)
++#define K_XFAUDIORECORD K(KT_XF,0x1C)
++
++/* These are sometimes found on PDA's (e.g. Palm, PocketPC or elsewhere) */
++#define K_XFCALCULATOR K(KT_XF,0x1D)
++#define K_XFMEMO K(KT_XF,0x1E)
++#define K_XFTODOLIST K(KT_XF,0x1F)
++#define K_XFCALENDAR K(KT_XF,0x20)
++#define K_XFPOWERDOWN K(KT_XF,0x21)
++#define K_XFCONTRASTADJUST K(KT_XF,0x22)
++#define K_XFROCKERUP K(KT_XF,0x23)
++#define K_XFROCKERDOWN K(KT_XF,0x24)
++#define K_XFROCKERENTER K(KT_XF,0x25)
++
++/* Some more "Internet" keyboard symbols */
++#define K_XFBACK K(KT_XF,0x26)
++#define K_XFFORWARD K(KT_XF,0x27)
++#define K_XFSTOP K(KT_XF,0x28)
++#define K_XFREFRESH K(KT_XF,0x29)
++
++/* Some more ... */
++#define K_XFFAVORITES K(KT_XF,0x30)
++#define K_XFAUDIOPAUSE K(KT_XF,0x31)
++#define K_XFAUDIOMEDIA K(KT_XF,0x32)
++#define K_XFMYCOMPUTER K(KT_XF,0x33)
++#define K_XFVENDORHOME K(KT_XF,0x34)
++#define K_XFLIGHTBULB K(KT_XF,0x35)
++#define K_XFSHOP K(KT_XF,0x36)
++
+ #endif
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch b/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
new file mode 100644
index 000000000..e97650a9d
--- /dev/null
+++ b/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.7.0/sh-missing.patch
@@ -0,0 +1,72 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh4/sigcontext.h 2004-08-27 17:56:59.000000000 -0500
+@@ -0,0 +1,24 @@
++#ifndef __ASM_CPU_SH4_SIGCONTEXT_H
++#define __ASM_CPU_SH4_SIGCONTEXT_H
++
++struct sigcontext {
++ unsigned long oldmask;
++
++ /* CPU registers */
++ unsigned long sc_regs[16];
++ unsigned long sc_pc;
++ unsigned long sc_pr;
++ unsigned long sc_sr;
++ unsigned long sc_gbr;
++ unsigned long sc_mach;
++ unsigned long sc_macl;
++
++ /* FPU registers */
++ unsigned long sc_fpregs[16];
++ unsigned long sc_xfpregs[16];
++ unsigned int sc_fpscr;
++ unsigned int sc_fpul;
++ unsigned int sc_ownedfp;
++};
++
++#endif /* __ASM_CPU_SH4_SIGCONTEXT_H */
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh2/sigcontext.h 2004-08-27 17:57:54.000000000 -0500
+@@ -0,0 +1,17 @@
++#ifndef __ASM_CPU_SH2_SIGCONTEXT_H
++#define __ASM_CPU_SH2_SIGCONTEXT_H
++
++struct sigcontext {
++ unsigned long oldmask;
++
++ /* CPU registers */
++ unsigned long sc_regs[16];
++ unsigned long sc_pc;
++ unsigned long sc_pr;
++ unsigned long sc_sr;
++ unsigned long sc_gbr;
++ unsigned long sc_mach;
++ unsigned long sc_macl;
++};
++
++#endif /* __ASM_CPU_SH2_SIGCONTEXT_H */
+--- /dev/null 2004-06-02 16:28:12.000000000 -0500
++++ linux-libc-headers-2.6.7.0/include/asm-sh/cpu-sh3/sigcontext.h 2004-08-27 17:57:58.000000000 -0500
+@@ -0,0 +1,17 @@
++#ifndef __ASM_CPU_SH3_SIGCONTEXT_H
++#define __ASM_CPU_SH3_SIGCONTEXT_H
++
++struct sigcontext {
++ unsigned long oldmask;
++
++ /* CPU registers */
++ unsigned long sc_regs[16];
++ unsigned long sc_pc;
++ unsigned long sc_pr;
++ unsigned long sc_sr;
++ unsigned long sc_gbr;
++ unsigned long sc_mach;
++ unsigned long sc_macl;
++};
++
++#endif /* __ASM_CPU_SH3_SIGCONTEXT_H */
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff b/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
new file mode 100644
index 000000000..a06b5affd
--- /dev/null
+++ b/openembedded/packages/linux-libc-headers/linux-libc-headers-2.6.8.1/mips-asm-atomic-system.diff
@@ -0,0 +1,11 @@
+--- include/asm-mips/atomic.h.orig 2004-10-01 10:10:05.487734944 +0200
++++ include/asm-mips/atomic.h 2004-10-01 10:10:15.837161592 +0200
+@@ -15,8 +15,6 @@
+ #define _ASM_ATOMIC_H
+
+
+-#include <asm/system.h>
+-
+ typedef struct { volatile int counter; } atomic_t;
+ typedef struct { volatile __s64 counter; } atomic64_t;
+
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
new file mode 100644
index 000000000..c7d6367c7
--- /dev/null
+++ b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -0,0 +1,64 @@
+SECTION = "devel"
+DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
+# license note from the package:
+# Linux-libc-headers are derived from linux kernel headers. For license of a
+# particular header, check it's content, and if copyright notice isn't present,
+# standard linux kernel license applies.
+# since we assume GPL for linux i think we can also assume it here
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
+
+SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
+ file://keyboard.patch;patch=1"
+
+S = "${WORKDIR}/linux-libc-headers-${PV}"
+
+do_configure () {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=ppc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ esac
+ if test ! -e include/asm-$ARCH; then
+ oefatal unable to create asm symlink in kernel headers
+ fi
+ cp -a "include/asm-$ARCH" "include/asm"
+ if test "$ARCH" = "arm"; then
+ cp -a include/asm/arch-ebsa285 include/asm/arch
+ elif test "$ARCH" = "sh"; then
+ cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ fi
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}
+ rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
+ cp -pfLR include/linux ${STAGING_INCDIR}/
+ cp -pfLR include/asm ${STAGING_INCDIR}/
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
+ install -d ${CROSS_DIR}/${TARGET_SYS}/include
+ cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
+ cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
+}
+
+do_install() {
+ install -d ${D}${includedir}
+ cp -pfLR include/linux ${D}${includedir}/
+ cp -pfLR include/asm ${D}${includedir}/
+}
+
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
new file mode 100644
index 000000000..f881d38a3
--- /dev/null
+++ b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.7.0.bb
@@ -0,0 +1,56 @@
+SECTION = "devel"
+DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r3"
+LICENSE = "GPL"
+# NOTE: no need to package these headers, since the c library includes them.
+PACKAGES = ""
+
+SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
+ file://sh-missing.patch;patch=1 \
+ file://keyboard.patch;patch=1"
+S = "${WORKDIR}/linux-libc-headers-${PV}"
+
+do_configure () {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=ppc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ esac
+ if test ! -e include/asm-$ARCH; then
+ oefatal unable to create asm symlink in kernel headers
+ fi
+ cp -a "include/asm-$ARCH" "include/asm"
+ if test "$ARCH" = "arm"; then
+ cp -a include/asm/arch-ebsa285 include/asm/arch
+ elif test "$ARCH" = "sh"; then
+ cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ fi
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}
+ rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
+ cp -pfLR include/linux ${STAGING_INCDIR}/
+ cp -pfLR include/asm ${STAGING_INCDIR}/
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
+ install -d ${CROSS_DIR}/${TARGET_SYS}/include
+ cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
+ cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
+
+ ln -sf ${STAGING_KERNEL_DIR}/include/linux/wireless.h ${STAGING_INCDIR}/linux/wireless.h
+ ln -sf ${STAGING_KERNEL_DIR}/include/linux/wireless.h ${CROSS_DIR}/${TARGET_SYS}/include/linux/wireless.h
+}
diff --git a/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
new file mode 100644
index 000000000..c127e8a9e
--- /dev/null
+++ b/openembedded/packages/linux-libc-headers/linux-libc-headers_2.6.8.1.bb
@@ -0,0 +1,61 @@
+SECTION = "devel"
+DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
+# license note from the package:
+# Linux-libc-headers are derived from linux kernel headers. For license of a
+# particular header, check it's content, and if copyright notice isn't present,
+# standard linux kernel license applies.
+# since we assume GPL for linux i think we can also assume it here
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r7"
+
+# NOTE: no need to package these headers, since the c library includes them.
+PACKAGES = ""
+
+SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
+ file://mips-asm-atomic-system.diff;patch=1;pnum=0 \
+ file://keyboard.patch;patch=1"
+
+S = "${WORKDIR}/linux-libc-headers-${PV}"
+
+do_configure () {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=ppc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ esac
+ if test ! -e include/asm-$ARCH; then
+ oefatal unable to create asm symlink in kernel headers
+ fi
+ cp -a "include/asm-$ARCH" "include/asm"
+ if test "$ARCH" = "arm"; then
+ cp -a include/asm/arch-ebsa285 include/asm/arch
+ elif test "$ARCH" = "sh"; then
+ cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ fi
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}
+ rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
+ cp -pfLR include/linux ${STAGING_INCDIR}/
+ cp -pfLR include/asm ${STAGING_INCDIR}/
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
+ install -d ${CROSS_DIR}/${TARGET_SYS}/include
+ cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
+ cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
+}