summaryrefslogtreecommitdiff
path: root/openembedded/packages/lttng
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-03-22 15:07:03 +0000
committerRichard Purdie <richard@openedhand.com>2006-03-22 15:07:03 +0000
commit91a5b96208f739ab8448081f2c895f80a92412b1 (patch)
tree5c1cb49cca1b557bf0291dd157c667db3a76b9c4 /openembedded/packages/lttng
parent1a630d6ef9a06079771fa1709e8efea1e67b29a5 (diff)
downloadopenembedded-core-91a5b96208f739ab8448081f2c895f80a92412b1.tar.gz
openembedded-core-91a5b96208f739ab8448081f2c895f80a92412b1.tar.bz2
openembedded-core-91a5b96208f739ab8448081f2c895f80a92412b1.tar.xz
openembedded-core-91a5b96208f739ab8448081f2c895f80a92412b1.zip
Add LTTng packages
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@323 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/lttng')
-rw-r--r--openembedded/packages/lttng/lttng-control_0.1.bb14
-rw-r--r--openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch59
-rw-r--r--openembedded/packages/lttng/lttng-modules_0.12.bb22
-rw-r--r--openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb20
4 files changed, 115 insertions, 0 deletions
diff --git a/openembedded/packages/lttng/lttng-control_0.1.bb b/openembedded/packages/lttng/lttng-control_0.1.bb
new file mode 100644
index 000000000..018187741
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-control_0.1.bb
@@ -0,0 +1,14 @@
+SECTION = "devel"
+DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
+extract program execution details from the Linux operating system and \
+interpret them."
+LICENSE = "GPL"
+MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
+
+SRC_URI = "http://ltt.polymtl.ca/lttng/ltt-control-${PV}-11032006.tar.gz"
+
+S = "${WORKDIR}/ltt-control-${PV}-11032006"
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/ltt-control/facilities/*" \ No newline at end of file
diff --git a/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch b/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch
new file mode 100644
index 000000000..68abc7dda
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-modules-0.12/ltt-modules-fixes.patch
@@ -0,0 +1,59 @@
+Index: ltt-modules-0.12/ltt-statedump.c
+===================================================================
+--- ltt-modules-0.12.orig/ltt-statedump.c 2006-03-09 19:33:38.000000000 +0000
++++ ltt-modules-0.12/ltt-statedump.c 2006-03-22 12:43:30.000000000 +0000
+@@ -19,8 +19,14 @@
+ #include <linux/proc_fs.h>
+ #include <linux/file.h>
+ #include <linux/interrupt.h>
+-#include <linux/irq.h>
+ #include <linux/ltt/ltt-facility-statedump.h>
++#ifndef CONFIG_ARM
++#include <linux/irq.h>
++#else
++#include <asm/mach/irq.h>
++#endif
++
++
+
+ #define NB_PROC_CHUNK 20
+
+@@ -160,6 +166,7 @@
+ return 0;
+ }
+
++#ifndef CONFIG_ARM
+ static inline int ltt_enumerate_interrupts(void)
+ {
+ unsigned int i;
+@@ -182,7 +189,9 @@
+
+ return 0;
+ }
+-
++#else
++#define ltt_enumerate_interrupts(x)
++#endif
+
+ static inline int ltt_enumerate_process_states(void)
+ {
+Index: ltt-modules-0.12/Makefile
+===================================================================
+--- ltt-modules-0.12.orig/Makefile 2006-03-11 18:16:17.000000000 +0000
++++ ltt-modules-0.12/Makefile 2006-03-22 12:39:44.000000000 +0000
+@@ -1,9 +1,7 @@
+-ifneq ($(KERNELRELEASE),)
+ ifneq ($(CONFIG_LTT),)
+ obj-m := ltt-control.o ltt-statedump.o
+ endif
+
+-else
+ KERNELDIR ?= /lib/modules/$(shell uname -r)/build
+ PWD := $(shell pwd)
+ KERNELRELEASE = $(shell cat $(KERNELDIR)/$(KBUILD_OUTPUT)/include/linux/version.h | sed -n 's/.*UTS_RELEASE.*\"\(.*\)\".*/\1/p')
+@@ -21,4 +19,4 @@
+
+ clean:
+ $(MAKE) -C $(KERNELDIR) M=$(PWD) clean
+-endif
++
diff --git a/openembedded/packages/lttng/lttng-modules_0.12.bb b/openembedded/packages/lttng/lttng-modules_0.12.bb
new file mode 100644
index 000000000..51f6a05ec
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-modules_0.12.bb
@@ -0,0 +1,22 @@
+SECTION = "devel"
+DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
+extract program execution details from the Linux operating system and \
+interpret them."
+LICENSE = "GPL"
+MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
+
+SRC_URI = "http://ltt.polymtl.ca/lttng/${PN}-${PV}.tar.gz \
+ file://ltt-modules-fixes.patch;patch=1"
+
+S = "${WORKDIR}/ltt-modules-${PV}"
+
+inherit module
+
+export KERNELDIR="${STAGING_KERNEL_DIR}"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+}
+
+FILES = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
diff --git a/openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb b/openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb
new file mode 100644
index 000000000..b76f8b811
--- /dev/null
+++ b/openembedded/packages/lttng/lttng-viewer_0.8.34-20060317.bb
@@ -0,0 +1,20 @@
+SECTION = "devel"
+DESCRIPTION = "The Linux trace toolkit is a suite of tools designed to \
+extract program execution details from the Linux operating system and \
+interpret them."
+LICENSE = "GPL"
+MAINTAINER = "Richrd Purdie <richard@openedhand.com>"
+PR = "r1"
+DEPENDS = "gtk+ pango popt"
+
+ALTNAME = "LinuxTraceToolkitViewer-0.8.34-17032006"
+
+SRC_URI = "http://ltt.polymtl.ca/packages/${ALTNAME}.tar.gz "
+S = "${WORKDIR}/${ALTNAME}"
+
+inherit autotools
+
+FILES_${PN} += "\
+ ${libdir}/lttv/plugins/* \
+ ${datadir}/LinuxTraceToolkitViewer/facilities/* \
+ ${datadir}/LinuxTraceToolkitViewer/pixmaps/* "