summaryrefslogtreecommitdiff
path: root/openembedded/packages/module-init-tools
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-02-10 14:33:55 +0000
committerRichard Purdie <richard@openedhand.com>2006-02-10 14:33:55 +0000
commit5fb35ca11147ed30c619cf93e19331fd835f3da9 (patch)
tree45f05442e8a91453bfea03a29fb3cb96f49d80e5 /openembedded/packages/module-init-tools
parent42dfbb2a0223ba5d091f053ad5401ecce6446e41 (diff)
downloadopenembedded-core-5fb35ca11147ed30c619cf93e19331fd835f3da9.tar.gz
openembedded-core-5fb35ca11147ed30c619cf93e19331fd835f3da9.tar.bz2
openembedded-core-5fb35ca11147ed30c619cf93e19331fd835f3da9.tar.xz
openembedded-core-5fb35ca11147ed30c619cf93e19331fd835f3da9.zip
Apply more chanegs from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@272 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/module-init-tools')
-rw-r--r--openembedded/packages/module-init-tools/files/ignore_arch_directory21
-rw-r--r--openembedded/packages/module-init-tools/files/manpagesopt22
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory24
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt41
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb24
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb15
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools_3.1.bb60
-rw-r--r--openembedded/packages/module-init-tools/module-init-tools_3.2.2.bb (renamed from openembedded/packages/module-init-tools/module-init-tools_3.2.1.bb)0
8 files changed, 37 insertions, 170 deletions
diff --git a/openembedded/packages/module-init-tools/files/ignore_arch_directory b/openembedded/packages/module-init-tools/files/ignore_arch_directory
index 2c7104322..185ea7a3a 100644
--- a/openembedded/packages/module-init-tools/files/ignore_arch_directory
+++ b/openembedded/packages/module-init-tools/files/ignore_arch_directory
@@ -1,25 +1,24 @@
diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8
---- module-init-tools-3.1-pre6.orig/modprobe.8 2004-10-06 02:44:43.000000000 +0200
-+++ module-init-tools-3.1-pre6/modprobe.8 2004-10-09 01:39:01.000000000 +0200
-@@ -30,6 +30,7 @@
- the modules and other files, except for the optional
- \fI/etc/modprobe.conf\fR configuration file
+--- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200
++++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200
+@@ -31,6 +31,7 @@
+ \fI/etc/modprobe.conf\fR configuration file and
+ \fI/etc/modprobe.d\fR directory
(see \fBmodprobe.conf\fR(5)).
+All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored.
.PP
Note that this version of \fBmodprobe\fR does not
do anything to the module itself: the work of resolving symbols
-diff -ruN module-init-tools-3.1-pre6.orig/modprobe.c module-init-tools-3.1-pre6/modprobe.c
---- module-init-tools-3.1-pre6.orig/modprobe.c 2004-10-09 01:40:18.000000000 +0200
-+++ module-init-tools-3.1-pre6/modprobe.c 2004-10-09 01:40:11.000000000 +0200
-@@ -1082,6 +1082,10 @@
- {
+--- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200
++++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200
+@@ -1158,6 +1158,10 @@
DIR *dir;
+ int ret = 0;
+ /* ignore everything in this directory */
+ if (streq(filename, "/etc/modprobe.d/arch"))
+ return 1;
+
- /* If it's a directory, recurse. */
+ /* Reiser4 has file/directory duality: treat it as both. */
dir = opendir(filename);
if (dir) {
diff --git a/openembedded/packages/module-init-tools/files/manpagesopt b/openembedded/packages/module-init-tools/files/manpagesopt
index 2e9d228d5..5d5cac609 100644
--- a/openembedded/packages/module-init-tools/files/manpagesopt
+++ b/openembedded/packages/module-init-tools/files/manpagesopt
@@ -1,7 +1,7 @@
-Index: module-init-tools-3.1/configure.in
+Index: module-init-tools-3.2-pre9/configure.in
===================================================================
---- module-init-tools-3.1.orig/configure.in 2004-11-12 00:05:25.000000000 -0500
-+++ module-init-tools-3.1/configure.in 2005-01-20 02:23:16.409792288 -0500
+--- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000
++++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000
@@ -41,5 +41,14 @@
fi])
AC_SUBST(MODULE_DIR)
@@ -18,22 +18,24 @@ Index: module-init-tools-3.1/configure.in
+AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes")
+AC_OUTPUT([Makefile])
-Index: module-init-tools-3.1/Makefile.am
+Index: module-init-tools-3.2-pre9/Makefile.am
===================================================================
---- module-init-tools-3.1.orig/Makefile.am 2004-07-12 02:11:46.000000000 -0400
-+++ module-init-tools-3.1/Makefile.am 2005-01-20 02:24:32.155277224 -0500
-@@ -21,11 +21,12 @@
+--- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000
++++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000
+@@ -21,13 +21,14 @@
MAN5 = modprobe.conf.5 modules.dep.5
MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
-man_MANS = $(MAN5) $(MAN8)
- mandir = $(shell if [ `echo $(prefix)/ | tr -s /` = / ]; then echo /usr/share/man; else echo $(prefix)/man; fi)
+ # If they haven't overridden mandir, fix it (never /man!)
+ mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
+ TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions
+
+-EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE)
+if MANPAGES
+man_MANS = $(MAN5) $(MAN8)
+endif
--EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ stress_modules.sh install-with-care $(SGML) $(man_MANS)
-
sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static
bin_PROGRAMS = lsmod
diff --git a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory b/openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory
deleted file mode 100644
index 185ea7a3a..000000000
--- a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/ignore_arch_directory
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -ruN module-init-tools-3.1-pre6.orig/modprobe.8 module-init-tools-3.1-pre6/modprobe.8
---- module-init-tools-3.2-pre7/modprobe.8.orig 2005-07-05 13:52:32.000000000 +0200
-+++ module-init-tools-3.2-pre7/modprobe.8 2005-07-05 13:52:42.000000000 +0200
-@@ -31,6 +31,7 @@
- \fI/etc/modprobe.conf\fR configuration file and
- \fI/etc/modprobe.d\fR directory
- (see \fBmodprobe.conf\fR(5)).
-+All files in the \fI/etc/modprobe.d/arch/\fR directory are ignored.
- .PP
- Note that this version of \fBmodprobe\fR does not
- do anything to the module itself: the work of resolving symbols
---- module-init-tools-3.2-pre7/modprobe.c.orig 2005-07-05 13:50:00.000000000 +0200
-+++ module-init-tools-3.2-pre7/modprobe.c 2005-07-05 13:50:15.000000000 +0200
-@@ -1158,6 +1158,10 @@
- DIR *dir;
- int ret = 0;
-
-+ /* ignore everything in this directory */
-+ if (streq(filename, "/etc/modprobe.d/arch"))
-+ return 1;
-+
- /* Reiser4 has file/directory duality: treat it as both. */
- dir = opendir(filename);
- if (dir) {
diff --git a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt b/openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt
deleted file mode 100644
index 5d5cac609..000000000
--- a/openembedded/packages/module-init-tools/module-init-tools-3.2.1/manpagesopt
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: module-init-tools-3.2-pre9/configure.in
-===================================================================
---- module-init-tools-3.2-pre9.orig/configure.in 2005-08-09 04:31:26.000000000 +0000
-+++ module-init-tools-3.2-pre9/configure.in 2005-09-20 22:06:10.000000000 +0000
-@@ -41,5 +41,14 @@
- fi])
- AC_SUBST(MODULE_DIR)
-
--AC_OUTPUT([Makefile])
-+AC_ARG_ENABLE(manpages,
-+[ --disable-manpages Disable man page generation.],
-+[if test x"$enableval" != x"no"; then
-+ enable_manpages=yes
-+else
-+ enable_manpages=no
-+fi],
-+[enable_manpages=yes])
-+AM_CONDITIONAL([MANPAGES], test x"$enable_manpages" = x"yes")
-
-+AC_OUTPUT([Makefile])
-Index: module-init-tools-3.2-pre9/Makefile.am
-===================================================================
---- module-init-tools-3.2-pre9.orig/Makefile.am 2005-08-09 04:54:28.000000000 +0000
-+++ module-init-tools-3.2-pre9/Makefile.am 2005-09-20 22:09:03.000000000 +0000
-@@ -21,13 +21,14 @@
- MAN5 = modprobe.conf.5 modules.dep.5
- MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
- SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
--man_MANS = $(MAN5) $(MAN8)
- # If they haven't overridden mandir, fix it (never /man!)
- mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
-
- TESTSUITE := $(shell find tests -type f ! -name '*~') tests/vg-suppressions
-
--EXTRA_DIST = generate-modprobe.conf modprobe.devfs FAQ CODING stress_modules.sh install-with-care $(SGML) $(man_MANS) $(TESTSUITE)
-+if MANPAGES
-+man_MANS = $(MAN5) $(MAN8)
-+endif
-
- sbin_PROGRAMS = insmod modprobe rmmod depmod modinfo insmod.static
- bin_PROGRAMS = lsmod
diff --git a/openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb
deleted file mode 100644
index 56fec5607..000000000
--- a/openembedded/packages/module-init-tools/module-init-tools-cross_3.1.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-LICENSE = "GPL"
-include module-init-tools_${PV}.bb
-inherit cross
-DEFAULT_PREFERENCE = "0"
-PROVIDES += "virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}depmod-2.6"
-
-PR="r3"
-
-# When cross compiling depmod as shipped cannot handle endian
-# differences between host and target, this fixes the problem.
-# It also solves any possible issues with alignment (only likely
-# if cross compiling for a low alignment target - e.g. x86, on
-# a high alignment host - e.g. SPARC).
-SRC_URI += " file://depmod-byteswap.patch;patch=1 "
-
-EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX}"
-
-do_stage () {
- oe_runmake install
-}
-
-do_install () {
- :
-}
diff --git a/openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb b/openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb
new file mode 100644
index 000000000..4bcc31170
--- /dev/null
+++ b/openembedded/packages/module-init-tools/module-init-tools-cross_3.2.2.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPL"
+include module-init-tools_${PV}.bb
+inherit cross
+DEFAULT_PREFERENCE = "0"
+PROVIDES += "virtual/${TARGET_PREFIX}depmod virtual/${TARGET_PREFIX}depmod-2.6"
+
+EXTRA_OECONF_append = " --program-prefix=${TARGET_PREFIX}"
+
+do_stage () {
+ oe_runmake install
+}
+
+do_install () {
+ :
+}
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.1.bb
deleted file mode 100644
index 62523f513..000000000
--- a/openembedded/packages/module-init-tools/module-init-tools_3.1.bb
+++ /dev/null
@@ -1,60 +0,0 @@
-LICENSE = "GPL"
-SECTION = "base"
-DESCRIPTION = "This package contains a set of programs for loading, inserting, and \
-removing kernel modules for Linux (versions 2.5.48 and above). It serves \
-the same function that the modutils package serves for Linux 2.4."
-PR = "r2"
-
-PACKAGES =+ "module-init-tools-insmod-static module-init-tools-depmod"
-RDEPENDS_${PN} += "module-init-tools-depmod"
-
-FILES_module-init-tools-depmod = "${sbindir}/depmod.26"
-FILES_module-init-tools-insmod-static = "${sbindir}/insmod.static"
-
-SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-${PV}.tar.bz2 \
- file://ignore_arch_directory;patch=1 \
- file://modutils_extension;patch=1 \
- file://no_man_rebuild;patch=1 \
- file://manpagesopt;patch=1 \
- file://soc.patch;patch=1;pnum=0"
-S = "${WORKDIR}/module-init-tools-${PV}"
-
-EXTRA_OECONF = "--disable-manpages"
-
-bindir = "/bin"
-sbindir = "/sbin"
-
-inherit autotools
-
-do_install() {
- autotools_do_install
- for f in bin/lsmod sbin/insmod sbin/rmmod sbin/modprobe sbin/modinfo sbin/depmod; do
- mv ${D}/$f ${D}/$f.26
- done
-}
-
-pkg_postinst_module-init-tools() {
-#!/bin/sh
-for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
-bn=`basename $f`
- update-alternatives --install /$f $bn /$f.26 20
-done
-}
-
-pkg_prerm_module-init-tools() {
-#!/bin/sh
-for f in sbin/insmod sbin/modprobe sbin/rmmod sbin/depmod sbin/modinfo bin/lsmod; do
-bn=`basename $f`
- update-alternatives --remove $bn /$f.26
-done
-}
-
-pkg_postinst_module-init-tools-depmod() {
-#!/bin/sh
-update-alternatives --install /sbin/depmod depmod /sbin/depmod.26 20
-}
-
-pkg_prerm_module-init-tools() {
-#!/bin/sh
-update-alternatives --remove depmod /sbin/depmod.26
-}
diff --git a/openembedded/packages/module-init-tools/module-init-tools_3.2.1.bb b/openembedded/packages/module-init-tools/module-init-tools_3.2.2.bb
index bbd8cca1b..bbd8cca1b 100644
--- a/openembedded/packages/module-init-tools/module-init-tools_3.2.1.bb
+++ b/openembedded/packages/module-init-tools/module-init-tools_3.2.2.bb