summaryrefslogtreecommitdiff
path: root/openembedded/packages/mpfr/mpfr_2.1.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-16 16:23:23 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-16 16:23:23 +0000
commite5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861 (patch)
tree9a1703625d50df42136931ab7a5cb042cd5760b3 /openembedded/packages/mpfr/mpfr_2.1.1.bb
parent1a5f0fedce5084690bb478a302d7dd326198afee (diff)
downloadopenembedded-core-e5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861.tar.gz
openembedded-core-e5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861.tar.bz2
openembedded-core-e5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861.tar.xz
openembedded-core-e5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861.zip
Add gmp and mpfr (needed by gcc 4.0.2)
git-svn-id: https://svn.o-hand.com/repos/poky@183 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/mpfr/mpfr_2.1.1.bb')
-rw-r--r--openembedded/packages/mpfr/mpfr_2.1.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/openembedded/packages/mpfr/mpfr_2.1.1.bb b/openembedded/packages/mpfr/mpfr_2.1.1.bb
new file mode 100644
index 000000000..8b739c080
--- /dev/null
+++ b/openembedded/packages/mpfr/mpfr_2.1.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
+LICENSE = "LGPL"
+MAINTAINER = "Rene Wagner <rw@handhelds.org>"
+SECTION = "libs"
+DEPENDS = "gmp"
+PR = "r1"
+
+SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2"
+S = "${WORKDIR}/mpfr-${PV}"
+
+inherit autotools
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}