summaryrefslogtreecommitdiff
path: root/openembedded/packages/mtd
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /openembedded/packages/mtd
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadopenembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.bz2
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.xz
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.zip
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/mtd')
-rw-r--r--openembedded/packages/mtd/mtd-utils-native_20060223.bb12
-rw-r--r--openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20060131.patch100
-rw-r--r--openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch103
-rw-r--r--openembedded/packages/mtd/mtd-utils/fix-ignoreerrors-20060131.patch20
-rw-r--r--openembedded/packages/mtd/mtd-utils/fix-ignoreerrors.patch20
-rw-r--r--openembedded/packages/mtd/mtd-utils/more-verbosity.patch17
-rw-r--r--openembedded/packages/mtd/mtd-utils_20060223.bb36
7 files changed, 0 insertions, 308 deletions
diff --git a/openembedded/packages/mtd/mtd-utils-native_20060223.bb b/openembedded/packages/mtd/mtd-utils-native_20060223.bb
deleted file mode 100644
index cd1fb7d11..000000000
--- a/openembedded/packages/mtd/mtd-utils-native_20060223.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-LICENSE = "GPLv2"
-SECTION = "base"
-include mtd-utils_${PV}.bb
-inherit native
-DEPENDS = "zlib-native"
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/mtd-utils"
-
-do_stage () {
- for binary in ${mtd_utils}; do
- install -m 0755 util/$binary ${STAGING_BINDIR}/
- done
-}
diff --git a/openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20060131.patch b/openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20060131.patch
deleted file mode 100644
index e24f39589..000000000
--- a/openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-20060131.patch
+++ /dev/null
@@ -1,100 +0,0 @@
---- mtd/util/mkfs.jffs2.c~add-exclusion-to-mkfs-jffs2.patch
-+++ mtd/util/mkfs.jffs2.c
-@@ -92,7 +92,12 @@
- struct filesystem_entry *files; /* Only relevant to directories */
- };
-
--
-+struct ignorepath_entry {
-+ struct ignorepath_entry* next; /* Points to the next ignorepath element */
-+ char name[PATH_MAX]; /* Name of the entry */
-+};
-+
-+static struct ignorepath_entry* ignorepath = 0;
- static int out_fd = -1;
- static int in_fd = -1;
- static char default_rootdir[] = ".";
-@@ -367,7 +372,7 @@
- char *hpath, *tpath;
- struct dirent *dp, **namelist;
- struct filesystem_entry *entry;
--
-+ struct ignorepath_entry* element = ignorepath;
-
- if (lstat(hostpath, &sb)) {
- perror_msg_and_die("%s", hostpath);
-@@ -376,6 +381,15 @@
- entry = add_host_filesystem_entry(targetpath, hostpath,
- sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
-
-+ while ( element ) {
-+ if ( strcmp( element->name, targetpath ) == 0 ) {
-+ printf( "Note: ignoring directories below '%s'\n", targetpath );
-+ return entry;
-+ break;
-+ }
-+ element = element->next;
-+ }
-+
- n = scandir(hostpath, &namelist, 0, alphasort);
- if (n < 0) {
- perror_msg_and_die("opening directory %s", hostpath);
-@@ -1157,6 +1171,7 @@
- {"root", 1, NULL, 'r'},
- {"pagesize", 1, NULL, 's'},
- {"eraseblock", 1, NULL, 'e'},
-+ {"ignore", 1, NULL, 'I'},
- {"output", 1, NULL, 'o'},
- {"help", 0, NULL, 'h'},
- {"verbose", 0, NULL, 'v'},
-@@ -1199,6 +1214,7 @@
- " -L, --list-compressors Show the list of the avaiable compressors\n"
- " -t, --test-compression Call decompress and compare with the original (for test)\n"
- " -n, --no-eraseblock-headers Don't add a eraseblock header to every eraseblock\n"
-+ " -I, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
- " -o, --output=FILE Output to FILE (default: stdout)\n"
- " -l, --little-endian Create a little-endian filesystem\n"
- " -b, --big-endian Create a big-endian filesystem\n"
-@@ -1368,11 +1384,12 @@
- struct filesystem_entry *root;
- char *compr_name = NULL;
- int compr_prior = -1;
-+ struct ignorepath_entry* element = ignorepath;
-
- jffs2_compressors_init();
-
- while ((opt = getopt_long(argc, argv,
-- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
-+ "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
- {
- switch (opt) {
- case 'D':
-@@ -1395,6 +1412,28 @@
- page_size = strtol(optarg, NULL, 0);
- break;
-
-+ case 'I':
-+ printf( "Note: Adding '%s' to ignore Path\n", optarg );
-+ element = ignorepath;
-+ if ( !ignorepath ) {
-+ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
-+ ignorepath->next = 0;
-+ strcpy( &ignorepath->name[0], optarg );
-+ } else {
-+ while ( element->next ) element = element->next;
-+ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
-+ element->next->next = 0;
-+ strcpy( &element->next->name[0], optarg );
-+ }
-+ printf( "--------- Dumping ignore path list ----------------\n" );
-+ element = ignorepath;
-+ while ( element ) {
-+ printf( " * '%s'\n", &element->name[0] );
-+ element = element->next;
-+ }
-+ printf( "---------------------------------------------------\n" );
-+ break;
-+
- case 'o':
- if (out_fd != -1) {
- error_msg_and_die("output filename specified more than once");
diff --git a/openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch b/openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
deleted file mode 100644
index 3ac41280b..000000000
--- a/openembedded/packages/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- mtd/util/mkfs.jffs2.c~add-exclusion-to-mkfs-jffs2.patch
-+++ mtd/util/mkfs.jffs2.c
-@@ -92,7 +92,12 @@
- struct filesystem_entry *files; /* Only relevant to directories */
- };
-
-+struct ignorepath_entry {
-+ struct ignorepath_entry* next; /* Points to the next ignorepath element */
-+ char name[PATH_MAX]; /* Name of the entry */
-+};
-
-+static struct ignorepath_entry* ignorepath = 0;
- static int out_fd = -1;
- static int in_fd = -1;
- static char default_rootdir[] = ".";
-@@ -367,6 +372,7 @@
- char *hpath, *tpath;
- struct dirent *dp, **namelist;
- struct filesystem_entry *entry;
-+ struct ignorepath_entry* element = ignorepath;
-
-
- if (lstat(hostpath, &sb)) {
-@@ -376,6 +382,15 @@
- entry = add_host_filesystem_entry(targetpath, hostpath,
- sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
-
-+ while ( element ) {
-+ if ( strcmp( element->name, targetpath ) == 0 ) {
-+ printf( "Note: ignoring directories below '%s'\n", targetpath );
-+ return entry;
-+ break;
-+ }
-+ element = element->next;
-+ }
-+
- n = scandir(hostpath, &namelist, 0, alphasort);
- if (n < 0) {
- perror_msg_and_die("opening directory %s", hostpath);
-@@ -1147,6 +1162,7 @@
- {"root", 1, NULL, 'r'},
- {"pagesize", 1, NULL, 's'},
- {"eraseblock", 1, NULL, 'e'},
-+ {"ignore", 1, NULL, 'I'},
- {"output", 1, NULL, 'o'},
- {"help", 0, NULL, 'h'},
- {"verbose", 0, NULL, 'v'},
-@@ -1189,6 +1205,7 @@
- " -L, --list-compressors Show the list of the avaiable compressors\n"
- " -t, --test-compression Call decompress and compare with the original (for test)\n"
- " -n, --no-cleanmarkers Don't add a cleanmarker to every eraseblock\n"
-+ " -I, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
- " -o, --output=FILE Output to FILE (default: stdout)\n"
- " -l, --little-endian Create a little-endian filesystem\n"
- " -b, --big-endian Create a big-endian filesystem\n"
-@@ -1349,11 +1366,12 @@
- struct filesystem_entry *root;
- char *compr_name = NULL;
- int compr_prior = -1;
-+ struct ignorepath_entry* element = ignorepath;
-
- jffs2_compressors_init();
-
- while ((opt = getopt_long(argc, argv,
-- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
-+ "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
- {
- switch (opt) {
- case 'D':
-@@ -1376,6 +1394,28 @@
- page_size = strtol(optarg, NULL, 0);
- break;
-
-+ case 'I':
-+ printf( "Note: Adding '%s' to ignore Path\n", optarg );
-+ element = ignorepath;
-+ if ( !ignorepath ) {
-+ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
-+ ignorepath->next = 0;
-+ strcpy( &ignorepath->name[0], optarg );
-+ } else {
-+ while ( element->next ) element = element->next;
-+ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
-+ element->next->next = 0;
-+ strcpy( &element->next->name[0], optarg );
-+ }
-+ printf( "--------- Dumping ignore path list ----------------\n" );
-+ element = ignorepath;
-+ while ( element ) {
-+ printf( " * '%s'\n", &element->name[0] );
-+ element = element->next;
-+ }
-+ printf( "---------------------------------------------------\n" );
-+ break;
-+
- case 'o':
- if (out_fd != -1) {
- error_msg_and_die("output filename specified more than once");
diff --git a/openembedded/packages/mtd/mtd-utils/fix-ignoreerrors-20060131.patch b/openembedded/packages/mtd/mtd-utils/fix-ignoreerrors-20060131.patch
deleted file mode 100644
index 8266a37c4..000000000
--- a/openembedded/packages/mtd/mtd-utils/fix-ignoreerrors-20060131.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- mtd/util/nanddump.c.orig 2006-01-30 21:19:22.000000000 +0100
-+++ mtd/util/nanddump.c 2006-01-30 21:19:24.000000000 +0100
-@@ -224,7 +224,7 @@
- }
- }
-
-- if (badblock) {
-+ if (badblock && !ignoreerrors) {
- if (omitbad)
- continue;
- memset (readbuf, 0xff, bs);
-@@ -259,7 +259,7 @@
- if (omitoob)
- continue;
-
-- if (badblock) {
-+ if (badblock && !ignoreerrors) {
- memset (readbuf, 0xff, meminfo.oobsize);
- } else {
- /* Read OOB data and exit on failure */
diff --git a/openembedded/packages/mtd/mtd-utils/fix-ignoreerrors.patch b/openembedded/packages/mtd/mtd-utils/fix-ignoreerrors.patch
deleted file mode 100644
index b1f702a31..000000000
--- a/openembedded/packages/mtd/mtd-utils/fix-ignoreerrors.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- mtd/util/nanddump.c.orig 2005-12-30 19:07:39.000000000 +0100
-+++ mtd/util/nanddump.c 2005-12-30 19:08:53.000000000 +0100
-@@ -224,7 +224,7 @@
- }
- }
-
-- if (badblock) {
-+ if (badblock && !ignoreerrors) {
- if (omitbad)
- continue;
- memset (readbuf, 0xff, bs);
-@@ -259,7 +259,7 @@
- if (omitoob)
- continue;
-
-- if (badblock) {
-+ if (badblock && !ignoreerrors) {
- memset (readbuf, 0xff, meminfo.oobsize);
- } else {
- /* Read OOB data and exit on failure */
diff --git a/openembedded/packages/mtd/mtd-utils/more-verbosity.patch b/openembedded/packages/mtd/mtd-utils/more-verbosity.patch
deleted file mode 100644
index cdc842a8f..000000000
--- a/openembedded/packages/mtd/mtd-utils/more-verbosity.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- mtd/util/mkfs.jffs2.c~more-verbosity.patch
-+++ mtd/util/mkfs.jffs2.c
-@@ -374,6 +374,9 @@
- struct filesystem_entry *entry;
- struct ignorepath_entry* element = ignorepath;
-
-+ if (verbose) {
-+ printf( "mkfs.jffs2: scanning '%s'...\n", targetpath );
-+ }
-
- if (lstat(hostpath, &sb)) {
- perror_msg_and_die("%s", hostpath);
diff --git a/openembedded/packages/mtd/mtd-utils_20060223.bb b/openembedded/packages/mtd/mtd-utils_20060223.bb
deleted file mode 100644
index 21d0f21fc..000000000
--- a/openembedded/packages/mtd/mtd-utils_20060223.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Tools for managing memory technology devices."
-SECTION = "base"
-DEPENDS = "zlib"
-HOMEPAGE = "http://www.linux-mtd.infradead.org/"
-LICENSE = "GPLv2"
-PR = "r0"
-SRCDATE = "${PV}"
-
-SRC_URI = "cvs://anoncvs:anoncvs@cvs.infradead.org/home/cvs;module=mtd \
- file://add-exclusion-to-mkfs-jffs2-20060131.patch;patch=1 \
- file://fix-ignoreerrors-20060131.patch;patch=1"
-S = "${WORKDIR}/mtd/"
-
-CFLAGS_prepend = "-I${S}/include "
-
-do_compile () {
- oe_runmake -C util ${mtd_utils}
-}
-
-do_stage () {
- install -d ${STAGING_INCDIR}/mtd
- for f in ${S}/include/mtd/*.h; do
- install -m 0644 $f ${STAGING_INCDIR}/mtd/
- done
-}
-
-mtd_utils = "ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
- mkfs.jffs ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
- flashcp nandwrite jffs2dump sumtool"
-
-do_install () {
- install -d ${D}${bindir}
- for binary in ${mtd_utils}; do
- install -m 0755 util/$binary ${D}${bindir}
- done
-}