summaryrefslogtreecommitdiff
path: root/openembedded/packages/oh
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-28 17:31:21 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-28 17:31:21 +0000
commitcb47354f1ce201e7b2d16698be19055c0d15c984 (patch)
tree14275fd46cef4a1e103864094231bc4875bddc1c /openembedded/packages/oh
parentdd2bd6254c9649e5301d7a45b086c23053d895d1 (diff)
downloadopenembedded-core-cb47354f1ce201e7b2d16698be19055c0d15c984.tar.gz
openembedded-core-cb47354f1ce201e7b2d16698be19055c0d15c984.tar.bz2
openembedded-core-cb47354f1ce201e7b2d16698be19055c0d15c984.tar.xz
openembedded-core-cb47354f1ce201e7b2d16698be19055c0d15c984.zip
Add usbinit hack to get usbnet connection on 770 (will replace with udev in due course)
git-svn-id: https://svn.o-hand.com/repos/poky@53 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/oh')
-rw-r--r--openembedded/packages/oh/usbinit.bb19
-rwxr-xr-xopenembedded/packages/oh/usbinit/usb-gether19
2 files changed, 38 insertions, 0 deletions
diff --git a/openembedded/packages/oh/usbinit.bb b/openembedded/packages/oh/usbinit.bb
new file mode 100644
index 000000000..bfc8490dc
--- /dev/null
+++ b/openembedded/packages/oh/usbinit.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Quick hack to start gadget Ethernet on the 770"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "file://usb-gether"
+S = ${WORKDIR}
+
+do_install() {
+ install -d ${D}/etc
+ install -d ${D}/etc/init.d
+ install usb-gether ${D}/etc/init.d
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "usb-gether"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
diff --git a/openembedded/packages/oh/usbinit/usb-gether b/openembedded/packages/oh/usbinit/usb-gether
new file mode 100755
index 000000000..590e77b22
--- /dev/null
+++ b/openembedded/packages/oh/usbinit/usb-gether
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+case "$1" in
+ start)
+ /sbin/depmod -a
+ /sbin/modprobe g_ether
+ ifconfig usb0 192.168.1.120
+ ;;
+
+ stop)
+
+ ;;
+
+ *)
+ echo "usage: $0 { start | stop }"
+ ;;
+esac
+
+exit 0