summaryrefslogtreecommitdiff
path: root/openembedded/packages/oprofile/oprofile_cvs.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-12-23 00:03:36 +0000
committerRichard Purdie <richard@openedhand.com>2005-12-23 00:03:36 +0000
commitf2bf93642c1280ac5952ed2373e61818c0d2f969 (patch)
tree45d095a0d05338b81b23d39e47bb1d2c4fac4c88 /openembedded/packages/oprofile/oprofile_cvs.bb
parenta096c6622f0172a6169bc9a52e62cce277694f73 (diff)
downloadopenembedded-core-f2bf93642c1280ac5952ed2373e61818c0d2f969.tar.gz
openembedded-core-f2bf93642c1280ac5952ed2373e61818c0d2f969.tar.bz2
openembedded-core-f2bf93642c1280ac5952ed2373e61818c0d2f969.tar.xz
openembedded-core-f2bf93642c1280ac5952ed2373e61818c0d2f969.zip
Remove gnome-vfs dependency from contacts (for now) and add oprofile
git-svn-id: https://svn.o-hand.com/repos/poky@211 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/oprofile/oprofile_cvs.bb')
-rw-r--r--openembedded/packages/oprofile/oprofile_cvs.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/openembedded/packages/oprofile/oprofile_cvs.bb b/openembedded/packages/oprofile/oprofile_cvs.bb
new file mode 100644
index 000000000..277c1835c
--- /dev/null
+++ b/openembedded/packages/oprofile/oprofile_cvs.bb
@@ -0,0 +1,41 @@
+PV = "0.0cvs${CVSDATE}"
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "popt binutils"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/oprofile;module=oprofile \
+ file://no_arm_mapping_syms.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/oprofile"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+ --without-x \
+ --disable-werror "
+
+do_configure () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+# Available config options
+# --enable-abi enable abi portability code (default is disabled)
+# --enable-pch enable precompiled header (default is disabled)
+# --enable-gcov enable option for gcov coverage testing (default is disabled)
+# --disable-werror disable -Werror flag (default is enabled for non-release)
+# --disable-optimization disable optimization flags (default is enabled)
+# --with-kernel-support Use 2.6 kernel (no kernel source tree required)
+# --with-linux=dir Path to Linux source tree
+# --with-module-dir=dir Path to module installation directory
+# --with-extra-includes=DIR add extra include paths
+# --with-extra-libs=DIR add extra library paths
+# --with-x use the X Window System
+# --with-qt-dir where the root of Qt is installed
+# --with-qt-includes where the Qt includes are.
+# --with-qt-libraries where the Qt library is installed.