summaryrefslogtreecommitdiff
path: root/openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-04 12:04:54 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-04 12:04:54 +0000
commit925c447a51ccc44f8b3697f6fe7397d906fe67f2 (patch)
tree0a4fe4added394518429536e19e435391eb16656 /openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb
parent46b6d82b5c309f12ad4fc69ce38c3aff0f4a11de (diff)
downloadopenembedded-core-925c447a51ccc44f8b3697f6fe7397d906fe67f2.tar.gz
openembedded-core-925c447a51ccc44f8b3697f6fe7397d906fe67f2.tar.bz2
openembedded-core-925c447a51ccc44f8b3697f6fe7397d906fe67f2.tar.xz
openembedded-core-925c447a51ccc44f8b3697f6fe7397d906fe67f2.zip
Updates from OE
git-svn-id: https://svn.o-hand.com/repos/poky@170 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb')
-rw-r--r--openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb23
1 files changed, 6 insertions, 17 deletions
diff --git a/openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb b/openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb
index 8093e7d24..e75924c19 100644
--- a/openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb
+++ b/openembedded/packages/orinoco/orinoco-modules_0.15rc2.bb
@@ -3,9 +3,11 @@ Also contains support for cards using downloadable firmware, i.e. the Symbol/Soc
SECTION = "kernel/modules"
PRIORITY = "optional"
PROVIDES = "spectrum-modules"
+DEPENDS = "orinoco-conf spectrum-fw"
+RDEPENDS = "orinoco-conf"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-PR = "r8"
+PR = "r9"
SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
file://makefile_fix.patch;patch=1 \
@@ -13,37 +15,24 @@ SRC_URI = "http://ozlabs.org/people/dgibson/dldwd/orinoco-${PV}.tar.gz \
file://add_utsname.patch;patch=1 \
file://add_event.patch;patch=1 \
file://spectrum_cs_ids.patch;patch=1 \
- file://spectrum-firmware.patch;patch=1 \
- file://catch-up-with-kernel-changes.patch;patch=1 \
- file://spectrum.conf \
- file://spectrum_fw.h \
- file://orinoco_cs.conf"
+ file://catch-up-with-kernel-changes.patch;patch=1"
S = "${WORKDIR}/orinoco-${PV}"
inherit module
-do_compile_prepend() {
- install ${WORKDIR}/spectrum_fw.h ${S}/
-}
-
do_install() {
install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
- install -d ${D}${sysconfdir}/pcmcia
install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
- install -m 0644 ${WORKDIR}/spectrum.conf ${D}${sysconfdir}/pcmcia/
- install -m 0644 hermes.conf ${D}${sysconfdir}/pcmcia/
- install -d ${D}${sysconfdir}/modutils
- install -m 0644 ${WORKDIR}/orinoco_cs.conf ${D}${sysconfdir}/modutils/
}
PACKAGES = "orinoco-modules-cs orinoco-modules-pci orinoco-modules-usb orinoco-modules-nortel orinoco-modules"
-FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX} /${sysconfdir}"
+FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"
FILES_orinoco-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/orinoco_p*${KERNEL_OBJECT_SUFFIX}"
FILES_orinoco-modules-usb = "/lib/modules/${KERNEL_VERSION}/net/*_usb${KERNEL_OBJECT_SUFFIX}"
FILES_orinoco-modules-nortel = "/lib/modules/${KERNEL_VERSION}/net/orinoco_tmd${KERNEL_OBJECT_SUFFIX} \
/lib/modules/${KERNEL_VERSION}/net/orinoco_nortel${KERNEL_OBJECT_SUFFIX}"
FILES_orinoco-modules = "/lib/modules/"
-RDEPENDS_orinoco-modules-cs = "orinoco-modules"
+RDEPENDS_orinoco-modules-cs = "orinoco-modules spectrum-fw"
RDEPENDS_orinoco-modules-pci = "orinoco-modules"
RDEPENDS_orinoco-modules-usb = "orinoco-modules"
RDEPENDS_orinoco-modules-nortel = "orinoco-modules"