summaryrefslogtreecommitdiff
path: root/openembedded/packages/pcmciautils
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-20 15:19:38 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-20 15:19:38 +0000
commit8d66edc4085db428e67223f0f71cde6b3640f27e (patch)
treeda9dcd13d59b36f7350d3938f9094cb2ecc4449a /openembedded/packages/pcmciautils
parentb4a7122cacef647dbec3db5c9ebe1e504a7670df (diff)
downloadopenembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.gz
openembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.bz2
openembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.xz
openembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.zip
pcmciautils and udev updates. Slowly aiming to get rid of hotplug and pcmcia-cs
git-svn-id: https://svn.o-hand.com/repos/poky@27 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/pcmciautils')
-rw-r--r--openembedded/packages/pcmciautils/pcmciautils_010.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/openembedded/packages/pcmciautils/pcmciautils_010.bb b/openembedded/packages/pcmciautils/pcmciautils_010.bb
new file mode 100644
index 000000000..f619a9823
--- /dev/null
+++ b/openembedded/packages/pcmciautils/pcmciautils_010.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
+DEPENDS = "sysfsutils udev"
+RDEPENDS = "udev"
+HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2"
+S = "${WORKDIR}/pcmciautils-${PV}"
+
+PR = "r1"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "coldplug"
+INITSCRIPT_PARAMS = "defaults"
+
+export HOSTCC = "${BUILD_CC}"
+export etcdir = "${sysconfdir}"
+export pcmciaconfdir = "${sysconfdir}/pcmcia"
+export udevrulesdir = "${sysconfdir}/udev/rules.d"
+export UDEV = 1
+LD = "${CC}"
+CFLAGS =+ "-I${S}/src"
+CFLAGS =+ '-DPCMCIAUTILS_VERSION=010'
+
+PARALLEL_MAKE = ""
+EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
+RCONFLICTS_${PN} += "pcmcia-cs"