summaryrefslogtreecommitdiff
path: root/openembedded/packages/rxvt-unicode/files
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-28 17:23:13 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-28 17:23:13 +0000
commitec2f15d43241fc17ad3dc2f76204e3b37fef6041 (patch)
tree82358f583fd9013fc8674d8142d42f263a21eb11 /openembedded/packages/rxvt-unicode/files
parentae628e564939adbe4475ffd0eda7ad340118add4 (diff)
downloadopenembedded-core-ec2f15d43241fc17ad3dc2f76204e3b37fef6041.tar.gz
openembedded-core-ec2f15d43241fc17ad3dc2f76204e3b37fef6041.tar.bz2
openembedded-core-ec2f15d43241fc17ad3dc2f76204e3b37fef6041.tar.xz
openembedded-core-ec2f15d43241fc17ad3dc2f76204e3b37fef6041.zip
Change to rxvt-unicode
git-svn-id: https://svn.o-hand.com/repos/poky@49 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/rxvt-unicode/files')
-rw-r--r--openembedded/packages/rxvt-unicode/files/makefile.patch20
-rw-r--r--openembedded/packages/rxvt-unicode/files/signedchar.patch11
-rw-r--r--openembedded/packages/rxvt-unicode/files/xwc.patch28
3 files changed, 59 insertions, 0 deletions
diff --git a/openembedded/packages/rxvt-unicode/files/makefile.patch b/openembedded/packages/rxvt-unicode/files/makefile.patch
new file mode 100644
index 000000000..86f82eeb4
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/files/makefile.patch
@@ -0,0 +1,20 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/Makefile.in 2004-08-12 22:32:40 +01:00
++++ rxvt-unicode/Makefile.in 2004-12-24 03:09:00 +00:00
+@@ -9,7 +9,7 @@
+ first_rule: all
+ dummy:
+
+-subdirs = src doc src/test
++subdirs = src src/test
+ allsubdirs = W11 $(subdirs)
+
+ DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
+@@ -24,7 +24,7 @@
+
+ #-------------------------------------------------------------------------
+
+-all allbin alldoc tags:
++all allbin tags:
+ @if test x@host_os@ = xcygwin; then (cd W11; ${MAKE} $@) || exit 1; fi
+ @for I in ${subdirs}; do (cd $$I; ${MAKE} $@) || exit 1; done
+
diff --git a/openembedded/packages/rxvt-unicode/files/signedchar.patch b/openembedded/packages/rxvt-unicode/files/signedchar.patch
new file mode 100644
index 000000000..6faa17514
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/files/signedchar.patch
@@ -0,0 +1,11 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/src/command.C 2004-12-21 06:43:00 +00:00
++++ rxvt-unicode/src/command.C 2004-12-24 02:31:36 +00:00
+@@ -1862,7 +1862,7 @@
+ #endif /* NO_SCROLLBAR_REPORT */
+
+ {
+- char upordown = 0;
++ signed char upordown = 0;
+
+ if (scrollBar.style == R_SB_NEXT)
+ {
diff --git a/openembedded/packages/rxvt-unicode/files/xwc.patch b/openembedded/packages/rxvt-unicode/files/xwc.patch
new file mode 100644
index 000000000..7cf59656c
--- /dev/null
+++ b/openembedded/packages/rxvt-unicode/files/xwc.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- rxvt-unicode-4.8/src/screen.C~xwc.c
++++ rxvt-unicode-4.8/src/screen.C
+@@ -3058,7 +3058,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3632,9 +3632,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (display->display, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;