summaryrefslogtreecommitdiff
path: root/openembedded/packages/udev/udev-070/flags.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-20 15:19:38 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-20 15:19:38 +0000
commit8d66edc4085db428e67223f0f71cde6b3640f27e (patch)
treeda9dcd13d59b36f7350d3938f9094cb2ecc4449a /openembedded/packages/udev/udev-070/flags.patch
parentb4a7122cacef647dbec3db5c9ebe1e504a7670df (diff)
downloadopenembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.gz
openembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.bz2
openembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.tar.xz
openembedded-core-8d66edc4085db428e67223f0f71cde6b3640f27e.zip
pcmciautils and udev updates. Slowly aiming to get rid of hotplug and pcmcia-cs
git-svn-id: https://svn.o-hand.com/repos/poky@27 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/udev/udev-070/flags.patch')
-rw-r--r--openembedded/packages/udev/udev-070/flags.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/openembedded/packages/udev/udev-070/flags.patch b/openembedded/packages/udev/udev-070/flags.patch
new file mode 100644
index 000000000..bd04041f7
--- /dev/null
+++ b/openembedded/packages/udev/udev-070/flags.patch
@@ -0,0 +1,70 @@
+--- udev-070/Makefile~flags 2005-09-15 01:19:07 +0200
++++ udev-070/Makefile 2005-09-16 11:44:37 +0200
+@@ -160,36 +160,36 @@
+ # check if compiler option is supported
+ cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi;}
+
+-CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
++override CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
+ -Wstrict-prototypes -Wsign-compare
+-CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
+-CFLAGS += -pipe
+-CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
++override CFLAGS += -pipe
++override CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+
+ # use '-Os' optimization if available, else use -O2
+ OPTFLAGS := $(call cc-supports, -Os, -O2)
+
+ # include our local copy of libsysfs
+-CFLAGS += -I$(PWD)/libsysfs/sysfs \
++override CFLAGS += -I$(PWD)/libsysfs/sysfs \
+ -I$(PWD)/libsysfs
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g -DDEBUG
++ override CFLAGS += -O1 -g -DDEBUG
+ LDFLAGS += -Wl
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+- CFLAGS += $(OPTFLAGS) -fomit-frame-pointer
++ override CFLAGS += $(OPTFLAGS) -fomit-frame-pointer
+ LDFLAGS += -s -Wl
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS = -fprofile-arcs
+ endif
+
+@@ -200,18 +200,18 @@
+ CC = $(KLCC)
+ LD = $(KLCC)
+ else
+- CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
++ override CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ LDFLAGS += -Wl,-warn-common
+ endif
+
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+