summaryrefslogtreecommitdiff
path: root/openembedded/packages/udev/udev-071
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-01 22:23:22 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-01 22:23:22 +0000
commit5de252ff87d5a21134bb05d1a55a79efb241c581 (patch)
tree8f6c229f86ca0dc5e269fde3f205325f27685973 /openembedded/packages/udev/udev-071
parent3ddb2123cf3813980ffdcab453e14a020724dfea (diff)
downloadopenembedded-core-5de252ff87d5a21134bb05d1a55a79efb241c581.tar.gz
openembedded-core-5de252ff87d5a21134bb05d1a55a79efb241c581.tar.bz2
openembedded-core-5de252ff87d5a21134bb05d1a55a79efb241c581.tar.xz
openembedded-core-5de252ff87d5a21134bb05d1a55a79efb241c581.zip
udev: Upgrade to 071 - fixes /dev/input problem with -git3 kernel
git-svn-id: https://svn.o-hand.com/repos/poky@156 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/udev/udev-071')
-rw-r--r--openembedded/packages/udev/udev-071/flags.patch72
-rw-r--r--openembedded/packages/udev/udev-071/noasmlinkage.patch38
-rw-r--r--openembedded/packages/udev/udev-071/tty-symlinks.patch13
3 files changed, 123 insertions, 0 deletions
diff --git a/openembedded/packages/udev/udev-071/flags.patch b/openembedded/packages/udev/udev-071/flags.patch
new file mode 100644
index 000000000..cb1733621
--- /dev/null
+++ b/openembedded/packages/udev/udev-071/flags.patch
@@ -0,0 +1,72 @@
+Index: udev-071/Makefile
+===================================================================
+--- udev-071.orig/Makefile 2005-10-19 23:28:34.000000000 +0100
++++ udev-071/Makefile 2005-11-01 22:04:31.000000000 +0000
+@@ -160,36 +160,36 @@
+ # check if compiler option is supported
+ cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi;}
+
+-CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
++override CFLAGS += -Wall -fno-builtin -Wchar-subscripts -Wpointer-arith \
+ -Wstrict-prototypes -Wsign-compare
+-CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
+-CFLAGS += -pipe
+-CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS += $(call cc-supports, -Wdeclaration-after-statement, )
++override CFLAGS += -pipe
++override CFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+
+ # use '-Os' optimization if available, else use -O2
+ OPTFLAGS := $(call cc-supports, -Os, -O2)
+
+ # include our local copy of libsysfs
+-CFLAGS += -I$(PWD)/libsysfs/sysfs \
++override CFLAGS += -I$(PWD)/libsysfs/sysfs \
+ -I$(PWD)/libsysfs
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip or optimize
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -O1 -g -DDEBUG
++ override CFLAGS += -O1 -g -DDEBUG
+ LDFLAGS += -Wl
+ STRIPCMD = /bin/true -Since_we_are_debugging
+ else
+- CFLAGS += $(OPTFLAGS) -fomit-frame-pointer
++ override CFLAGS += $(OPTFLAGS) -fomit-frame-pointer
+ LDFLAGS += -s -Wl
+ STRIPCMD = $(STRIP) -s --remove-section=.note --remove-section=.comment
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS = -fprofile-arcs
+ endif
+
+@@ -200,18 +200,18 @@
+ CC = $(KLCC)
+ LD = $(KLCC)
+ else
+- CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
++ override CFLAGS += -Wshadow -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+ LDFLAGS += -Wl,-warn-common
+ endif
+
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+
diff --git a/openembedded/packages/udev/udev-071/noasmlinkage.patch b/openembedded/packages/udev/udev-071/noasmlinkage.patch
new file mode 100644
index 000000000..0d8e854c0
--- /dev/null
+++ b/openembedded/packages/udev/udev-071/noasmlinkage.patch
@@ -0,0 +1,38 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udev-062/udev.c~noasmlinkage.patch
++++ udev-062/udev.c
+@@ -54,7 +54,7 @@
+ }
+ #endif
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ switch (signum) {
+ case SIGALRM:
+--- udev-062/udevd.c~noasmlinkage.patch
++++ udev-062/udevd.c
+@@ -639,7 +639,7 @@
+ return msg;
+ }
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ int rc;
+
+--- udev-062/udevstart.c~noasmlinkage.patch
++++ udev-062/udevstart.c
+@@ -323,7 +323,7 @@
+ exec_list(&device_list);
+ }
+
+-static void asmlinkage sig_handler(int signum)
++static void sig_handler(int signum)
+ {
+ switch (signum) {
+ case SIGALRM:
diff --git a/openembedded/packages/udev/udev-071/tty-symlinks.patch b/openembedded/packages/udev/udev-071/tty-symlinks.patch
new file mode 100644
index 000000000..28bdf92af
--- /dev/null
+++ b/openembedded/packages/udev/udev-071/tty-symlinks.patch
@@ -0,0 +1,13 @@
+--- udev-068/etc/udev/udev-devfs.rules.orig 2005-08-22 20:22:18.000000000 +0200
++++ udev-068/etc/udev/udev-devfs.rules 2005-08-22 20:22:44.000000000 +0200
+@@ -14,8 +14,8 @@
+ KERNEL="fd[0-9]*", NAME="floppy/%n"
+
+ # tty devices
+-KERNEL="tty[0-9]*", NAME="vc/%n"
+-KERNEL="ttyS[0-9]*", NAME="tts/%n"
++KERNEL="tty[0-9]*", NAME="vc/%n", SYMLINK="%k"
++KERNEL="ttyS[0-9]*", NAME="tts/%n", SYMLINK="%k"
+ KERNEL="ttyUSB[0-9]*", NAME="tts/USB%n"
+
+ # vc devices