summaryrefslogtreecommitdiff
path: root/openembedded/packages/udev/udev-084/flags.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-02-03 09:02:41 +0000
committerRichard Purdie <richard@openedhand.com>2006-02-03 09:02:41 +0000
commit4a64818533733e194138a45656aaf14d5a123e98 (patch)
tree79925075659d01f3b148e4267138ee6e8de91789 /openembedded/packages/udev/udev-084/flags.patch
parentbc4e7ed8993d3f598e5c03b78838bbc6199413ba (diff)
downloadopenembedded-core-4a64818533733e194138a45656aaf14d5a123e98.tar.gz
openembedded-core-4a64818533733e194138a45656aaf14d5a123e98.tar.bz2
openembedded-core-4a64818533733e194138a45656aaf14d5a123e98.tar.xz
openembedded-core-4a64818533733e194138a45656aaf14d5a123e98.zip
Update to udev 084 from OE. This adds a coldplug script to emulate the calls necessary to load devices already inserted into the system at boot. It also adds a network interface control script.
git-svn-id: https://svn.o-hand.com/repos/poky@247 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/udev/udev-084/flags.patch')
-rw-r--r--openembedded/packages/udev/udev-084/flags.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/openembedded/packages/udev/udev-084/flags.patch b/openembedded/packages/udev/udev-084/flags.patch
new file mode 100644
index 000000000..f144a5f62
--- /dev/null
+++ b/openembedded/packages/udev/udev-084/flags.patch
@@ -0,0 +1,52 @@
+--- udev-081/Makefile.orig 2006-01-29 12:36:33.000000000 +0100
++++ udev-081/Makefile 2006-01-29 12:36:58.000000000 +0100
+@@ -123,29 +123,29 @@
+ STRIP = $(CROSS)strip
+ STRIPCMD = $(STRIP) -s
+
+-CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++override CFLAGS = -g -Wall -pipe -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ WARNINGS = -Wstrict-prototypes -Wsign-compare -Wshadow \
+ -Wchar-subscripts -Wmissing-declarations -Wnested-externs \
+ -Wpointer-arith -Wcast-align -Wsign-compare -Wmissing-prototypes
+-CFLAGS += $(WARNINGS)
++override CFLAGS += $(WARNINGS)
+
+ LDFLAGS = -Wl,-warn-common
+
+ OPTFLAGS = -Os
+-CFLAGS += $(OPTFLAGS)
++override CFLAGS += $(OPTFLAGS)
+
+ ifeq ($(strip $(USE_LOG)),true)
+- CFLAGS += -DUSE_LOG
++ override CFLAGS += -DUSE_LOG
+ endif
+
+ # if DEBUG is enabled, then we do not strip
+ ifeq ($(strip $(DEBUG)),true)
+- CFLAGS += -DDEBUG
++ override CFLAGS += -DDEBUG
+ STRIPCMD =
+ endif
+
+ ifeq ($(strip $(USE_GCOV)),true)
+- CFLAGS += -fprofile-arcs -ftest-coverage
++ override CFLAGS += -fprofile-arcs -ftest-coverage
+ LDFLAGS += -fprofile-arcs
+ endif
+
+@@ -160,11 +160,11 @@
+ ifeq ($(strip $(USE_SELINUX)),true)
+ UDEV_OBJS += udev_selinux.o
+ LIB_OBJS += -lselinux -lsepol
+- CFLAGS += -DUSE_SELINUX
++ override CFLAGS += -DUSE_SELINUX
+ endif
+
+ ifeq ($(strip $(USE_STATIC)),true)
+- CFLAGS += -DUSE_STATIC
++ override CFLAGS += -DUSE_STATIC
+ LDFLAGS += -static
+ endif
+