summaryrefslogtreecommitdiff
path: root/openembedded/packages
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-04 20:19:30 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-04 20:19:30 +0000
commit81b93eb2ed7eb493d3da664bf7b4d6b3178fe535 (patch)
tree1bd7babc2bdd39a99340d6f458f720a8acda7611 /openembedded/packages
parent38a06013d777588bd40cacc16d354e62caa3e6ab (diff)
downloadopenembedded-core-81b93eb2ed7eb493d3da664bf7b4d6b3178fe535.tar.gz
openembedded-core-81b93eb2ed7eb493d3da664bf7b4d6b3178fe535.tar.bz2
openembedded-core-81b93eb2ed7eb493d3da664bf7b4d6b3178fe535.tar.xz
openembedded-core-81b93eb2ed7eb493d3da664bf7b4d6b3178fe535.zip
packages/meta: Make sdk its own target (oh-image-sdk), refine the oh-image-devel package
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@501 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/meta/oh-image-devel.bb11
-rw-r--r--openembedded/packages/meta/oh-image-sdk.bb27
-rw-r--r--openembedded/packages/meta/task-oh.bb40
3 files changed, 55 insertions, 23 deletions
diff --git a/openembedded/packages/meta/oh-image-devel.bb b/openembedded/packages/meta/oh-image-devel.bb
index 04016f55e..2865151b0 100644
--- a/openembedded/packages/meta/oh-image-devel.bb
+++ b/openembedded/packages/meta/oh-image-devel.bb
@@ -6,18 +6,15 @@ GUI_MACHINE_CLASS ?= "none"
XSERVER ?= "xserver-kdrive-fbdev"
-DEPENDS = "\
- task-bootstrap \
- task-oh \
- task-oh-sdk"
-
+DEPENDS = "task-oh"
+
RDEPENDS = "\
task-oh-boot \
task-oh-boot-extras \
task-oh-base \
task-oh-standard \
- task-oh-devel \
- task-oh-sdk \
+ task-oh-devtools \
+ task-oh-testapps \
${XSERVER} "
export IPKG_INSTALL = "${RDEPENDS}"
diff --git a/openembedded/packages/meta/oh-image-sdk.bb b/openembedded/packages/meta/oh-image-sdk.bb
new file mode 100644
index 000000000..b5dfee740
--- /dev/null
+++ b/openembedded/packages/meta/oh-image-sdk.bb
@@ -0,0 +1,27 @@
+PR = "r9"
+
+export IMAGE_BASENAME = "oh-sdk"
+
+GUI_MACHINE_CLASS ?= "none"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+DEPENDS = "\
+ task-oh \
+ task-oh-sdk"
+
+RDEPENDS = "\
+ task-oh-boot \
+ task-oh-boot-extras \
+ task-oh-base \
+ task-oh-standard \
+ task-oh-devtools \
+ task-oh-testapps \
+ task-oh-sdk \
+ ${XSERVER} "
+
+export IPKG_INSTALL = "${RDEPENDS}"
+#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+
+inherit image_ipk
+LICENSE = MIT
diff --git a/openembedded/packages/meta/task-oh.bb b/openembedded/packages/meta/task-oh.bb
index 41dc4e510..aa88f45e1 100644
--- a/openembedded/packages/meta/task-oh.bb
+++ b/openembedded/packages/meta/task-oh.bb
@@ -1,7 +1,15 @@
-PACKAGES = "task-oh-base task-oh-devel task-oh-boot task-oh-standard task-oh-boot-extras task-oh-boot-min-extras"
DESCRIPTION = "Tasks for OpenedHand Poky"
MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r36"
+PR = "r37"
+
+PACKAGES = "\
+ task-oh-base \
+ task-oh-boot \
+ task-oh-standard \
+ task-oh-boot-extras \
+ task-oh-boot-min-extras \
+ task-oh-devtools \
+ task-oh-testapps"
ALLOW_EMPTY = "1"
@@ -92,24 +100,24 @@ RDEPENDS_task-oh-standard_append_akita = " zaurusd "
PACKAGE_ARCH_task-oh-standard = "${MACHINE_ARCH}"
-# minimo \
-# teleport \
-# xst \
-# libgtkstylus \
-# detect-stylus \
-# xrdb \
-
-
-RDEPENDS_task-oh-devel = "\
- tslib-calibrate \
- tslib-tests \
+RDEPENDS_task-oh-devtools = "\
oprofile \
gdb \
strace \
lttng-viewer"
-
-RRECOMMENDS_task-oh-devel = "\
+RRECOMMENDS_task-oh-devtools = "\
kernel-module-oprofile"
-# lttng-modules
+RDEPENDS_task-oh-testapps = "\
+ tslib-calibrate \
+ tslib-tests \
+ lrzsz \
+ alsa-utils-amixer \
+ alsa-utils-aplay"
+
+# minimo \
+# teleport \
+# xst \
+# libgtkstylus \
+# xrdb \